aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 03:58:52 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 03:58:52 +0000
commitbaa26c1b4da96049f0a4995d2103a37b38a15ac9 (patch)
tree9b754f1d113e54ec95e7f620942e268e964b5786 /emulators
parentfb3f49d7410298270f9b4502eaa98c90d65764d1 (diff)
downloadports-baa26c1b4da96049f0a4995d2103a37b38a15ac9.tar.gz
ports-baa26c1b4da96049f0a4995d2103a37b38a15ac9.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64-gln64/Makefile46
-rw-r--r--emulators/mupen64-gln64/distinfo3
-rw-r--r--emulators/mupen64-gln64/files/patch-Combiner.cpp11
-rw-r--r--emulators/mupen64-gln64/files/patch-Makefile21
-rw-r--r--emulators/mupen64-gln64/files/patch-glN64_Config_linux.cpp40
-rw-r--r--emulators/mupen64-gln64/files/patch-winlnxdefs.h24
-rw-r--r--emulators/mupen64-gln64/pkg-descr15
-rw-r--r--emulators/mupen64-gln64/pkg-message9
-rw-r--r--emulators/mupen64-sdlaudio/Makefile41
-rw-r--r--emulators/mupen64-sdlaudio/distinfo3
-rw-r--r--emulators/mupen64-sdlaudio/files/patch-Makefile18
-rw-r--r--emulators/mupen64-sdlaudio/pkg-descr15
-rw-r--r--emulators/mupen64-sdlaudio/pkg-message9
13 files changed, 54 insertions, 201 deletions
diff --git a/emulators/mupen64-gln64/Makefile b/emulators/mupen64-gln64/Makefile
index e17940352e90..19823e9bb693 100644
--- a/emulators/mupen64-gln64/Makefile
+++ b/emulators/mupen64-gln64/Makefile
@@ -7,50 +7,20 @@
PORTNAME= mupen64
PORTVERSION= 0.4.1
-PORTREVISION= 3
-CATEGORIES+= emulators
-MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PORTREVISION= 4
PKGNAMESUFFIX= -gln64
-DISTNAME= glN64-${PORTVERSION}-rc2
-MAINTAINER?= tlp@LiquidX.org
-COMMENT= GlN64 graphics plugin for Mupen64
+COMMENT= The glN64 graphics plugin for Mupen64
-USE_BZIP2= yes
-USE_GMAKE= yes
+USE_GL= yes
USE_SDL= sdl
-USE_GL= gl
-USE_GNOME= gtk12
-USE_GCC= 3.4
-ONLY_FOR_ARCHS= i386
-PLUGIN_NAME= glN64-${PORTVERSION}
-PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
-PLIST_DIRS= share/mupen64/plugins
-PLIST_DIRS+= share/mupen64
+FIXFILES= glN64/DepthBuffer.cpp
-ALL_TARGET= ${PLUGIN_NAME}.so
+PLUGIN_NAME= glN64
-post-patch:
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/DepthBuffer.cpp
+MASTERDIR= ${.CURDIR}/../mupen64-base
-do-install:
- @${MKDIR} ${PREFIX}/share/mupen64/plugins
- ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
- ${PREFIX}/share/mupen64/plugins/
+OPTIONS= #
-.include <bsd.port.pre.mk>
-
-CFLAGS+= -I. -D__LINUX__ -D__USE_GNU `${SDL_CONFIG} --cflags`
-CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags gtk gthread` `${GLIB_CONFIG} --cflags` -fPIC
-CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -finline-functions -Wall -pipe
-CFLAGS+= -DX86_ASM -mcpu=athlon
-LDFLAGS+= -shared -Wl,-Bsymbolic
-LDFLAGS+= `${SDL_CONFIG} --libs` `${GTK_CONFIG} --libs gtk gthread` `${GLIB_CONFIG} --libs` -lGL -lGLU
-
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64-gln64/distinfo b/emulators/mupen64-gln64/distinfo
deleted file mode 100644
index 7c243ee5fd44..000000000000
--- a/emulators/mupen64-gln64/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (glN64-0.4.1-rc2.tar.bz2) = 0cb22a6bce17723a18ab0b16118eb37a
-SHA256 (glN64-0.4.1-rc2.tar.bz2) = 6e52e47c127309561da53168c3312db39ec96e3403d0810ac81d38d5fa3ef326
-SIZE (glN64-0.4.1-rc2.tar.bz2) = 137423
diff --git a/emulators/mupen64-gln64/files/patch-Combiner.cpp b/emulators/mupen64-gln64/files/patch-Combiner.cpp
deleted file mode 100644
index b9545cf967c1..000000000000
--- a/emulators/mupen64-gln64/files/patch-Combiner.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Combiner.cpp.orig Tue Sep 21 16:59:01 2004
-+++ Combiner.cpp Tue Sep 21 16:59:37 2004
-@@ -348,7 +348,7 @@
- void Combiner_SelectCombine( u64 mux )
- {
- // Hack for the Banjo-Tooie shadow (framebuffer textures must be enabled too)
-- if ((gDP.otherMode.cycleType == G_CYC_1CYCLE) && (mux == 0x00ffe7ffffcf9fcf) && (cache.current[0]->frameBufferTexture))
-+ if ((gDP.otherMode.cycleType == G_CYC_1CYCLE) && (mux == 0x00ffe7ffffcf9fcfLL) && (cache.current[0]->frameBufferTexture))
- {
- mux = EncodeCombineMode( 0, 0, 0, 0, TEXEL0, 0, PRIMITIVE, 0,
- 0, 0, 0, 0, TEXEL0, 0, PRIMITIVE, 0 );
diff --git a/emulators/mupen64-gln64/files/patch-Makefile b/emulators/mupen64-gln64/files/patch-Makefile
deleted file mode 100644
index 7d61968c4097..000000000000
--- a/emulators/mupen64-gln64/files/patch-Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.orig Sat Jul 3 22:34:59 2004
-+++ Makefile Thu Aug 12 16:48:48 2004
-@@ -1,13 +1,13 @@
- DEFINES = -D__LINUX__ -DX86_ASM
--CXX = g++
--CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `gtk-config --cflags gtk gthread` \
-+#CXX = g++
-+#CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `gtk-config --cflags gtk gthread` \
- `glib-config --cflags` -finline-functions -funroll-loops \
- -ffast-math -fomit-frame-pointer -mcpu=`uname -m` -O3
- #CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `gtk-config --cflags gtk gthread` \
- # `glib-config --cflags` -g3 #-DDEBUG
--LD = g++
--LDFLAGS = -shared -Wl,-Bsymbolic
--LIBS = `sdl-config --libs` `gtk-config --libs gtk gthread` `glib-config --libs` -lGL -lGLU
-+#LD = g++
-+#LDFLAGS = -shared -Wl,-Bsymbolic
-+#LIBS = `sdl-config --libs` `gtk-config --libs gtk gthread` `glib-config --libs` -lGL -lGLU
- TARGET = glN64-0.4.1.so
- OBJECTS = 2xSAI.o \
- CRC.o \
diff --git a/emulators/mupen64-gln64/files/patch-glN64_Config_linux.cpp b/emulators/mupen64-gln64/files/patch-glN64_Config_linux.cpp
new file mode 100644
index 000000000000..8a2785c2e8ec
--- /dev/null
+++ b/emulators/mupen64-gln64/files/patch-glN64_Config_linux.cpp
@@ -0,0 +1,40 @@
+--- glN64/Config_linux.cpp 2005-08-26 14:52:17.000000000 -0500
++++ glN64/Config_linux.cpp 2007-10-08 03:14:27.000000000 -0500
+@@ -1,4 +1,3 @@
+-#include <features.h>
+ #include <dlfcn.h>
+ #include <unistd.h>
+ #include "../main/winlnxdefs.h"
+@@ -35,29 +34,9 @@
+ {
+ static char path[PATH_MAX];
+
+-#ifdef __USE_GNU
+- Dl_info info;
+- void *addr = (void*)GetPluginDir;
+- if(dladdr(addr, &info) != 0)
+- {
+- strncpy(path, info.dli_fname, PATH_MAX);
+- *(strrchr(path, '/')) = '\0';
+- }
+- else
+- {
+- fprintf(stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n");
+-#endif // __USE_GNU
+- if(readlink("/proc/self/exe", path, PATH_MAX) == -1)
+- {
+- fprintf(stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror(errno));
+- path[0] = '.';
+- path[1] = '\0';
+- }
+- *(strrchr(path, '/')) = '\0';
+- strncat(path, "/plugins", PATH_MAX);
+-#ifdef __USE_GNU
+- }
+-#endif
++ strcpy(path, getenv("HOME"));
++ strncat(path, "/.mupen64/plugins", PATH_MAX);
++
+ return path;
+ }
+
diff --git a/emulators/mupen64-gln64/files/patch-winlnxdefs.h b/emulators/mupen64-gln64/files/patch-winlnxdefs.h
deleted file mode 100644
index 2ff16f96000e..000000000000
--- a/emulators/mupen64-gln64/files/patch-winlnxdefs.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- winlnxdefs.h.orig Thu Oct 16 01:01:08 2003
-+++ winlnxdefs.h Wed Sep 22 05:32:54 2004
-@@ -30,7 +30,9 @@
- #ifndef WINLNXDEFS_H
- #define WINLNXDEFS_H
-
-+#ifndef __FreeBSD__
- #include <features.h> // we want GNU extensions
-+#endif
- #include <dlfcn.h>
- #include <errno.h>
- #include <limits.h> // PATH_MAX
-@@ -113,7 +115,11 @@
- {
- fprintf( stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n" );
- #endif // __USE_GNU
-+#ifndef __FreeBSD__
- if (readlink( "/proc/self/exe", path, PATH_MAX ) == -1)
-+#else
-+ if (readlink( "/proc/curproc/file", path, PATH_MAX ) == -1)
-+#endif // __FreeBSD__
- {
- fprintf( stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror( errno ) );
- path[0] = '.';
diff --git a/emulators/mupen64-gln64/pkg-descr b/emulators/mupen64-gln64/pkg-descr
deleted file mode 100644
index a016fd024232..000000000000
--- a/emulators/mupen64-gln64/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-glN64 graphics plugin for Mupen64
--
-Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
-on/for Linux originally but has already been ported successfully to other
-operating systems. The program can easily be ported to all operating systems
-supported by the SDL library.
-
-In its current state, the emulator is highly compatible and uses a plugin
-system. With the correct plugins ("correct" can be computer dependent), it
-can achieve nearly perfect graphics and sound in many games.
-
-WWW: http://mupen64.emulation64.com/
-
-- Travis Poppe
-tlp@liquidx.org
diff --git a/emulators/mupen64-gln64/pkg-message b/emulators/mupen64-gln64/pkg-message
deleted file mode 100644
index d53470396a22..000000000000
--- a/emulators/mupen64-gln64/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
--------------------------------------------------------------------------------
-If you have installed/upgraded any new plugins or are upgrading from a previous
-version of Mupen64, please note that in order for these changes to take effect,
-you -must- backup and then remove ~/.mupen64 first. After you have removed the
-directory, run 'mupen64' to re-create it. Then, manually copy back your save
-files/other data you need from the backup if necessary.
-
-Enjoy!
--------------------------------------------------------------------------------
diff --git a/emulators/mupen64-sdlaudio/Makefile b/emulators/mupen64-sdlaudio/Makefile
index 9a64ec54b63f..8792d362bc8a 100644
--- a/emulators/mupen64-sdlaudio/Makefile
+++ b/emulators/mupen64-sdlaudio/Makefile
@@ -5,49 +5,20 @@
# $FreeBSD$
#
-PORTNAME= mupen64
PORTVERSION= 1.2
-PORTREVISION= 3
-CATEGORIES+= emulators
-MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PORTREVISION= 4
PKGNAMESUFFIX= -sdlaudio
-DISTNAME= jttl_sound-${PORTVERSION}
-MAINTAINER?= tlp@LiquidX.org
COMMENT= JttL's SDL audio plugin for Mupen64
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_SDL= sdl
-USE_GNOME= gtk12
-USE_GCC= 3.4
-ONLY_FOR_ARCHS= i386
-PLUGIN_NAME= jttl_audio
-PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
-PLIST_FILES+= share/mupen64/jttl_audio.conf
-PLIST_DIRS= share/mupen64/plugins
-PLIST_DIRS+= share/mupen64
-
-do-install:
- @${MKDIR} ${PREFIX}/share/mupen64/plugins
- ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
- ${PREFIX}/share/mupen64/plugins/
- ${INSTALL_DATA} ${WRKSRC}/${PLUGIN_NAME}.conf \
- ${PREFIX}/share/mupen64/${PLUGIN_NAME}.conf
+FIXFILES= #
-.include <bsd.port.pre.mk>
-
-CFLAGS+= `${SDL_CONFIG} --cflags`
-CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
-CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
-CFLAGS+= -DX86 -mcpu=athlon
-LDFLAGS+= -shared -Wl,-Bsymbolic `${GTK_CONFIG} --libs` -lm
-LDFLAGS+= `${SDL_CONFIG} --libs` -lc
+PLUGIN_NAME= jttl_audio
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
+MASTERDIR= ${.CURDIR}/../mupen64-base
-post-install:
- @${CAT} ${PKGMESSAGE}
+OPTIONS= #
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64-sdlaudio/distinfo b/emulators/mupen64-sdlaudio/distinfo
deleted file mode 100644
index fa4462e90d97..000000000000
--- a/emulators/mupen64-sdlaudio/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (jttl_sound-1.2.tar.bz2) = 7bb104cf6ca94c0e761027eb9895fcbe
-SHA256 (jttl_sound-1.2.tar.bz2) = bc113e193c32729b2b0f9e9b7b0059bad0504c2aa41335d68d9b0fe1f2e5d422
-SIZE (jttl_sound-1.2.tar.bz2) = 10015
diff --git a/emulators/mupen64-sdlaudio/files/patch-Makefile b/emulators/mupen64-sdlaudio/files/patch-Makefile
deleted file mode 100644
index eaf2a4ef8b6e..000000000000
--- a/emulators/mupen64-sdlaudio/files/patch-Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.orig Sun Mar 28 20:09:45 2004
-+++ Makefile Thu Aug 12 15:25:07 2004
-@@ -1,11 +1,11 @@
--CC = gcc
-+#CC = gcc
- #CFLAGS = -g -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags` -lm `sdl-config --libs`
--CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags`
-+#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags`
-
- #CFLAGS = -g -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
-
--LD = gcc
--LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread -lm `sdl-config --libs`
-+#LD = gcc
-+#LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread -lm `sdl-config --libs`
-
- OBJECTS = main.o
-
diff --git a/emulators/mupen64-sdlaudio/pkg-descr b/emulators/mupen64-sdlaudio/pkg-descr
deleted file mode 100644
index 8522e9606191..000000000000
--- a/emulators/mupen64-sdlaudio/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-JttL SDL sound plugin for Mupen64
--
-Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
-on/for Linux originally but has already been ported successfully to other
-operating systems. The program can easily be ported to all operating systems
-supported by the SDL library.
-
-In its current state, the emulator is highly compatible and uses a plugin
-system. With the correct plugins ("correct" can be computer dependent), it
-can achieve nearly perfect graphics and sound in many games.
-
-WWW: http://mupen64.emulation64.com/
-
-- Travis Poppe
-tlp@liquidx.org
diff --git a/emulators/mupen64-sdlaudio/pkg-message b/emulators/mupen64-sdlaudio/pkg-message
deleted file mode 100644
index d53470396a22..000000000000
--- a/emulators/mupen64-sdlaudio/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
--------------------------------------------------------------------------------
-If you have installed/upgraded any new plugins or are upgrading from a previous
-version of Mupen64, please note that in order for these changes to take effect,
-you -must- backup and then remove ~/.mupen64 first. After you have removed the
-directory, run 'mupen64' to re-create it. Then, manually copy back your save
-files/other data you need from the backup if necessary.
-
-Enjoy!
--------------------------------------------------------------------------------