aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2014-12-28 20:39:48 +0000
committerDavid Naylor <dbn@FreeBSD.org>2014-12-28 20:39:48 +0000
commit33c9b1b9f7edc3409f8d20790e8a9602580503ed (patch)
tree6669e177b253f20e1b53b822b5e571ab184d52fd /emulators
parentd5b6b4643f4ba6de6332ce8391b1ed9b010e3150 (diff)
downloadports-33c9b1b9f7edc3409f8d20790e8a9602580503ed.tar.gz
ports-33c9b1b9f7edc3409f8d20790e8a9602580503ed.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-compholio/Makefile2
-rw-r--r--emulators/i386-wine-devel/Makefile.i3863
-rw-r--r--emulators/i386-wine-devel/files/nvidia.sh10
-rw-r--r--emulators/wine-compholio/Makefile3
-rw-r--r--emulators/wine-devel/Makefile5
5 files changed, 17 insertions, 6 deletions
diff --git a/emulators/i386-wine-compholio/Makefile b/emulators/i386-wine-compholio/Makefile
index ebe98267fa48..5caabadea5ac 100644
--- a/emulators/i386-wine-compholio/Makefile
+++ b/emulators/i386-wine-compholio/Makefile
@@ -5,7 +5,7 @@ COMMENT= 32bit Wine built with the compholio patchset for 64bit FreeBSD
SLAVE_PORT= i386-wine-devel
-CONFLICTS= i386-wine-[0-9]* wine-[0-9]* wine-compholio-[0-9]* i386-wine-devel-[0-9]* wine-devel-[0-9]*
+CONFLICTS_INSTALL= i386-wine-[0-9]* wine-[0-9]* wine-compholio-[0-9]* i386-wine-devel-[0-9]* wine-devel-[0-9]*
OPTIONS_SET= COMPHOLIO LIBXSLT GNUTLS HAL X11
diff --git a/emulators/i386-wine-devel/Makefile.i386 b/emulators/i386-wine-devel/Makefile.i386
index 949ba3a3aff8..4812c6774603 100644
--- a/emulators/i386-wine-devel/Makefile.i386
+++ b/emulators/i386-wine-devel/Makefile.i386
@@ -14,7 +14,8 @@ PKGDEINSTALL= ${PKGINSTALL}
RUN_DEPENDS= dri>0:${PORTSDIR}/graphics/dri
-CONFLICTS_INSTALLi?= i386-wine-[0-9]* wine-[0-9]* wine-devel-[0-9]*
+CONFLICTS_INSTALL?= wine-[0-9]* wine-compholio-[0-9]* wine-devel-[0-9]* \
+ i386-wine-[0-9]* i386-wine-compholio-[0-9]*
ACTUAL-PACKAGE-DEPENDS= ${DO_NADA}
WINELIBDIR= ${PREFIX}/lib32
diff --git a/emulators/i386-wine-devel/files/nvidia.sh b/emulators/i386-wine-devel/files/nvidia.sh
index 94a06b9aefea..77bc58d84618 100644
--- a/emulators/i386-wine-devel/files/nvidia.sh
+++ b/emulators/i386-wine-devel/files/nvidia.sh
@@ -65,6 +65,9 @@
# - add detection for i386-wine-devel
# Version 1.13 - 2014/08/05
# - add detection for i386-wine-compholio
+# Version 1.14 - 2014/12/26
+# - gracefully handle a corrupt nVidia tarball
+# - provide checksum and size information for nVidia tarball
set -e
@@ -163,13 +166,18 @@ echo "=> Detected nvidia-driver: ${NV}"
NVIDIA=${NV}
NV=`echo ${NV} | cut -f 1 -d _ | cut -f 1 -d ,`
-if [ ! -f NVIDIA-FreeBSD-x86-${NV}.tar.gz ]
+if [ ! -f NVIDIA-FreeBSD-x86-${NV}.tar.gz ] || !(tar -tf NVIDIA-FreeBSD-x86-${NV}.tar.gz > /dev/null 2>&1)
then
[ -n "$NO_FETCH" ] \
&& terminate 8 "NVIDIA-FreeBSD-x86-${NV}.tar.gz unavailable"
echo "=> Downloading NVIDIA-FreeBSD-x86-${NV}.tar.gz from ftp://download.nvidia.com..."
+ rm -f NVIDIA-FreeBSD-x86-${NV}.tar.gz
fetch -apRr ftp://download.nvidia.com/XFree86/FreeBSD-x86/${NV}/NVIDIA-FreeBSD-x86-${NV}.tar.gz \
|| terminate 2 "Failed to download NVIDIA-FreeBSD-x86-${NV}.tar.gz"
+ echo "=> Downloaded NVIDIA-FreeBSD-x86-${NV}.tar.gz"
+ echo "Please check the following information against /usr/ports/x11/nvidia-driver/distinfo"
+ sha256 NVIDIA-FreeBSD-x86-${NV}.tar.gz
+ echo "SIZE (NVIDIA-FreeBSD-x86-${NV}.tar.gz) = `stat -f "%z" NVIDIA-FreeBSD-x86-${NV}.tar.gz`"
fi
echo "=> Extracting NVIDIA-FreeBSD-x86-${NV}.tar.gz to $PREFIX/lib32..."
diff --git a/emulators/wine-compholio/Makefile b/emulators/wine-compholio/Makefile
index bcbb3dafc258..65b2a5dc6b3d 100644
--- a/emulators/wine-compholio/Makefile
+++ b/emulators/wine-compholio/Makefile
@@ -5,7 +5,8 @@ COMMENT= Wine built with the compholio patchset
SLAVE_PORT= wine-devel
-CONFLICTS= wine-[0-9]* wine-devel-[0-9]*
+CONFLICTS_INSTALL= wine-[0-9]* wine-devel-[0-9]* i386-wine-[0-9]* \
+ i386-wine-compholio-[0-9]* i386-wine-devel-[0-9]*
OPTIONS_SET= COMPHOLIO LIBXSLT MPG123 GNUTLS HAL V4L X11
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 3985f2cb27fc..0e924151b492 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wine
DISTVERSION= 1.7.33
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -22,7 +22,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
prelink:${PORTSDIR}/sysutils/prelink
LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
-CONFLICTS_INSTALL= i386-wine-[0-9]* i386-wine-devel-[0-9]* wine-[0-9]*
+CONFLICTS_INSTALL= wine-[0-9]* wine-compholio-[0-9]* i386-wine-[0-9]* \
+ i386-wine-compholio-[0-9]* i386-wine-devel-[0-9]*
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib