aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 08:02:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 08:02:49 +0000
commit33dfe3dc81041cb09da76f3a0c33c276bbac58d3 (patch)
tree1d18a65ede60be73ff6e92c59db38a9b30c5aaa2 /emulators
parentf0764c3fe0d09df0771a6911cbc49a53f6a68974 (diff)
downloadports-33dfe3dc81041cb09da76f3a0c33c276bbac58d3.tar.gz
ports-33dfe3dc81041cb09da76f3a0c33c276bbac58d3.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/stella/Makefile35
-rw-r--r--emulators/stella/distinfo2
-rw-r--r--emulators/stella/files/patch-OSS.c15
-rw-r--r--emulators/stella/files/patch-ac16
-rw-r--r--emulators/stella/pkg-descr6
-rw-r--r--emulators/stella/pkg-plist22
6 files changed, 57 insertions, 39 deletions
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 632a47874e83..ff4e8995fbcd 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -1,14 +1,15 @@
-# New ports collection makefile for: stella-1.1
-# Date created: March 4, 1999
-# Whom: Jacques Vidrine <nectar@FreeBSD.org>
+# New ports collection makefile for: stella
+# Date created: March 4, 1999
+# Whom: Jacques Vidrine <nectar@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= stella
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.eos.ncsu.edu/pub/bsvc/stella/1.1/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
@@ -17,16 +18,21 @@ USE_XLIB= yes
PORTTOP= ${WRKDIR}/${PKGNAME}
WRKSRC= ${PORTTOP}/src/build
+USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET= freebsd-x
USE_XLIB= yes
-ROMSDIR= ${PREFIX}/share/stella/roms
-ROMS= ELK.BIN OKIEDOKE.BIN OYSTR29.BIN TEST.BIN TPS.BIN
DOCSDIR= ${PREFIX}/share/doc/stella
-DOCS= docs/Stella.pdf games/docs/elk.doc games/docs/okiedoke.doc \
- games/docs/oystron.doc games/docs/tps.doc
+DOCS= docs/stella.html
+GFX= docs/graphics/chucky_cheese.png \
+ docs/graphics/circuit.png \
+ docs/graphics/console.png \
+ docs/graphics/jr_pacman.png \
+ docs/graphics/pacman.png \
+ docs/graphics/secret_quest.png \
+ docs/graphics/space_invaders.png
post-build:
@(cd ${PORTTOP}/src/ui/sound && \
@@ -34,13 +40,10 @@ post-build:
${MAKE_ARGS} oss)
do-install:
-.for exe in src/build/xstella src/ui/sound/stella-sound
+.for exe in src/build/stella.x11 src/ui/sound/stella-sound
${INSTALL_PROGRAM} ${PORTTOP}/${exe} ${PREFIX}/bin/
.endfor
- ${MKDIR} ${ROMSDIR}
-.for rom in ${ROMS}
- ${INSTALL_DATA} ${PORTTOP}/games/ROMS/${rom} ${ROMSDIR}/
-.endfor
+ ${MKDIR} ${PREFIX}/share/stella
${INSTALL_DATA} ${PORTTOP}/src/emucore/stella.pro \
${PREFIX}/share/stella/
.if !defined(NOPORTDOCS)
@@ -48,6 +51,10 @@ do-install:
.for doc in ${DOCS}
${INSTALL_DATA} ${PORTTOP}/${doc} ${DOCSDIR}/
.endfor
+ ${MKDIR} ${DOCSDIR}/graphics
+.for gfx in ${GFX}
+ ${INSTALL_DATA} ${PORTTOP}/${gfx} ${DOCSDIR}/graphics/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/emulators/stella/distinfo b/emulators/stella/distinfo
index 1da6dd24d1b5..02ed6f4f5896 100644
--- a/emulators/stella/distinfo
+++ b/emulators/stella/distinfo
@@ -1 +1 @@
-MD5 (stella-1.1-src.tar.gz) = 6e2e5336f2789654ddd822d82a4c7b8e
+MD5 (stella-1.2-src.tar.gz) = 2c24c0fa2655a597b9e04742485e5ed8
diff --git a/emulators/stella/files/patch-OSS.c b/emulators/stella/files/patch-OSS.c
new file mode 100644
index 000000000000..df0899b821dc
--- /dev/null
+++ b/emulators/stella/files/patch-OSS.c
@@ -0,0 +1,15 @@
+--- ../ui/sound/OSS.c.orig Tue Jan 8 17:11:32 2002
++++ ../ui/sound/OSS.c Mon Dec 30 04:08:03 2002
+@@ -32,12 +32,7 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <string.h>
+-
+-#ifdef __FreeBSD__
+- #include <machine/soundcard.h>
+-#else
+- #include <sys/soundcard.h>
+-#endif
++#include <sys/soundcard.h>
+
+ #include "TIASound.h"
diff --git a/emulators/stella/files/patch-ac b/emulators/stella/files/patch-ac
index 3374a5ca23e3..b34fb7a2de8f 100644
--- a/emulators/stella/files/patch-ac
+++ b/emulators/stella/files/patch-ac
@@ -1,15 +1,15 @@
---- makefile.orig Thu Mar 4 16:52:03 1999
-+++ makefile Thu Mar 4 16:53:33 1999
-@@ -129,6 +129,15 @@
- LDLIBS=`gtk-config --libs` \
- OBJS="gtk.o editor.o SndUnix.o"
+--- makefile.orig Mon Apr 22 01:53:19 2002
++++ makefile Mon Dec 30 03:44:36 2002
+@@ -218,6 +218,15 @@
+ LDLIBS+="$(LIBS.X11)" \
+ OBJS="mainX11.o SndUnix.o"
+freebsd-x:
-+ make xstella \
++ gmake stella.x11 \
+ INCLUDES="$(INCLUDES) -I$(UI)/x11 -I$(UI)/sound" \
-+ SYS_INCLUDES="-I${X11BASE}/include" \
++ SYS_INCLUDES="-I$(X11BASE)/include" \
+ OPTIONS="-DBSPF_UNIX -DSHOW_TIMING" \
-+ LDFLAGS="-L${X11BASE}/lib" \
++ LDFLAGS="-L$(X11BASE)/lib" \
+ LDLIBS="-lX11 -lXext" \
+ OBJS="mainX11.o SndUnix.o"
+
diff --git a/emulators/stella/pkg-descr b/emulators/stella/pkg-descr
index f009e4a58819..f2996adf649d 100644
--- a/emulators/stella/pkg-descr
+++ b/emulators/stella/pkg-descr
@@ -4,9 +4,7 @@ From the documentation:
to enjoy all of your favorite 2600 games once again by emulating the
2600's hardware with software. Stella is written in C++, which allows
it to be ported to other operating systems and architectures. Since
- its original release Stella has been ported to AcronOS, AmigaOS, DOS,
+ its original release Stella has been ported to AcornOS, AmigaOS, DOS,
FreeBSD, IRIX, Linux, MacOS, OpenStep, OS/2, Unix, and Windows.
-See also: http://www4.ncsu.edu/~bwmott/www/2600/
-
-Jacques Vidrine <nectar@FreeBSD.ORG>
+See also: http://stella.sourceforge.net/
diff --git a/emulators/stella/pkg-plist b/emulators/stella/pkg-plist
index 8e9100151c12..41749b422ddc 100644
--- a/emulators/stella/pkg-plist
+++ b/emulators/stella/pkg-plist
@@ -1,16 +1,14 @@
-bin/xstella
+bin/stella.x11
bin/stella-sound
-share/stella/roms/ELK.BIN
-share/stella/roms/OKIEDOKE.BIN
-share/stella/roms/OYSTR29.BIN
-share/stella/roms/TEST.BIN
-share/stella/roms/TPS.BIN
-@dirrm share/stella/roms
share/stella/stella.pro
@dirrm share/stella
-share/doc/stella/Stella.pdf
-share/doc/stella/elk.doc
-share/doc/stella/okiedoke.doc
-share/doc/stella/oystron.doc
-share/doc/stella/tps.doc
+share/doc/stella/graphics/chucky_cheese.png
+share/doc/stella/graphics/circuit.png
+share/doc/stella/graphics/console.png
+share/doc/stella/graphics/jr_pacman.png
+share/doc/stella/graphics/pacman.png
+share/doc/stella/graphics/secret_quest.png
+share/doc/stella/graphics/space_invaders.png
+@dirrm share/doc/stella/graphics
+share/doc/stella/stella.html
@dirrm share/doc/stella