aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 19:11:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 19:11:55 +0000
commit6d563d0ab273e71af8a12a844f1e0da12b830791 (patch)
tree9149c94e5d5e39315ff5d488c44a4926d89e805f /emulators
parent21eff32876e438f9766081073d2f249d9237bdcf (diff)
downloadports-6d563d0ab273e71af8a12a844f1e0da12b830791.tar.gz
ports-6d563d0ab273e71af8a12a844f1e0da12b830791.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus/Makefile47
-rw-r--r--emulators/mupen64plus/files/pkg-message.in23
-rw-r--r--emulators/mupen64plus/pkg-descr4
4 files changed, 75 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 1d587779cbea..82a97a40e189 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -107,6 +107,7 @@
SUBDIR += mupen64-softgfx
SUBDIR += mupen64-sound
SUBDIR += mupen64-tr64
+ SUBDIR += mupen64plus
SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-dummyaudio
SUBDIR += mupen64plus-glide
diff --git a/emulators/mupen64plus/Makefile b/emulators/mupen64plus/Makefile
new file mode 100644
index 000000000000..ea122172ceac
--- /dev/null
+++ b/emulators/mupen64plus/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mupen64plus
+# Date created: 2008-05-17
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64plus
+PORTVERSION= 1.3
+CATEGORIES= emulators
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER?= acm@FreeBSD.org
+COMMENT= A fork of Mupen64 Nintendo 64 emulator with plugins (meta port)
+
+# Mupen64 Emulator gui and no-gui
+RUN_DEPENDS+= ${LOCALBASE}/bin/mupen64plus:${PORTSDIR}/emulators/mupen64plus-base
+
+# Audio plugins
+RUN_DEPENDS+= ${PLUGINDIR}/dummyaudio.so:${PORTSDIR}/emulators/mupen64plus-dummyaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_audio.so:${PORTSDIR}/emulators/mupen64plus-sound
+RUN_DEPENDS+= ${PLUGINDIR}/jttl_audio.so:${PORTSDIR}/emulators/mupen64plus-sdlaudio
+
+# Input plugins
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_input.so:${PORTSDIR}/emulators/mupen64plus-input
+RUN_DEPENDS+= ${PLUGINDIR}/blight_input.so:${PORTSDIR}/emulators/mupen64plus-sdlinput
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_hle_rsp_azimer.so:${PORTSDIR}/emulators/mupen64plus-rsp
+
+# Graphics plugins
+RUN_DEPENDS+= ${PLUGINDIR}/ricevideo.so:${PORTSDIR}/emulators/mupen64plus-rice
+RUN_DEPENDS+= ${PLUGINDIR}/glide64.so:${PORTSDIR}/emulators/mupen64plus-glide
+RUN_DEPENDS+= ${PLUGINDIR}/glN64.so:${PORTSDIR}/emulators/mupen64plus-gln64
+
+NO_MTREE= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+PLUGINDIR= ${LOCALBASE}/share/mupen64plus/plugins
+
+do-install: # empty
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/mupen64plus/files/pkg-message.in b/emulators/mupen64plus/files/pkg-message.in
new file mode 100644
index 000000000000..cae647cde208
--- /dev/null
+++ b/emulators/mupen64plus/files/pkg-message.in
@@ -0,0 +1,23 @@
+###############################################################################
+
+The mupen64plus emulator was installed
+
+1) If you have installed/upgraded any new plugins or are upgrading from a
+previous version of Mupen64Plus, please note that in order for these changes to
+take effect, you -must- backup and then remove ~/.mupen64plus first. After you
+have removed the directory, run 'mupen64plus' to re-create it. Then, manually
+copy back your save files/other data you need from the backup if necessary.
+
+2) This port install gui or no-gui version of Mupen64Plus
+
+ Run gui or no-gui version
+
+ # mupen64plus
+
+3) You can see an use manual about mupen64plus at
+
+ # %%DOCSDIR%%/readme.pdf
+
+4) Enjoy it ;)
+
+###############################################################################
diff --git a/emulators/mupen64plus/pkg-descr b/emulators/mupen64plus/pkg-descr
new file mode 100644
index 000000000000..b14363e5653e
--- /dev/null
+++ b/emulators/mupen64plus/pkg-descr
@@ -0,0 +1,4 @@
+This is the metaport to install the mupen64plus emulator and all graphics,
+input and audio plugins.
+
+WWW: http://code.google.com/p/mupen64plus/