aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2015-05-26 04:33:08 +0000
committerDavid Naylor <dbn@FreeBSD.org>2015-05-26 04:33:08 +0000
commit78a67a25a84869bdb841f19c83685e66f78be7f8 (patch)
tree764d2cc351502814b4d47ae1c469cda1d02296e6 /emulators
parent75e63f689f5f09211e284f211bccc615765cc04c (diff)
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile.inc11
1 files changed, 6 insertions, 5 deletions
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index b4c8e6284c68..7a195c8d142e 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -29,7 +29,8 @@ CONFLICTS_INSTALL?= wine-[0-9]* wine-staging-[0-9]* wine-devel-[0-9]* \
EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude +MTREE_DIRS --exclude share/licenses/'*' \
--exclude libdata/ldconfig32/${UNIQUENAME} \
- -s '|/usr/local|${STAGEDIR}${PREFIX}|gs'
+ -s '|/usr/local|${STAGEDIR}${PREFIX}|gs' \
+ -s '|compholio|staging|gs'
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= wine only runs on x86 architecture
@@ -60,15 +61,15 @@ BROKEN= Temporary fix for compholio->staging rename. Needs to be undone for 1.
PLIST_SUB+= OSREL${osrel}=""
.if ${PKGNAMESUFFIX} == -devel
PLIST_SUB+= OSREL${osrel}-DEVEL=""
-PLIST_SUB+= OSREL${osrel}-COMPHOLIO="@comment "
+PLIST_SUB+= OSREL${osrel}-STAGING="@comment "
.else
PLIST_SUB+= OSREL${osrel}-DEVEL="@comment "
-PLIST_SUB+= OSREL${osrel}-COMPHOLIO=""
+PLIST_SUB+= OSREL${osrel}-STAGING=""
.endif
.else
PLIST_SUB+= OSREL${osrel}="@comment "
PLIST_SUB+= OSREL${osrel}-DEVEL="@comment "
-PLIST_SUB+= OSREL${osrel}-COMPHOLIO="@comment "
+PLIST_SUB+= OSREL${osrel}-STAGING="@comment "
.endif
.endfor
@@ -80,7 +81,7 @@ DISTFILES=
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} -C ${WRKDIR} --include '/usr/local/share/licenses/${PKGNAME}/LICENSE' -s '|/usr/local/share/licenses/${PKGNAME}/||g'
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} -C ${WRKDIR} --include '/usr/local/share/licenses/${DISTNAME}/LICENSE' -s '|/usr/local/share/licenses/${DISTNAME}/||g' -s '|compholio|staging|gs'
do-install:
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}