aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-03-28 18:12:38 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-03-28 18:12:38 +0000
commit9b8261add199420c1aee083ce99ef972a5e14212 (patch)
treef82c6e64c942dabe4c75e1030aa4ead81b3db625 /emulators
parentd5d186f73248e52af7df9873c0388d7a1036c113 (diff)
downloadports-9b8261add199420c1aee083ce99ef972a5e14212.tar.gz
ports-9b8261add199420c1aee083ce99ef972a5e14212.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/kqemu-kmod-devel/Makefile9
-rw-r--r--emulators/kqemu-kmod/Makefile9
2 files changed, 16 insertions, 2 deletions
diff --git a/emulators/kqemu-kmod-devel/Makefile b/emulators/kqemu-kmod-devel/Makefile
index ea31b4a182b0..96af32721578 100644
--- a/emulators/kqemu-kmod-devel/Makefile
+++ b/emulators/kqemu-kmod-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.4.0.p1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -68,6 +68,13 @@ post-extract:
@${ECHO_MSG} "then please define NOKSE."
.endif
+# 7.1 and head have seperate gdts also on amd64 now so the tss fixup code
+# is no longer needed there
+post-patch:
+.if ${OSVERSION} >= 701100 && (${OSVERSION} < 800000 || ${OSVERSION} >= 800046)
+ @cd ${WRKSRC} && ${PATCH} -R --quiet < ${FILESDIR}/patch-tssworkaround
+.endif
+
do-build:
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index d2987124dc17..31c025bfbfed 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.3.0.p11
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -68,6 +68,13 @@ post-extract:
@${ECHO_MSG} "then please define NOKSE."
.endif
+# 7.1 and head have seperate gdts also on amd64 now so the tss fixup code
+# is no longer needed there
+post-patch:
+.if ${OSVERSION} >= 701100 && (${OSVERSION} < 800000 || ${OSVERSION} >= 800046)
+ @cd ${WRKSRC} && ${PATCH} -R --quiet < ${FILESDIR}/patch-tssworkaround
+.endif
+
do-build:
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})