aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2018-01-25 11:07:50 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2018-01-25 11:07:50 +0000
commitd79ff76e2426d87a8ad0a9731e6e4ebef6d01090 (patch)
tree563a40b6ae1519cfbef58e63b360c073f2240e7b /emulators
parentbb347f42ed1ff2d58ab1a4df7b3db4e811a094ce (diff)
downloadports-d79ff76e2426d87a8ad0a9731e6e4ebef6d01090.tar.gz
ports-d79ff76e2426d87a8ad0a9731e6e4ebef6d01090.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile4
-rw-r--r--emulators/pcsxr/Makefile7
2 files changed, 6 insertions, 5 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 86a8038f1a0f..2cdf4c39371e 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -31,6 +31,8 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libcurl.so:ftp/curl \
libgtest.so:devel/googletest
+USES= cmake compiler:c++11-lib iconv openal pkgconfig
+
USE_GITHUB= yes
GH_PROJECT= dolphin
@@ -40,8 +42,6 @@ USE_SDL= sdl2
USE_WX= 3.0+
USE_XORG= ice sm x11 xext xi xrandr
-USES= cmake compiler:c++11-lib iconv openal pkgconfig
-
CMAKE_ARGS+= -DTRY_X11:BOOL=ON \
-DUSE_UPNP:BOOL=ON \
-DDISABLE_WX:BOOL=OFF \
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 0ed8320e3e48..247710b81d78 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -13,11 +13,14 @@ COMMENT= Playstation (PSX) emulator
LICENSE= GPLv2
+ONLY_FOR_ARCHS= amd64 i386
+
BUILD_DEPENDS= gawk:lang/gawk
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libcdio.so:sysutils/libcdio
-ONLY_FOR_ARCHS= i386 amd64
+USES= autoreconf desktop-file-utils dos2unix iconv gmake libtool \
+ pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -32,8 +35,6 @@ USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
USE_GL= gl
-USES= autoreconf desktop-file-utils dos2unix iconv gmake libtool \
- pkgconfig tar:bzip2
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
PORTDOCS= ChangeLog README