aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-04-23 00:46:26 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-04-23 00:46:26 +0000
commitf074d22615878d46f4b7bf6ed9b120e971a4bfdc (patch)
tree47b02764fb53dac301040138e81babd43d36c53f /emulators
parentc01de01b0fcf58f39835a78290ebc7b3311eb8d2 (diff)
downloadports-f074d22615878d46f4b7bf6ed9b120e971a4bfdc.tar.gz
ports-f074d22615878d46f4b7bf6ed9b120e971a4bfdc.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mess/Makefile8
-rw-r--r--emulators/mess/distinfo6
-rw-r--r--emulators/mess/files/patch-makefile.sdl41
-rw-r--r--emulators/mess/pkg-plist1
-rw-r--r--emulators/sdlmess/Makefile8
-rw-r--r--emulators/sdlmess/distinfo6
-rw-r--r--emulators/sdlmess/files/patch-makefile.sdl41
-rw-r--r--emulators/sdlmess/pkg-plist1
8 files changed, 60 insertions, 52 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 067948d6e8d1..1aa796ae2852 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.122
-PORTREVISION= 2
+PORTVERSION= 0.124
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -26,8 +25,11 @@ SUB_FILES= ${PORTNAME} pkg-message
.include <bsd.port.pre.mk>
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
-BROKEN= does not compile
+USE_GCC= 4.2+
.endif
do-install:
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
index 705ac3b96c94..2a468f72503e 100644
--- a/emulators/mess/distinfo
+++ b/emulators/mess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0122.zip) = 5c159e0ebecf33fb3d4ca213f26b4104
-SHA256 (sdlmess0122.zip) = 8e9e85f11c5171663719992a0fa6ee766eca73285f72bb13f72135c0e1b40ed3
-SIZE (sdlmess0122.zip) = 28795297
+MD5 (sdlmess0124.zip) = a727c374da2b72c21e7373fb95de4472
+SHA256 (sdlmess0124.zip) = a1dc328f66c2818f0ac5deea74a57501310ea354f0683576333c0868537c9caa
+SIZE (sdlmess0124.zip) = 29192593
diff --git a/emulators/mess/files/patch-makefile.sdl b/emulators/mess/files/patch-makefile.sdl
index e94ac72ee001..da3e09121c14 100644
--- a/emulators/mess/files/patch-makefile.sdl
+++ b/emulators/mess/files/patch-makefile.sdl
@@ -1,6 +1,6 @@
---- ./makefile.sdl.orig Mon Dec 31 13:41:23 2007
-+++ ./makefile.sdl Mon Feb 4 13:15:31 2008
-@@ -99,11 +99,13 @@
+--- ./makefile.sdl.orig 2008-03-26 20:35:31.000000000 -0300
++++ ./makefile.sdl 2008-04-21 16:26:24.000000000 -0300
+@@ -104,11 +104,13 @@
# uncomment next line to include the internal profiler
# PROFILER = 1
@@ -12,9 +12,9 @@
X86_PPC_DRC = 1
+endif
-
-
-@@ -113,7 +115,9 @@
+ # uncomment next line to build using unix-style libsdl on Mac OS X
+ # (vs. the native framework port). Normal users should not enable this.
+@@ -121,7 +123,9 @@
#-------------------------------------------------
# uncomment next line if you are building for a 64-bit target
@@ -25,7 +25,7 @@
# uncomment next line if you are building for a big-endian target
# BIGENDIAN = 1
-@@ -186,8 +190,8 @@
+@@ -198,8 +202,8 @@
# compiler, linker and utilities
AR = @ar
@@ -36,7 +36,7 @@
MD = -mkdir$(EXE)
RM = @rm -f
-@@ -211,7 +215,7 @@
+@@ -223,7 +227,7 @@
endif
# fullname is prefix+name+suffix+debugsuffix
@@ -45,7 +45,7 @@
# add an EXE suffix to get the final emulator name
EMULATOR = $(FULLNAME)$(EXE)
-@@ -276,7 +280,7 @@
+@@ -293,7 +297,7 @@
#-------------------------------------------------
# we compile to C89 standard with GNU extensions
@@ -54,16 +54,17 @@
# this speeds it up a bit by piping between the preprocessor/compiler/assembler
CFLAGS += -pipe
-@@ -313,7 +317,7 @@
- # if we are optimizing, include optimization options
+@@ -331,9 +335,6 @@
# and make all errors into warnings
ifneq ($(OPTIMIZE),0)
--CFLAGS += -Werror $(ARCHOPTS) -fno-strict-aliasing
-+CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
- #CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
+ CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
+-ifneq ($(TARGETOS),os2)
+-CFLAGS += -Werror
+-endif
endif
-@@ -339,6 +343,7 @@
+ # if symbols are on, make sure we have frame pointers
+@@ -358,6 +359,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(OSD) \
@@ -71,12 +72,12 @@
-@@ -349,7 +354,7 @@
- # LDFLAGS are used generally; LDFLAGSEMULATOR are additional
- # flags only used when linking the core emulator
+@@ -370,7 +372,7 @@
+ LDFLAGS =
ifneq ($(TARGETOS),macosx)
+ ifneq ($(TARGETOS),os2)
-LDFLAGS = -Wl,--warn-common
+LDFLAGS = -Wl,--warn-common -L$(LOCALBASE)/lib
- else
- LDFLAGS =
endif
+ endif
+ LDFLAGSEMULATOR =
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index 36b050bc764e..7135d4b5bf55 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -85,6 +85,7 @@ libexec/sdlmess/testkeys
%%DATADIR%%/hash/advision.hsi
%%DATADIR%%/hash/aim65.hsi
%%DATADIR%%/hash/apexc.hsi
+%%DATADIR%%/hash/apfm1000.hsi
%%DATADIR%%/hash/apple1.hsi
%%DATADIR%%/hash/apple2.hsi
%%DATADIR%%/hash/aquarius.hsi
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index 067948d6e8d1..1aa796ae2852 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.122
-PORTREVISION= 2
+PORTVERSION= 0.124
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -26,8 +25,11 @@ SUB_FILES= ${PORTNAME} pkg-message
.include <bsd.port.pre.mk>
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
-BROKEN= does not compile
+USE_GCC= 4.2+
.endif
do-install:
diff --git a/emulators/sdlmess/distinfo b/emulators/sdlmess/distinfo
index 705ac3b96c94..2a468f72503e 100644
--- a/emulators/sdlmess/distinfo
+++ b/emulators/sdlmess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0122.zip) = 5c159e0ebecf33fb3d4ca213f26b4104
-SHA256 (sdlmess0122.zip) = 8e9e85f11c5171663719992a0fa6ee766eca73285f72bb13f72135c0e1b40ed3
-SIZE (sdlmess0122.zip) = 28795297
+MD5 (sdlmess0124.zip) = a727c374da2b72c21e7373fb95de4472
+SHA256 (sdlmess0124.zip) = a1dc328f66c2818f0ac5deea74a57501310ea354f0683576333c0868537c9caa
+SIZE (sdlmess0124.zip) = 29192593
diff --git a/emulators/sdlmess/files/patch-makefile.sdl b/emulators/sdlmess/files/patch-makefile.sdl
index e94ac72ee001..da3e09121c14 100644
--- a/emulators/sdlmess/files/patch-makefile.sdl
+++ b/emulators/sdlmess/files/patch-makefile.sdl
@@ -1,6 +1,6 @@
---- ./makefile.sdl.orig Mon Dec 31 13:41:23 2007
-+++ ./makefile.sdl Mon Feb 4 13:15:31 2008
-@@ -99,11 +99,13 @@
+--- ./makefile.sdl.orig 2008-03-26 20:35:31.000000000 -0300
++++ ./makefile.sdl 2008-04-21 16:26:24.000000000 -0300
+@@ -104,11 +104,13 @@
# uncomment next line to include the internal profiler
# PROFILER = 1
@@ -12,9 +12,9 @@
X86_PPC_DRC = 1
+endif
-
-
-@@ -113,7 +115,9 @@
+ # uncomment next line to build using unix-style libsdl on Mac OS X
+ # (vs. the native framework port). Normal users should not enable this.
+@@ -121,7 +123,9 @@
#-------------------------------------------------
# uncomment next line if you are building for a 64-bit target
@@ -25,7 +25,7 @@
# uncomment next line if you are building for a big-endian target
# BIGENDIAN = 1
-@@ -186,8 +190,8 @@
+@@ -198,8 +202,8 @@
# compiler, linker and utilities
AR = @ar
@@ -36,7 +36,7 @@
MD = -mkdir$(EXE)
RM = @rm -f
-@@ -211,7 +215,7 @@
+@@ -223,7 +227,7 @@
endif
# fullname is prefix+name+suffix+debugsuffix
@@ -45,7 +45,7 @@
# add an EXE suffix to get the final emulator name
EMULATOR = $(FULLNAME)$(EXE)
-@@ -276,7 +280,7 @@
+@@ -293,7 +297,7 @@
#-------------------------------------------------
# we compile to C89 standard with GNU extensions
@@ -54,16 +54,17 @@
# this speeds it up a bit by piping between the preprocessor/compiler/assembler
CFLAGS += -pipe
-@@ -313,7 +317,7 @@
- # if we are optimizing, include optimization options
+@@ -331,9 +335,6 @@
# and make all errors into warnings
ifneq ($(OPTIMIZE),0)
--CFLAGS += -Werror $(ARCHOPTS) -fno-strict-aliasing
-+CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
- #CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
+ CFLAGS += $(ARCHOPTS) -fno-strict-aliasing
+-ifneq ($(TARGETOS),os2)
+-CFLAGS += -Werror
+-endif
endif
-@@ -339,6 +343,7 @@
+ # if symbols are on, make sure we have frame pointers
+@@ -358,6 +359,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(OSD) \
@@ -71,12 +72,12 @@
-@@ -349,7 +354,7 @@
- # LDFLAGS are used generally; LDFLAGSEMULATOR are additional
- # flags only used when linking the core emulator
+@@ -370,7 +372,7 @@
+ LDFLAGS =
ifneq ($(TARGETOS),macosx)
+ ifneq ($(TARGETOS),os2)
-LDFLAGS = -Wl,--warn-common
+LDFLAGS = -Wl,--warn-common -L$(LOCALBASE)/lib
- else
- LDFLAGS =
endif
+ endif
+ LDFLAGSEMULATOR =
diff --git a/emulators/sdlmess/pkg-plist b/emulators/sdlmess/pkg-plist
index 36b050bc764e..7135d4b5bf55 100644
--- a/emulators/sdlmess/pkg-plist
+++ b/emulators/sdlmess/pkg-plist
@@ -85,6 +85,7 @@ libexec/sdlmess/testkeys
%%DATADIR%%/hash/advision.hsi
%%DATADIR%%/hash/aim65.hsi
%%DATADIR%%/hash/apexc.hsi
+%%DATADIR%%/hash/apfm1000.hsi
%%DATADIR%%/hash/apple1.hsi
%%DATADIR%%/hash/apple2.hsi
%%DATADIR%%/hash/aquarius.hsi