aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-10-03 13:10:13 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-10-03 13:10:13 +0000
commitfcc2b18cb34049640e4c7da1e3629aa8b8aed7b4 (patch)
tree813be81c370748ff5d0e72034089e2d743e2da2b /emulators
parent45901fed899044f7e6387232f29ce81800db9c89 (diff)
downloadports-fcc2b18cb34049640e4c7da1e3629aa8b8aed7b4.tar.gz
ports-fcc2b18cb34049640e4c7da1e3629aa8b8aed7b4.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile6
-rw-r--r--emulators/qemu-devel/files/patch-cpu-exec.c13
2 files changed, 14 insertions, 5 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index d35d01d8c797..08ee376da586 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 1.6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -63,10 +63,6 @@ CONFIGURE_ARGS+= --enable-nptl --target-list=i386-softmmu,x86_64-softmmu,i386-bs
CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
.endif
.else
-# clang seems to build a broken mips-softmmu target (qemu segfaults
-# at boot) Feel free to debug :) Some info is here:
-# http://people.freebsd.org/~nox/tmp/qemu-1.6.0-mips-softmmu-crash.txt
-USE_GCC= any
.if empty(PORT_OPTIONS:MBSD_USER)
CONFIGURE_ARGS+= --disable-bsd-user
.else
diff --git a/emulators/qemu-devel/files/patch-cpu-exec.c b/emulators/qemu-devel/files/patch-cpu-exec.c
new file mode 100644
index 000000000000..57229ab351db
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-cpu-exec.c
@@ -0,0 +1,13 @@
+--- a/cpu-exec.c
++++ b/cpu-exec.c
+@@ -681,6 +681,10 @@ int cpu_exec(CPUArchState *env)
+ * local variables as longjmp is marked 'noreturn'. */
+ cpu = current_cpu;
+ env = cpu->env_ptr;
++#if !(defined(CONFIG_USER_ONLY) && \
++ (defined(TARGET_M68K) || defined(TARGET_PPC) || defined(TARGET_S390X)))
++ cc = CPU_GET_CLASS(cpu);
++#endif
+ }
+ } /* for(;;) */
+