aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-27 01:16:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-27 01:16:09 +0000
commit07cdcaaf4f194e4f487fc25aaa3baaf017ac725e (patch)
treebcc3b4ba5b9ebcf1b447cf89ca971d590584ecf6 /emulators
parent62dfbc91a9b14b1043cf812a54bf6591a6134d45 (diff)
downloadports-07cdcaaf4f194e4f487fc25aaa3baaf017ac725e.tar.gz
ports-07cdcaaf4f194e4f487fc25aaa3baaf017ac725e.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/vmips/Makefile30
-rw-r--r--emulators/vmips/distinfo2
-rw-r--r--emulators/vmips/pkg-descr8
-rw-r--r--emulators/vmips/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c1a8509d08e1..31f85fa0d195 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -90,6 +90,7 @@
SUBDIR += vgba-bin
SUBDIR += vice
SUBDIR += visualos
+ SUBDIR += vmips
SUBDIR += vmsbackup
SUBDIR += vmware-guestd3
SUBDIR += vmware-guestd4
diff --git a/emulators/vmips/Makefile b/emulators/vmips/Makefile
new file mode 100644
index 000000000000..18e1df240702
--- /dev/null
+++ b/emulators/vmips/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: vmips
+# Date created: 13 July 2004
+# Whom: brg
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmips
+PORTVERSION= 1.2.1
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.dgate.org/vmips/releases/vmips-${PORTVERSION}/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= brg@dgate.org
+COMMENT= MIPS R3000 simulator
+
+GNU_CONFIGURE= yes
+
+MAN1= vmips.1 vmipstool.1
+INFO= vmips
+
+post-install:
+ @${MKDIR} ${PREFIX}/include/vmips
+ ${INSTALL_DATA} ${WRKSRC}/sample_code/asm_regnames.h \
+ ${PREFIX}/include/vmips
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_code/ld.script ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/emulators/vmips/distinfo b/emulators/vmips/distinfo
new file mode 100644
index 000000000000..c6d9a827852d
--- /dev/null
+++ b/emulators/vmips/distinfo
@@ -0,0 +1,2 @@
+MD5 (vmips-1.2.1.tar.gz) = d1f18690c3017536436e72a7e94e3421
+SIZE (vmips-1.2.1.tar.gz) = 1050167
diff --git a/emulators/vmips/pkg-descr b/emulators/vmips/pkg-descr
new file mode 100644
index 000000000000..b10a8bda8db8
--- /dev/null
+++ b/emulators/vmips/pkg-descr
@@ -0,0 +1,8 @@
+vmips is a virtual machine based on the MIPS R3000 RISC processor.
+It has built-in support for several emulated devices and GNU GDB
+remote debugging.
+
+WWW: http://www.dgate.org/vmips/
+
+Brian Gaeke (brg at dgate.org)
+David Bushong helped write the FreeBSD port.
diff --git a/emulators/vmips/pkg-plist b/emulators/vmips/pkg-plist
new file mode 100644
index 000000000000..fdf626bd359d
--- /dev/null
+++ b/emulators/vmips/pkg-plist
@@ -0,0 +1,7 @@
+bin/vmips
+bin/vmipstool
+etc/vmipsrc
+include/vmips/asm_regnames.h
+@dirrm include/vmips
+%%DATADIR%%/ld.script
+@dirrm %%DATADIR%%