aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:49:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:49:37 +0000
commit445b5c3a24799cd5ab9a064de468972dc4aa4bdf (patch)
treea92f5bfc1c350d556de8a5404303867f8d27aa88 /emulators
parent220ce518be8eca9cf6368cf1307a93ee3194c054 (diff)
downloadports-445b5c3a24799cd5ab9a064de468972dc4aa4bdf.tar.gz
ports-445b5c3a24799cd5ab9a064de468972dc4aa4bdf.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/spim/Makefile44
-rw-r--r--emulators/spim/distinfo6
-rw-r--r--emulators/spim/files/patch-spim_Makefile43
-rw-r--r--emulators/spim/files/patch-xspim_Imakefile41
-rw-r--r--emulators/spim/pkg-descr2
5 files changed, 60 insertions, 76 deletions
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 07cc766d8f19..cf5e6c6a2bd3 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -7,55 +7,49 @@
#
PORTNAME= spim
-PORTVERSION= 7.2.1
-PORTREVISION= 3
+PORTVERSION= 7.3
CATEGORIES= emulators
-MASTER_SITES= http://www.cs.wisc.edu/~larus/SPIM/
+MASTER_SITES= http://pages.cs.wisc.edu/~larus/SPIM/
MAINTAINER= ports@FreeBSD.org
COMMENT= MIPS32 Simulator
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS= GUI "Graphical user interface" on
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+INSTALL_WRKSRC= ${WRKSRC}/${PORTNAME}
+ALL_TARGET= ${PORTNAME}
MAN1= spim.1
PORTDOCS= cycle.ps.gz spim.ps.gz SPIM.html
PLIST_FILES= bin/spim %%DATADIR%%/exceptions.s
PLIST_DIRS= %%DATADIR%%
-OPTIONS= GUI "Graphical user interface" on
-
.include <bsd.port.pre.mk>
-.if defined(WITH_GUI)
+.if !defined(WITHOUT_GUI)
USE_XORG= x11 xaw
BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake
PLIST_FILES+= bin/xspim
MAN1+= xspim.1
.endif
-do-configure:
-
-do-build:
- cd ${WRKSRC}/spim && \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
-.if defined(WITH_GUI)
- cd ${WRKSRC}/xspim && ${XMKMF} && \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
+post-build:
+.if !defined(WITHOUT_GUI)
+ @(cd ${WRKSRC}/xspim && ${XMKMF} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE})
.endif
do-install:
- cd ${WRKSRC}/spim && \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
- ${INSTALL_TARGET}
-.if defined(WITH_GUI)
- cd ${WRKSRC}/xspim && \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
- ${INSTALL_TARGET}
- ${INSTALL_MAN} ${WRKSRC}/Documentation/xspim.man ${PREFIX}/man/man1/xspim.1
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/spim ${PREFIX}/bin/spim
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/spim.man ${MANPREFIX}/man/man1/spim.1
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/CPU/exceptions.s ${DATADIR}/exceptions.s
+.if !defined(WITHOUT_GUI)
+ ${INSTALL_PROGRAM} ${WRKSRC}/xspim/xspim ${PREFIX}/bin/xspim
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/xspim.man ${MANPREFIX}/man/man1/xspim.1
.endif
-
-post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/cycle.ps ${DOCSDIR}
diff --git a/emulators/spim/distinfo b/emulators/spim/distinfo
index c5ffe1adb178..13aa55b54d96 100644
--- a/emulators/spim/distinfo
+++ b/emulators/spim/distinfo
@@ -1,3 +1,3 @@
-MD5 (spim-7.2.1.tar.gz) = 0fe5696659364d38660f5610ef380ad0
-SHA256 (spim-7.2.1.tar.gz) = 347771fc7f91ba12092b22374ddb377f13c588e6d0d1a0cdacea8bbb76f347fb
-SIZE (spim-7.2.1.tar.gz) = 534388
+MD5 (spim-7.3.tar.gz) = 52002170982d157fd89d445b481bd223
+SHA256 (spim-7.3.tar.gz) = d7de06135c519108055a90abe77ced4e36dec4f7f27ce1a2fca0059f86cdf35d
+SIZE (spim-7.3.tar.gz) = 347226
diff --git a/emulators/spim/files/patch-spim_Makefile b/emulators/spim/files/patch-spim_Makefile
index e9aa25f973bd..349e07f8532d 100644
--- a/emulators/spim/files/patch-spim_Makefile
+++ b/emulators/spim/files/patch-spim_Makefile
@@ -1,28 +1,25 @@
---- spim/Makefile.orig Mon Aug 29 02:28:14 2005
-+++ spim/Makefile Mon Jul 17 14:46:59 2006
-@@ -46,16 +46,16 @@
- VPATH = src:$(CPU_DIR)
+--- spim/Makefile.orig 2006-08-29 11:23:19.000000000 +0900
++++ spim/Makefile 2008-04-23 01:36:01.000000000 +0900
+@@ -54,13 +54,13 @@
- # Full path for directory that will hold the exception handler file:
--EXCEPTION_DIR = ../CPU
-+EXCEPTION_DIR = ${PREFIX}/share/spim
-
- # Path of directory that contains SPIM tests:
- TEST_DIR = ../Tests
# Full path for the directory that will hold the executable files:
--BIN_DIR = /usr/unsup/bin
+-BIN_DIR = /usr/local/bin
+BIN_DIR = ${PREFIX}/bin
+ # Full path for the directory that will hold the exception handler:
+-EXCEPTION_DIR = /usr/local/lib
++EXCEPTION_DIR = ${PREFIX}/share/spim
+
# Full path for the directory that will hold the man files:
--MAN_DIR = /usr/unsup/man
+-MAN_DIR = /usr/man/mann
+MAN_DIR = ${PREFIX}/man/man1
- # Full path for the exception handler file:
-@@ -90,12 +90,12 @@
+ # If you have flex, use it instead of lex. If you use flex, define this
+@@ -92,12 +92,12 @@
- DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER=$(EXCEPTION_PATH) -DSPIM_VERSION="\"`cat ../VERSION`\""
+ DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER="\"$(EXCEPTION_DIR)/exceptions.s\"" -DSPIM_VERSION="\"`cat ../VERSION`\""
-CC = gcc
-CFLAGS = -I. -I$(CPU_DIR) $(DEFINES) -g -Wall
@@ -37,7 +34,7 @@
# lex.yy.c is usually compiled with -O to speed it up.
-@@ -108,10 +108,10 @@
+@@ -110,10 +110,10 @@
spim: force
@@ -50,19 +47,7 @@
force: configuration
-@@ -176,8 +176,9 @@
-
- install: spim
- install -c -s spim $(BIN_DIR)
-- install -c -m 0444 exceptions.s $(EXCEPTION_DIR)
-- install -c -m 0444 spim.man $(MAN_DIR)
-+ mkdir -p $(EXCEPTION_DIR)
-+ install -c -m 0444 $(CPU_DIR)/exceptions.s $(EXCEPTION_DIR)
-+ install -c -m 0444 ../Documentation/spim.man $(MAN_DIR)/spim.1
-
- very-clean: clean
- rm -f configuration
-@@ -195,7 +196,7 @@
+@@ -196,7 +196,7 @@
y.tab.h: y.tab.c
y.tab.c: $(CPU_DIR)/parser.y
diff --git a/emulators/spim/files/patch-xspim_Imakefile b/emulators/spim/files/patch-xspim_Imakefile
index ccceba07d3a5..12b58e283392 100644
--- a/emulators/spim/files/patch-xspim_Imakefile
+++ b/emulators/spim/files/patch-xspim_Imakefile
@@ -1,32 +1,37 @@
---- xspim/Imakefile.orig Mon Aug 29 02:28:15 2005
-+++ xspim/Imakefile Mon Jul 17 14:24:25 2006
-@@ -33,15 +33,15 @@
+--- xspim/Imakefile.orig 2006-08-29 11:23:19.000000000 +0900
++++ xspim/Imakefile 2008-04-23 00:58:19.000000000 +0900
+@@ -33,13 +33,13 @@
#
# Full path for the directory that will hold the executable files:
-BIN_DIR = /usr/local/bin
+BIN_DIR = ${PREFIX}/bin
+ # Full path for the directory that will hold the exception handler:
+-EXCEPTION_DIR = /usr/local/lib
++EXCEPTION_DIR = ${PREFIX}/share/spim
+
# Full path for the directory that will hold the man files:
--MAN_DIR = /usr/local/share/man1
-+MAN_DIR = ${PREFIX}/share/man1
+-MAN_DIR = /usr/man/mann
++MAN_DIR = ${PREFIX}/man/man1
- # Full path for the exception handler file:
--#EXCEPTION_PATH = /usr/local/lib/exceptions.s
-+EXCEPTION_PATH = ${PREFIX}/share/spim/exceptions.s
- # Use this path for testing:
--EXCEPTION_PATH = $(CPU_DIR)/exceptions.s
-+#EXCEPTION_PATH = $(CPU_DIR)/exceptions.s
# If you have flex, use it instead of lex. If you use flex, define this
- # variable and set LEXFLAGS.
-@@ -119,9 +119,6 @@
- NormalProgramTarget(xspim_sub,$(XOBJS),$(DEPLIBS),$(LOCALLIBS),$(SYSLIBS))
+@@ -91,7 +91,7 @@
+ DEPLIBS = XawClientDepLibs
+ LOCALLIBS = XawClientLibs
+
+-CDEBUGFLAGS = -g
++#CDEBUGFLAGS = -g
+
+ INCLUDES = -I. -I$(CPU_DIR)
+
+@@ -113,7 +113,7 @@
+ ./Configure
InstallProgram(xspim,$(BIN_DIR))
--InstallManPage(xspim,$(MAN_DIR))
--InstallNonExec($(EXCEPTION_DIR)/exceptions.s,$(EXCEPTION_PATH))
--
+-InstallNonExec($(CPU_DIR)/exceptions.s,$(EXCEPTION_DIR))
++#InstallNonExec($(CPU_DIR)/exceptions.s,$(EXCEPTION_DIR))
+ #InstallManPage($(DOC_DIR)/xspim,$(MAN_DIR))
- y.tab.h: y.tab.c
diff --git a/emulators/spim/pkg-descr b/emulators/spim/pkg-descr
index 7ef6fa09c98d..eb85cdffa13b 100644
--- a/emulators/spim/pkg-descr
+++ b/emulators/spim/pkg-descr
@@ -12,6 +12,6 @@ This simulator is useful in CS and EE classes, including providing a
target machine for compilers courses, lower division assembly language
programming, microprocessor design courses, etc...
-WWW: http://www.cs.wisc.edu/~larus/SPIM/
+WWW: http://pages.cs.wisc.edu/~larus/spim.html
-- David O'Brien (obrien@cs.ucdavis.edu)