aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-11-09 23:55:32 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-11-09 23:55:32 +0000
commit7e9c41cb866cdd2a2fe8f77c0aaee2da3a575a2d (patch)
tree1db967168925a0940b81737ef6eaf31648dba04b /emulators
parentb8594e766433dfb7ccd7ad280ac173e1fa0a5d8f (diff)
downloadports-7e9c41cb866cdd2a2fe8f77c0aaee2da3a575a2d.tar.gz
ports-7e9c41cb866cdd2a2fe8f77c0aaee2da3a575a2d.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine/Makefile44
1 files changed, 21 insertions, 23 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index d0476589777e..afe2f0012b6b 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --without-dbus \
--with-fontconfig --with-glu \
--without-gphoto --without-gsm --without-gstreamer \
- --with-opengl --without-mpg123 --without-opencl \
- --with-oss --without-sane --without-tiff \
+ --with-opengl \
+ --without-opencl --with-oss --without-sane --without-tiff \
--without-v4l --with-xcomposite --without-xinerama \
--with-xinput2 --with-xrandr
CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
@@ -47,56 +47,54 @@ USES= bison compiler:c11 gmake shebangfix tar:bzip2
SHEBANG_FILES= tools/winemaker tools/winedump/function_grep.pl
USE_GL= glu
USE_XORG= xcomposite xcursor xi xpm xrandr xrender
-OPTIONS_SUB= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO DOCS
+OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT MPG123 OPENAL WINEMAKER GECKO MONO DOCS
+OPTIONS_SUB= yes
+
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
WINEMAKER_DESC= Fully support winemaker (requires Perl)
GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
-# USES needs to be before bsd.port.pre.mk
-OPENAL_USES= openal
-
PORTDATA= fonts/ generic.ppd l_intl.nls wine.inf
PORTSCOUT= limitw:1,even
-CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
CUPS_CONFIGURE_WITH= cups
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
DOSBOX_RUN_DEPENDS= dosbox:${PORTSDIR}/emulators/dosbox
-GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GECKO_RUN_DEPENDS= ${DATADIR}/gecko/wine_gecko-2.21-x86.msi:${PORTSDIR}/emulators/wine-gecko
+
GNUTLS_CONFIGURE_WITH= gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-HAL_LIB_DEPENDS= libhal.so:${PORTSDIR}/sysutils/hal
HAL_CONFIGURE_WITH= hal
+HAL_LIB_DEPENDS= libhal.so:${PORTSDIR}/sysutils/hal
-LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_WITH= ldap
+LDAP_USE= OPENLDAP=yes
-LIBXSLT_LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt
LIBXSLT_CONFIGURE_WITH= xslt
+LIBXSLT_LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt
-OPENAL_CONFIGURE_WITH= openal
+MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
-WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+MPG123_CONFIGURE_WITH= mpg123
+MPG123_LIB_DEPENDS= libmpg123.so:${PORTSDIR}/audio/mpg123
-GECKO_RUN_DEPENDS= ${DATADIR}/gecko/wine_gecko-2.21-x86.msi:${PORTSDIR}/emulators/wine-gecko
+OPENAL_CONFIGURE_WITH= openal
+OPENAL_USES= openal
-MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
+WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-IGNORE= lacks required sound support on FreeBSD before 8.0
-.endif
-
pre-build:
cd ${WRKSRC} && ${MAKE_CMD} depend
@@ -106,9 +104,9 @@ post-install:
@${LN} -sf libwine.so.1 ${STAGEDIR}/${WINELIBDIR}/libwine.so
-@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README ANNOUNCE AUTHORS
- @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${STAGEDIR}${DOCSDIR}/README.winedbg
- @${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${STAGEDIR}${DOCSDIR}/README.winedump
+ ${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${STAGEDIR}${DOCSDIR}/README.winedbg
+ ${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${STAGEDIR}${DOCSDIR}/README.winedump
.include <bsd.port.post.mk>