aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2011-06-02 17:02:22 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2011-06-02 17:02:22 +0000
commitcd2186d43c7d54fef2f6926d916158abc5fc5d7d (patch)
treec1f8c4c543f562b645a3d755af1147831b4c3b72 /emulators
parent7ffa735755cdd8bbacd19bb283ea2ba23c09bfeb (diff)
downloadports-cd2186d43c7d54fef2f6926d916158abc5fc5d7d.tar.gz
ports-cd2186d43c7d54fef2f6926d916158abc5fc5d7d.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile1
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h12
2 files changed, 13 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 93f488b9b8db..e5d0ac18a493 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -7,6 +7,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.0.8
+PORTREVISION= 1
CATEGORIES= emulators kld
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h
new file mode 100644
index 000000000000..e745733bdee2
--- /dev/null
+++ b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h
@@ -0,0 +1,12 @@
+--- src/VBox/Runtime/r0drv/freebsd/sleepqueue-r0drv-freebsd.h.orig 2011-05-16 18:33:52.000000000 +0200
++++ src/VBox/Runtime/r0drv/freebsd/sleepqueue-r0drv-freebsd.h 2011-06-02 18:26:49.000000000 +0200
+@@ -313,7 +313,9 @@
+ {
+ sleepq_lock(pvWaitChan);
+ sleepq_broadcast(pvWaitChan, SLEEPQ_CONDVAR, 0, 0);
++#if __FreeBSD_version >= 800000 /* Broadcast releases the sleep queue lock on FreeBSD 7.x */
+ sleepq_release(pvWaitChan);
++#endif
+ }
+
+ /**