aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-12-22 12:13:16 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-12-22 12:13:16 +0000
commit7e0d5971d186fe366ad3948cb7f5f28aaee77e06 (patch)
tree4c3c2dfeeb00e3a2afec7fcc28a06b4337b82228 /emulators
parent44f4909f195b12f43dfcf09f2d575a59126bd6a9 (diff)
downloadports-7e0d5971d186fe366ad3948cb7f5f28aaee77e06.tar.gz
ports-7e0d5971d186fe366ad3948cb7f5f28aaee77e06.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/ukncbtl/Makefile40
-rw-r--r--emulators/ukncbtl/distinfo3
-rw-r--r--emulators/ukncbtl/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 091550132517..2718edf84d3e 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -140,6 +140,7 @@
SUBDIR += tuxnes
SUBDIR += uae
SUBDIR += ucon64
+ SUBDIR += ukncbtl
SUBDIR += unicorn
SUBDIR += vba
SUBDIR += vboxtool
diff --git a/emulators/ukncbtl/Makefile b/emulators/ukncbtl/Makefile
new file mode 100644
index 000000000000..467fdd5981fe
--- /dev/null
+++ b/emulators/ukncbtl/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= ukncbtl
+DISTVERSION= g20191117
+CATEGORIES= emulators
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= UKNC (Elektronika MS-0511) emulator
+
+LICENSE= LGPL3
+LICENSE_FILE= LICENSE
+
+USES= compiler:c++11-lang gl qmake qt:5
+
+USE_GL= gl
+USE_QT= core gui multimedia network script testlib widgets \
+ buildtools_build qmake_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= nzeemin
+GH_PROJECT= ukncbtl-qt
+GH_TAGNAME= 20b5f043
+
+DESKTOP_ENTRIES= "UkncBtl" \
+ "" \
+ "" \
+ "${PORTNAME}" \
+ "" \
+ true
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} '/^#include/s,malloc.h,stdlib.h,' ${WRKSRC}/stdafx.h
+ ${REINPLACE_CMD} '/^TARGET/s,QtUkncBtl,${PORTNAME},' ${WRKSRC}/QtUkncBtl.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/emulators/ukncbtl/distinfo b/emulators/ukncbtl/distinfo
new file mode 100644
index 000000000000..6f80f3c5b89b
--- /dev/null
+++ b/emulators/ukncbtl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577007753
+SHA256 (nzeemin-ukncbtl-qt-g20191117-20b5f043_GH0.tar.gz) = 882d2e015d3d4f284a83bed0e46c75da6e9481def547e6af7e5a2ad3b0029e66
+SIZE (nzeemin-ukncbtl-qt-g20191117-20b5f043_GH0.tar.gz) = 166473
diff --git a/emulators/ukncbtl/pkg-descr b/emulators/ukncbtl/pkg-descr
new file mode 100644
index 000000000000..c75ce2400821
--- /dev/null
+++ b/emulators/ukncbtl/pkg-descr
@@ -0,0 +1,5 @@
+UKNCBTL - UKNC Back to Life! - is a cross-platform UKNC emulator.
+UKNC, also known as Elektronika MS-0511, is a Soviet educational
+computer based on two PDP-11 compatible processors KM1801VM2.
+
+WWW: https://github.com/nzeemin/ukncbtl-doc/wiki