aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:21:16 +0000
commita3c56e68df3a7bf6713f80ab7c2e99f961e98a80 (patch)
tree831a3c893bea5650066440c5b2854bd428d2cc44 /emulators
parent680550419d6ab5747243411408ef3f63ee7d4b77 (diff)
downloadports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.tar.gz
ports-a3c56e68df3a7bf6713f80ab7c2e99f961e98a80.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gngb/Makefile1
-rw-r--r--emulators/open-vm-tools/Makefile1
-rw-r--r--emulators/qemu40/Makefile2
-rw-r--r--emulators/virtualbox-ose-additions/Makefile4
4 files changed, 5 insertions, 3 deletions
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
index 1eae72910b7c..3345b0726159 100644
--- a/emulators/gngb/Makefile
+++ b/emulators/gngb/Makefile
@@ -23,6 +23,7 @@ PLIST_FILES= bin/gngb \
OPTIONS_DEFINE= OPENGL
+OPENGL_USES= gl
OPENGL_USE= GL=gl
OPENGL_CONFIGURE_ENABLE=gl
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index a2bd3dd72ccc..c41e5aa3ed77 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -30,6 +30,7 @@ OPTIONS_SUB=
LIBNOTIFY_DESC= Desktop notification support
X11_CONFIGURE_WITH= x gtk2 gtkmm
+X11_USES= gnome xorg
X11_USE= xorg=ice,sm,x11,xext,xi,xinerama,xorgproto,xrandr,xrender,xtst \
gnome=gdkpixbuf2,gtk20,gtkmm24
X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
diff --git a/emulators/qemu40/Makefile b/emulators/qemu40/Makefile
index bdefb542006f..d2e614aa75a8 100644
--- a/emulators/qemu40/Makefile
+++ b/emulators/qemu40/Makefile
@@ -55,7 +55,7 @@ X11_USES= sdl
X11_CONFIGURE_ENABLE= sdl
GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
-GTK3_USES= gettext gl
+GTK3_USES= gettext gl xorg
GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_OFF= --disable-gnutls
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 18ca8698fcfd..99cbd722d334 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -60,11 +60,11 @@ DEBUG_VARS_OFF= KMK_BUILDTYPE=release
OPENGL_CONFIGURE_OFF= --disable-opengl
OPENGL_IMPLIES= X11
OPENGL_USE= GL=gl,glu XORG=xcomposite,xdamage,xfixes
-OPENGL_USES= gl
+OPENGL_USES= gl xorg
X11_BUILD_DEPENDS= ${LOCALBASE}/include/xorg/compiler.h:x11-servers/xorg-server
X11_RUN_DEPENDS= xrandr:x11/xrandr
X11_USE= XORG=x11,xcursor,xext,xorgproto,xmu,xrandr,xt
-X11_USES= pkgconfig
+X11_USES= pkgconfig xorg
X11_VARS= VBOX_WITH_X11=1
.include <bsd.port.options.mk>