aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-04-19 23:18:29 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-04-19 23:18:29 +0000
commit30d7aac9537bc31b1b0a1c422f1d1fec0a626a2b (patch)
treebf03b2aa0f489afc9cb7e6426bb8248edfd59458 /emulators
parent4a580e3e8621c1d28ff4991d9af36b21fd97ccd5 (diff)
downloadports-30d7aac9537bc31b1b0a1c422f1d1fec0a626a2b.tar.gz
ports-30d7aac9537bc31b1b0a1c422f1d1fec0a626a2b.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-debian/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/emulators/linux_base-debian/Makefile b/emulators/linux_base-debian/Makefile
index fdcfe15d7654..550b07e5e1bd 100644
--- a/emulators/linux_base-debian/Makefile
+++ b/emulators/linux_base-debian/Makefile
@@ -31,8 +31,8 @@ PREFIX?= ${LINUXBASE}
DPKGDB= ${PREFIX}/var/lib/dpkg
DPKG_CMD?= ${LOCALBASE}/bin/dpkg
DPKG_ARGS= --force-architecture --force-depends
-DPKG= ${BATCHENV} ${DPKG_CMD} --root=${PREFIX} \
- --admindir=${DPKGDB} ${DPKG_ARGS}
+DPKG= ${BATCHENV} PATH="${PATH}:${LOCALBASE}/sbin" ${DPKG_CMD} \
+ --root=${PREFIX} --admindir=${DPKGDB} ${DPKG_ARGS}
LIBC6NAME= libc6_2.2.5-6_${ARCH}
INSTALL_INFO?= install-info
@@ -58,7 +58,7 @@ post-extract:
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/util-linux-locales_2.11n-4_all.deb \
${WRKSRC}
-do-patch:
+do-patch: build-depends
cd ${WRKSRC} && \
${DPKG_CMD} -x ${LIBC6NAME}.deb ${LIBC6NAME} && \
${DPKG_CMD} -e ${LIBC6NAME}.deb ${LIBC6NAME}/DEBIAN && \