aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-09 05:40:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-09 05:40:16 +0000
commit3241160ea2d597c84591e0d541f5fe04dcdba6a7 (patch)
tree8b1feb994856b2c2be6923468f203046a3679231 /emulators
parent955f01ad0c92a514830b987d955e2676a55d15de (diff)
downloadports-3241160ea2d597c84591e0d541f5fe04dcdba6a7.tar.gz
ports-3241160ea2d597c84591e0d541f5fe04dcdba6a7.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/tiemu3/Makefile58
-rw-r--r--emulators/tiemu3/distinfo6
-rw-r--r--emulators/tiemu3/pkg-descr9
-rw-r--r--emulators/tiemu3/pkg-plist114
5 files changed, 188 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 6778a76400fc..c5bd291a8dc9 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -131,6 +131,7 @@
SUBDIR += stonx
SUBDIR += svr4_base
SUBDIR += tiemu2
+ SUBDIR += tiemu3
SUBDIR += tilem
SUBDIR += tkhfs
SUBDIR += tme
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
new file mode 100644
index 000000000000..3eb173d68166
--- /dev/null
+++ b/emulators/tiemu3/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: tiemu3
+# Date created: 13 Aug 2007
+# Whom: Naram Qashat <cyberbotx@cyberbotx.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiemu3
+PORTVERSION= 3.01
+CATEGORIES= emulators
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= gtktiemu
+
+PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}
+PATCH_SITE_SUBDIR= gtktiemu
+PATCHFILES= ${PORTNAME}-${PORTVERSION}a.diff.bz2
+
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= TI89(ti)/92(+)/V200 hand-helds emulator
+
+LIB_DEPENDS= ticalcs2.6:${PORTSDIR}/comms/libticalcs2 \
+ ticables2.1:${PORTSDIR}/comms/libticables2 \
+ tifiles2.4:${PORTSDIR}/devel/libtifiles2
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -export-dynamic"
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-gdb --mandir=${MANPREFIX}/man
+USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
+USE_SDL= sdl
+
+MAN1= tiemu.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.if defined(WITHOUT_KDE)
+CONFIGURE_ARGS+= --without-kde
+.else
+USE_KDELIBS_VER= 3
+.endif
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -E 's,(install-data-am:).*$$,\1,' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's,defined(__LINUX__),& || defined(__BSD__),' \
+ ${WRKSRC}/src/gui/calc/pckeys.h ${WRKSRC}/src/misc/paths.h
+
+pre-install:
+ ${CHMOD} +x ${WRKSRC}/install-sh
+
+.include <bsd.port.mk>
diff --git a/emulators/tiemu3/distinfo b/emulators/tiemu3/distinfo
new file mode 100644
index 000000000000..ff0919a3d708
--- /dev/null
+++ b/emulators/tiemu3/distinfo
@@ -0,0 +1,6 @@
+MD5 (tiemu3-3.01.tar.bz2) = 7a78a4dfcd64ab9b8119d9574f8a11fa
+SHA256 (tiemu3-3.01.tar.bz2) = 716c4b09243774773cc9c234619a66a8459eb1f3a9c1c1a2e7bb3f28e2b21d51
+SIZE (tiemu3-3.01.tar.bz2) = 21564336
+MD5 (tiemu3-3.01a.diff.bz2) = bce3626a27a185ec8f740a47f4f38941
+SHA256 (tiemu3-3.01a.diff.bz2) = c32d6ce0f44a7a4b2526aebd2060b52c2606eab7239c7be8a65d57415764ccff
+SIZE (tiemu3-3.01a.diff.bz2) = 7209
diff --git a/emulators/tiemu3/pkg-descr b/emulators/tiemu3/pkg-descr
new file mode 100644
index 000000000000..dadfccfa7298
--- /dev/null
+++ b/emulators/tiemu3/pkg-descr
@@ -0,0 +1,9 @@
+This project aims to develop a fast emulator for the TI89(titanium), 92(+),
+and V200PLT calculators. This emulator started on the Jonas Minnberg's
+(X)Tiger emulator which is based on UAE (the Universal Amiga Emulator). It
+was deeply reworked and improved thus it's very different now.
+
+TiEmu uses the GDK library (GTK component) for display. The GUI has been
+written with GTK+ (the Gimp ToolKit).
+
+WWW: http://lpg.ticalc.org/prj_tiemu/
diff --git a/emulators/tiemu3/pkg-plist b/emulators/tiemu3/pkg-plist
new file mode 100644
index 000000000000..849cc1eee763
--- /dev/null
+++ b/emulators/tiemu3/pkg-plist
@@ -0,0 +1,114 @@
+bin/tiemu
+%%NLS%%share/locale/fr/LC_MESSAGES/tiemu.mo
+share/tiemu/Manpage.txt
+share/tiemu/glade/calc-2.glade
+share/tiemu/glade/dbg_bits-2.glade
+share/tiemu/glade/dbg_bkpts-2.glade
+share/tiemu/glade/dbg_cause-2.glade
+share/tiemu/glade/dbg_code-2.glade
+share/tiemu/glade/dbg_data-2.glade
+share/tiemu/glade/dbg_entry-2.glade
+share/tiemu/glade/dbg_heap-2.glade
+share/tiemu/glade/dbg_ioports-2.glade
+share/tiemu/glade/dbg_mem-2.glade
+share/tiemu/glade/dbg_pclog-2.glade
+share/tiemu/glade/dbg_regs-2.glade
+share/tiemu/glade/dbg_stack-2.glade
+share/tiemu/glade/dbg_vectors-2.glade
+share/tiemu/glade/dboxes-2.glade
+share/tiemu/glade/device-2.glade
+share/tiemu/glade/infos-2.glade
+share/tiemu/glade/log_link-2.glade
+share/tiemu/glade/manpage-2.glade
+share/tiemu/glade/pbars-2.glade
+share/tiemu/glade/popup-2.glade
+share/tiemu/glade/quicksend-2.glade
+share/tiemu/glade/release-2.glade
+share/tiemu/glade/romversion-2.glade
+share/tiemu/glade/scroptions-2.glade
+share/tiemu/glade/wizard-2.glade
+share/tiemu/help/FAQ.html
+share/tiemu/help/Manual_en.html
+share/tiemu/help/calc_infos.png
+share/tiemu/help/chapter01.html
+share/tiemu/help/chapter02.html
+share/tiemu/help/chapter03.html
+share/tiemu/help/chapter04.html
+share/tiemu/help/chapter05.html
+share/tiemu/help/chapter06.html
+share/tiemu/help/chapter07.html
+share/tiemu/help/chapter08.html
+share/tiemu/help/chapter09.html
+share/tiemu/help/chapter10.html
+share/tiemu/help/chapter11.html
+share/tiemu/help/chapter20.html
+share/tiemu/help/chapter21.html
+share/tiemu/help/chapter22.html
+share/tiemu/help/dbg_bkpts.png
+share/tiemu/help/dbg_heap.png
+share/tiemu/help/dbg_mem.png
+share/tiemu/help/dbg_registers.png
+share/tiemu/help/dbg_search.png
+share/tiemu/help/dbg_source.png
+share/tiemu/help/dbg_sr.png
+share/tiemu/help/dbg_stack.png
+share/tiemu/help/linkport.png
+share/tiemu/help/log_link.png
+share/tiemu/help/logo_lpg.png
+share/tiemu/help/logo_tiemu.png
+share/tiemu/help/no_skin.png
+share/tiemu/help/popup_menu.png
+share/tiemu/help/romversion.png
+share/tiemu/help/screenshot.png
+share/tiemu/help/skinedit.jpg
+share/tiemu/help/tiemu.jpg
+share/tiemu/help/wizard.png
+share/tiemu/misc/iodefs_ti89_hw1.txt
+share/tiemu/misc/iodefs_ti89_hw2.txt
+share/tiemu/misc/iodefs_ti89t_hw3.txt
+share/tiemu/misc/iodefs_ti89t_hw4.txt
+share/tiemu/misc/iodefs_ti92_hw1.txt
+share/tiemu/misc/iodefs_ti92p_hw1.txt
+share/tiemu/misc/iodefs_ti92p_hw2.txt
+share/tiemu/misc/iodefs_v200_hw2.txt
+share/tiemu/misc/memmap_ti89_hw1.txt
+share/tiemu/misc/memmap_ti89_hw2.txt
+share/tiemu/misc/memmap_ti89t_hw3.txt
+share/tiemu/misc/memmap_ti89t_hw4.txt
+share/tiemu/misc/memmap_ti92_hw1.txt
+share/tiemu/misc/memmap_ti92p_hw1.txt
+share/tiemu/misc/memmap_ti92p_hw2.txt
+share/tiemu/misc/memmap_v200_hw2.txt
+share/tiemu/misc/romcalls.txt
+share/tiemu/pedrom/pedrom89.tib
+share/tiemu/pedrom/pedrom89ti.tib
+share/tiemu/pedrom/pedrom9x.tib
+share/tiemu/pedrom/pedromv2.tib
+share/tiemu/pixmaps/bkpt.xpm
+share/tiemu/pixmaps/bkpt_tmp.xpm
+share/tiemu/pixmaps/icon.xpm
+share/tiemu/pixmaps/logo.xpm
+share/tiemu/pixmaps/romdump.ico
+share/tiemu/pixmaps/romdump.xpm
+share/tiemu/pixmaps/run.xpm
+share/tiemu/pixmaps/void.xpm
+share/tiemu/skins/ipaq_89.skn
+share/tiemu/skins/ipaq_92.skn
+share/tiemu/skins/ipaq_v200plt.skn
+share/tiemu/skins/ti89.map
+share/tiemu/skins/ti89.skn
+share/tiemu/skins/ti89_fr.map
+share/tiemu/skins/ti89t.skn
+share/tiemu/skins/ti92.map
+share/tiemu/skins/ti92.skn
+share/tiemu/skins/ti92_fr.map
+share/tiemu/skins/v200plt.skn
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm share/tiemu/skins
+@dirrm share/tiemu/pixmaps
+@dirrm share/tiemu/pedrom
+@dirrm share/tiemu/misc
+@dirrm share/tiemu/help
+@dirrm share/tiemu/glade
+@dirrm share/tiemu