aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-06-13 20:53:15 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-06-13 20:53:15 +0000
commit33edb218027d79c7b71614269c998ffcdf0a5a49 (patch)
treec363c1fb3f5f4316e8a9ad6ca40574e3f21a37b4 /emulators
parent47e4bebfc4dff9eee146332db7c6fa950e78c6c3 (diff)
downloadports-33edb218027d79c7b71614269c998ffcdf0a5a49.tar.gz
ports-33edb218027d79c7b71614269c998ffcdf0a5a49.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/simh-hp3000/Makefile46
-rw-r--r--emulators/simh-hp3000/distinfo3
-rw-r--r--emulators/simh-hp3000/files/LICENSE23
-rw-r--r--emulators/simh-hp3000/files/hp3000.1.in72
-rw-r--r--emulators/simh-hp3000/pkg-descr6
-rw-r--r--emulators/simh-hp3000/pkg-plist5
7 files changed, 156 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index bfdcd211e909..aca5784de6a6 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -125,6 +125,7 @@
SUBDIR += rubygem-fission
SUBDIR += simh
SUBDIR += simh-hp2100
+ SUBDIR += simh-hp3000
SUBDIR += simh-hpdoc
SUBDIR += skyeye
SUBDIR += snes9x-gtk
diff --git a/emulators/simh-hp3000/Makefile b/emulators/simh-hp3000/Makefile
new file mode 100644
index 000000000000..c0527c833566
--- /dev/null
+++ b/emulators/simh-hp3000/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= hp3000
+DISTVERSION= 3.11-0.8
+CATEGORIES= emulators
+MASTER_SITES= http://simh.trailing-edge.com/hp/releases/:src \
+ http://simh.trailing-edge.com/hp/docs/:app \
+ http://www.ml1.org.uk/distfiles/:src \
+ http://www.ml1.org.uk/distfiles/:app
+PKGNAMEPREFIX= simh-
+DISTFILES= HP3000-source-release-${DISTVERSION:E}.zip:src
+DIST_SUBDIR= simh-hp
+EXTRACT_ONLY= HP3000-source-release-${DISTVERSION:E}.zip
+
+MAINTAINER= bob@eager.cx
+COMMENT= Emulates classic HP 3000 computers
+
+LICENSE= SIMHv1
+LICENSE_NAME= SIMH License
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${LOCALBASE}/share/doc/hpdoc/simh_doc.pdf:emulators/simh-hpdoc
+
+USES= gmake dos2unix zip
+
+NO_WRKSUBDIR= yes
+
+CONFLICTS_INSTALL= simh-3.[789]*
+DOS2UNIX_GLOB= *.c *.h *.txt *.mak makefile
+
+SUB_FILES= hp3000.1
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ (cd ${WRKSRC}; GCC=clang ${GMAKE} -C SCP hp3000)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hp3000 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKDIR}/hp3000.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/SCP/doc/*.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/SCP/doc/hp3000_guide.pdf ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/simh-hp3000/distinfo b/emulators/simh-hp3000/distinfo
new file mode 100644
index 000000000000..2ed4cabd9a23
--- /dev/null
+++ b/emulators/simh-hp3000/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582502963
+SHA256 (simh-hp/HP3000-source-release-8.zip) = 2c003841b8c189299d45253520fd687694687c0a023aae9c79650234948b5a66
+SIZE (simh-hp/HP3000-source-release-8.zip) = 1412655
diff --git a/emulators/simh-hp3000/files/LICENSE b/emulators/simh-hp3000/files/LICENSE
new file mode 100644
index 000000000000..c613c9a7c183
--- /dev/null
+++ b/emulators/simh-hp3000/files/LICENSE
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject
+to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the names of the authors shall not
+be used in advertising or otherwise to promote the sale, use or other
+dealings in this Software without prior written authorization from the
+authors.
diff --git a/emulators/simh-hp3000/files/hp3000.1.in b/emulators/simh-hp3000/files/hp3000.1.in
new file mode 100644
index 000000000000..fcfb5ac8e7c3
--- /dev/null
+++ b/emulators/simh-hp3000/files/hp3000.1.in
@@ -0,0 +1,72 @@
+.Dd February 23, 2020
+.Dt HP3000 1 CON
+.Os
+.Sh NAME
+.Nm hp3000
+.Nd Simulator for HP 3000 series computers
+.Sh SYNOPSIS
+.Nm
+.Op Fl e
+.Op Fl q
+.Op Fl v
+.Oo
+.Ar startup-file
+.Op Ar arguments
+.Oc
+.Sh DESCRIPTION
+.Nm
+is a simulator for the classic SIO machines. This group consists of the
+3000 CX, the Series I, Series II, and the HP 3000 Series III that is
+simulated here. A large variety of CPU options, device interface cards,
+and peripherals are provided.
+.Pp
+The following options are available:
+.Bl -tag -width indent
+.It Fl e
+Processing of
+.Ar startup-file
+(including nested command invocations) is aborted if
+a command error is encountered.
+.It Fl q
+Certain informational messages are suppressed.
+.It Fl v
+The commands in
+.Ar startup-file
+are echoed before they are executed.
+.El
+.Pp
+If
+.Ar startup-file
+is specified, it is used as an initial source of simulator commands.
+If
+.Ar startup-file
+is not specified, default locations are searched. See the
+.Em SIMH User's Supplement
+for more details.
+.Pp
+If a startup file is specified, either on the
+command line or otherwise,
+it should contain a series of non-interactive simulator
+commands, one per line.
+These commands can be used to set up standard parameters.
+.Pp
+After initializing its internal structures and processing the startup file (if any),
+the simulator types out its name and version and then prompts for input with:
+.Bd -ragged -offset indent
+.Sy sim>
+.Ed
+.Sh EXIT STATUS
+.Nm
+exits 0 on success, and >0 if an error occurs.
+.Sh SEE ALSO
+Documentation is available; it can be found locally in
+.Pa %%DOCSDIR%%
+(if installed), and also at
+.Pa http://simh.trailing-edge.com/hp/#Documentation .
+.Sh SEE ALSO
+.Xr hp2100 1 ,
+.Xr hpdoc 1 .
+.Sh AUTHORS
+.An "J. David Bryan, Robert M. Supnik and others" .
+.Fx "port maintenance, and this manual page, by"
+.An "Bob Eager" Aq bob@eager.cx .
diff --git a/emulators/simh-hp3000/pkg-descr b/emulators/simh-hp3000/pkg-descr
new file mode 100644
index 000000000000..26b6271cc3dc
--- /dev/null
+++ b/emulators/simh-hp3000/pkg-descr
@@ -0,0 +1,6 @@
+hp3000 is a simulator for the classic SIO machines. This group consists
+of the 3000 CX, the Series I, Series II, and the HP 3000 Series III that
+is simulated here. A large variety of CPU options, device interface
+cards, and peripherals are provided.
+
+WWW: http://simh.trailing-edge.com/hp/
diff --git a/emulators/simh-hp3000/pkg-plist b/emulators/simh-hp3000/pkg-plist
new file mode 100644
index 000000000000..99462c646d20
--- /dev/null
+++ b/emulators/simh-hp3000/pkg-plist
@@ -0,0 +1,5 @@
+bin/hp3000
+man/man1/hp3000.1.gz
+%%DOCSDIR%%/hp3000_diag.txt
+%%DOCSDIR%%/hp3000_guide.pdf
+%%DOCSDIR%%/hp3000_release.txt