aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-12-31 00:12:20 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-12-31 00:12:20 +0000
commit58ed0a6bf93ee4d0c21ee29f5026df11e203ade7 (patch)
treea3ec173d46415e364857f408becea5bba432971b /emulators
parentab27b4344018fbfb38ff3398bfeb42daa73849df (diff)
downloadports-58ed0a6bf93ee4d0c21ee29f5026df11e203ade7.tar.gz
ports-58ed0a6bf93ee4d0c21ee29f5026df11e203ade7.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile18
-rw-r--r--emulators/qemu-devel/distinfo9
-rw-r--r--emulators/qemu/Makefile18
-rw-r--r--emulators/qemu/distinfo9
4 files changed, 46 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 74bf2975086e..c4e701205973 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -12,8 +12,14 @@ CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
http://www.volny.cz/xnavara/qemu/:snapshot \
- http://qemu.dad-answers.com/download/qemu/:snapshot
+ http://qemu.dad-answers.com/download/qemu/:snapshot \
+ http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
+.if defined (WITH_HACKS)
+DISTFILES+= qemu_dma_patch.tar.gz:idedma
+.endif
+DIST_SUBDIR= qemu
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= QEMU CPU Emulator
@@ -54,6 +60,11 @@ pre-everything::
@${ECHO_MSG} "Notice: you can build qemu with the (alpha!) kqemu accelerator kernel module"
@${ECHO_MSG} "by defining WITH_KQEMU."
.endif
+.if !defined(WITH_HACKS)
+ @${ECHO_MSG} "You can build qemu with some hacks (esp. for speedup)"
+ @${ECHO_MSG} "by defining WITH_HACKS."
+ @${ECHO_MSG} "1. IDE Bus-master DMA Support by John Coiner"
+.endif
.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
@${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
@${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
@@ -70,6 +81,11 @@ pre-patch:
${MKDIR} ${WRKSRC}/bsd/$$A; \
done
+post-patch:
+.if defined(WITH_HACKS)
+ @cd ${WRKDIR} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/qemu_dma_patch.tar.gz ; ${CP} new_qemu_dma_patch/bios.bin ${WRKSRC}/pc-bios; cd ${WRKSRC}; ${PATCH} -p1 < ../new_qemu_dma_patch/qemu-piix4-udma.patch
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index fc978c5d5f4e..57c380becdc7 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,3 +1,6 @@
-MD5 (qemu-0.8.0.tar.gz) = eb175b26583280706fe7e4d8910d320d
-SHA256 (qemu-0.8.0.tar.gz) = de388539ce86971a2cbe8474fca8b6160898c95772e3e6e08a7794d48db32a61
-SIZE (qemu-0.8.0.tar.gz) = 1497965
+MD5 (qemu/qemu-0.8.0.tar.gz) = eb175b26583280706fe7e4d8910d320d
+SHA256 (qemu/qemu-0.8.0.tar.gz) = de388539ce86971a2cbe8474fca8b6160898c95772e3e6e08a7794d48db32a61
+SIZE (qemu/qemu-0.8.0.tar.gz) = 1497965
+MD5 (qemu/qemu_dma_patch.tar.gz) = 5e339dc201d411af56bad684d3f89338
+SHA256 (qemu/qemu_dma_patch.tar.gz) = cdf74bf5e079d835e100f116d940686b13ec2b7ed6aee5a6a97a4441ea5f2b8f
+SIZE (qemu/qemu_dma_patch.tar.gz) = 25837
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 74bf2975086e..c4e701205973 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -12,8 +12,14 @@ CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
http://www.volny.cz/xnavara/qemu/:snapshot \
- http://qemu.dad-answers.com/download/qemu/:snapshot
+ http://qemu.dad-answers.com/download/qemu/:snapshot \
+ http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
+.if defined (WITH_HACKS)
+DISTFILES+= qemu_dma_patch.tar.gz:idedma
+.endif
+DIST_SUBDIR= qemu
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= QEMU CPU Emulator
@@ -54,6 +60,11 @@ pre-everything::
@${ECHO_MSG} "Notice: you can build qemu with the (alpha!) kqemu accelerator kernel module"
@${ECHO_MSG} "by defining WITH_KQEMU."
.endif
+.if !defined(WITH_HACKS)
+ @${ECHO_MSG} "You can build qemu with some hacks (esp. for speedup)"
+ @${ECHO_MSG} "by defining WITH_HACKS."
+ @${ECHO_MSG} "1. IDE Bus-master DMA Support by John Coiner"
+.endif
.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
@${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
@${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
@@ -70,6 +81,11 @@ pre-patch:
${MKDIR} ${WRKSRC}/bsd/$$A; \
done
+post-patch:
+.if defined(WITH_HACKS)
+ @cd ${WRKDIR} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/qemu_dma_patch.tar.gz ; ${CP} new_qemu_dma_patch/bios.bin ${WRKSRC}/pc-bios; cd ${WRKSRC}; ${PATCH} -p1 < ../new_qemu_dma_patch/qemu-piix4-udma.patch
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index fc978c5d5f4e..57c380becdc7 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,6 @@
-MD5 (qemu-0.8.0.tar.gz) = eb175b26583280706fe7e4d8910d320d
-SHA256 (qemu-0.8.0.tar.gz) = de388539ce86971a2cbe8474fca8b6160898c95772e3e6e08a7794d48db32a61
-SIZE (qemu-0.8.0.tar.gz) = 1497965
+MD5 (qemu/qemu-0.8.0.tar.gz) = eb175b26583280706fe7e4d8910d320d
+SHA256 (qemu/qemu-0.8.0.tar.gz) = de388539ce86971a2cbe8474fca8b6160898c95772e3e6e08a7794d48db32a61
+SIZE (qemu/qemu-0.8.0.tar.gz) = 1497965
+MD5 (qemu/qemu_dma_patch.tar.gz) = 5e339dc201d411af56bad684d3f89338
+SHA256 (qemu/qemu_dma_patch.tar.gz) = cdf74bf5e079d835e100f116d940686b13ec2b7ed6aee5a6a97a4441ea5f2b8f
+SIZE (qemu/qemu_dma_patch.tar.gz) = 25837