aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-08-29 02:23:58 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-08-29 02:23:58 +0000
commit834586c272e259bd1fca9f75f8e7a4298d16733f (patch)
tree7cf47dc34a3e2568848819eaf6cbf8a2ebf689dd /emulators
parent70e88083b552bb632e3da82532c3453581396672 (diff)
downloadports-834586c272e259bd1fca9f75f8e7a4298d16733f.tar.gz
ports-834586c272e259bd1fca9f75f8e7a4298d16733f.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/simh-hp3000/Makefile4
-rw-r--r--emulators/simh-hp3000/files/patch-SCP_makefile17
2 files changed, 19 insertions, 2 deletions
diff --git a/emulators/simh-hp3000/Makefile b/emulators/simh-hp3000/Makefile
index 0b235ab19d50..2980be57db5b 100644
--- a/emulators/simh-hp3000/Makefile
+++ b/emulators/simh-hp3000/Makefile
@@ -22,7 +22,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${LOCALBASE}/share/doc/hpdoc/simh_doc.pdf:emulators/simh-hpdoc
-USES= compiler gmake dos2unix zip
+USES= gmake dos2unix zip
NO_WRKSUBDIR= yes
@@ -34,7 +34,7 @@ SUB_FILES= hp3000.1
.include <bsd.port.pre.mk>
do-build:
- (cd ${WRKSRC}; GCC=${CHOSEN_COMPILER_TYPE} ${GMAKE} -C SCP hp3000)
+ (cd ${WRKSRC}; GCC=${CC} ${GMAKE} -C SCP hp3000)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hp3000 ${STAGEDIR}${PREFIX}/bin
diff --git a/emulators/simh-hp3000/files/patch-SCP_makefile b/emulators/simh-hp3000/files/patch-SCP_makefile
new file mode 100644
index 000000000000..1a83c734a73e
--- /dev/null
+++ b/emulators/simh-hp3000/files/patch-SCP_makefile
@@ -0,0 +1,17 @@
+--- SCP/makefile.orig 2020-08-23 21:58:56 UTC
++++ SCP/makefile
+@@ -532,10 +532,12 @@ ifneq ($(DONT_USE_READER_THREAD),)
+ endif
+
+
+-# Shut up annoying clang default warnings.
++# Shut up annoying clang default warnings, and also fix
++# multiply defined symbols on clang 11 and above
+
+-ifeq ($(GCC),clang)
++ifeq ($(findstring clang,$(COMPILER_NAME)),clang)
+ OS_CCDEFS += -Wno-parentheses -Wno-bitwise-op-parentheses -Wno-dangling-else
++ CFLAGS_O += -fcommon
+ endif
+
+