aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-29 02:33:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-29 02:33:58 +0000
commitbb08e4a3ac9becb6727a94ffa6817140fc490992 (patch)
tree956f3a5f0749912f771137bbb22cefef17e50337 /emulators
parent2e4fa96fabaf0020333c1f8bea651b6f33435169 (diff)
downloadports-bb08e4a3ac9becb6727a94ffa6817140fc490992.tar.gz
ports-bb08e4a3ac9becb6727a94ffa6817140fc490992.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ppsspp/Makefile1
-rw-r--r--emulators/ppsspp/files/patch-no-egl18
2 files changed, 18 insertions, 1 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 82fdbbf415a2..dc673035622e 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -36,7 +36,6 @@ EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
USE_GL= gl glew glu
USE_SDL= sdl2 # joystick
CMAKE_ON= USE_SYSTEM_FFMPEG USE_SYSTEM_LIBZIP
-CMAKE_OFF= USING_EGL
SUB_FILES= pkg-message
PORTDATA= assets ${PORTNAME}
diff --git a/emulators/ppsspp/files/patch-no-egl b/emulators/ppsspp/files/patch-no-egl
new file mode 100644
index 000000000000..962d800fc960
--- /dev/null
+++ b/emulators/ppsspp/files/patch-no-egl
@@ -0,0 +1,18 @@
+EGL hangs on X11 and doesn't build without GLESv2.
+https://github.com/hrydgard/ppsspp/issues/10626
+
+--- CMakeLists.txt.orig 2017-12-05 13:51:51 UTC
++++ CMakeLists.txt
+@@ -56,12 +56,6 @@ include(ccache)
+ # Remove soon?
+ set(USE_FFMPEG ON)
+
+-if(NOT ANDROID AND NOT IOS)
+- if(ARM OR SIMULATOR)
+- set(USING_EGL ON)
+- endif()
+-endif()
+-
+ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ set(LINUX ON)
+ add_definitions(-D__STDC_CONSTANT_MACROS)