aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2005-03-15 05:17:10 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2005-03-15 05:17:10 +0000
commitc9d38a9570cae36cf2f0f60c2d0adacf024e5a95 (patch)
tree97cf022900c9b11943ebda0225252c02654e9b81 /emulators
parent6694f5c53aa27ec72df18835da0174a83ce7e11d (diff)
downloadports-c9d38a9570cae36cf2f0f60c2d0adacf024e5a95.tar.gz
ports-c9d38a9570cae36cf2f0f60c2d0adacf024e5a95.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux_base-src-rh-8/Makefile66
-rw-r--r--emulators/linux_base-src-rh-8/distinfo46
-rw-r--r--emulators/linux_base-src-rh-8/pkg-descr8
4 files changed, 121 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index b0d40d41c851..69200fb08e1d 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -59,6 +59,7 @@
SUBDIR += linux_base-gentoo-stage1
SUBDIR += linux_base-rh-9
SUBDIR += linux_base-src-rh-7.3
+ SUBDIR += linux_base-src-rh-8
SUBDIR += linux_base-suse-9.1
SUBDIR += linux_base-suse-9.2
SUBDIR += mastergear
diff --git a/emulators/linux_base-src-rh-8/Makefile b/emulators/linux_base-src-rh-8/Makefile
new file mode 100644
index 000000000000..9c57c698773b
--- /dev/null
+++ b/emulators/linux_base-src-rh-8/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: linux_base-src-rh-8
+# Date created: 2003-09-28
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux_base-src-rh-8
+PORTVERSION= 8.0
+CATEGORIES= emulators linux
+MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX} \
+ ${MASTER_SITE_REDHAT_LINUX:S/$/:new/}
+MASTER_SITE_SUBDIR= 8.0/en/os/i386/SRPMS updates/8.0/en/os/SRPMS/:new
+# The rpm and popt sources are packaged together.
+DISTFILES= \
+ acl-2.0.11-2.src.rpm \
+ attr-2.0.8-3.src.rpm \
+ basesystem-8.0-1.src.rpm \
+ bash-2.05b-5.src.rpm \
+ compat-gcc-7.3-2.96.110.src.rpm \
+ filesystem-2.1.6-5.src.rpm \
+ fileutils-4.1.9-11.src.rpm \
+ gcc-3.2-7.src.rpm \
+ gdbm-1.8.0-18.src.rpm \
+ glib-1.2.10-8.src.rpm \
+ glibc-2.3.2-4.80.8.src.rpm:new \
+ grep-2.5.1-4.src.rpm \
+ libelf-0.8.2-2.src.rpm \
+ libtermcap-2.0.8-31.src.rpm \
+ readline-4.3-3.src.rpm \
+ redhat-release-8.0-8.src.rpm \
+ rpm-4.1-1.06.src.rpm \
+ setserial-2.17-9.src.rpm \
+ setup-2.5.20-1.src.rpm \
+ sh-utils-2.0.12-3.src.rpm \
+ termcap-11.0.1-13.src.rpm \
+ texinfo-4.2-5.src.rpm
+EXTRACT_ONLY=
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= (L)GPL sources for linux_base-8, to comply with licences
+
+.undef USE_LINUX
+
+DIST_SUBDIR= rpm/src/rh-${PORTVERSION}
+NO_MTREE= yes
+PLIST= ${WRKDIR}/plist
+PREFIX= ${LINUXBASE}
+
+do-build:
+ ${RM} -f ${PLIST}
+.for ii in ${DISTFILES:S/:new//}
+ ${ECHO_MSG} ${ii}
+ ${ECHO_CMD} usr/src/redhat/SRPMS/${ii} >> ${PLIST}
+.endfor
+.for ii in /SRPMS /
+ ${ECHO_CMD} @dirrm usr/src/redhat${ii} >> ${PLIST}
+.endfor
+
+do-install:
+ - ${MKDIR} ${PREFIX}/usr/src/redhat/SRPMS
+.for ii in ${DISTFILES:S/:new//}
+ ${CP} -p ${DISTDIR}/${DIST_SUBDIR}/${ii} ${PREFIX}/usr/src/redhat/SRPMS/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/emulators/linux_base-src-rh-8/distinfo b/emulators/linux_base-src-rh-8/distinfo
new file mode 100644
index 000000000000..e9f428b449bb
--- /dev/null
+++ b/emulators/linux_base-src-rh-8/distinfo
@@ -0,0 +1,46 @@
+MD5 (rpm/src/rh-8.0/acl-2.0.11-2.src.rpm) = 0bb030e8faf2416d16e4b5fc11c711f3
+SIZE (rpm/src/rh-8.0/acl-2.0.11-2.src.rpm) = 127736
+MD5 (rpm/src/rh-8.0/attr-2.0.8-3.src.rpm) = af8acbccf48420d9f701b97139fdfe73
+SIZE (rpm/src/rh-8.0/attr-2.0.8-3.src.rpm) = 83395
+MD5 (rpm/src/rh-8.0/basesystem-8.0-1.src.rpm) = beedf394dc3ef9a7e31bfecfa4a76ffd
+SIZE (rpm/src/rh-8.0/basesystem-8.0-1.src.rpm) = 3424
+MD5 (rpm/src/rh-8.0/bash-2.05b-5.src.rpm) = 78e294cb020aecfdc6b7f28a19609171
+SIZE (rpm/src/rh-8.0/bash-2.05b-5.src.rpm) = 3066576
+MD5 (rpm/src/rh-8.0/compat-gcc-7.3-2.96.110.src.rpm) = 6a13e80b2a7cc54b9c4595b686990b31
+SIZE (rpm/src/rh-8.0/compat-gcc-7.3-2.96.110.src.rpm) = 18722423
+MD5 (rpm/src/rh-8.0/filesystem-2.1.6-5.src.rpm) = 017f5771c48cc2c94795f7b5eb05b9f6
+SIZE (rpm/src/rh-8.0/filesystem-2.1.6-5.src.rpm) = 9365
+MD5 (rpm/src/rh-8.0/fileutils-4.1.9-11.src.rpm) = 70fd00dc8fc629e23a1714ed608888d6
+SIZE (rpm/src/rh-8.0/fileutils-4.1.9-11.src.rpm) = 1703053
+MD5 (rpm/src/rh-8.0/gcc-3.2-7.src.rpm) = 23d5089960d8fc7d973ce5c42940c5e8
+SIZE (rpm/src/rh-8.0/gcc-3.2-7.src.rpm) = 20735638
+MD5 (rpm/src/rh-8.0/gdbm-1.8.0-18.src.rpm) = e4cc39db2e4467a30e5221d787249ed9
+SIZE (rpm/src/rh-8.0/gdbm-1.8.0-18.src.rpm) = 143356
+MD5 (rpm/src/rh-8.0/glib-1.2.10-8.src.rpm) = c416d1428e38ffeba796422cd09de204
+SIZE (rpm/src/rh-8.0/glib-1.2.10-8.src.rpm) = 428348
+MD5 (rpm/src/rh-8.0/glibc-2.3.2-4.80.8.src.rpm) = d6c96dff6893d449a57439ec3b362ded
+SIZE (rpm/src/rh-8.0/glibc-2.3.2-4.80.8.src.rpm) = 12935811
+MD5 (rpm/src/rh-8.0/grep-2.5.1-4.src.rpm) = 65fade50d1f37eb44f7a3859c1ec38a0
+SIZE (rpm/src/rh-8.0/grep-2.5.1-4.src.rpm) = 566656
+MD5 (rpm/src/rh-8.0/libelf-0.8.2-2.src.rpm) = f6a936ae0a609c9e929de6e869105e5e
+SIZE (rpm/src/rh-8.0/libelf-0.8.2-2.src.rpm) = 119960
+MD5 (rpm/src/rh-8.0/libtermcap-2.0.8-31.src.rpm) = c982dd992f9c44d19c31ff844a92825f
+SIZE (rpm/src/rh-8.0/libtermcap-2.0.8-31.src.rpm) = 226211
+MD5 (rpm/src/rh-8.0/readline-4.3-3.src.rpm) = 83360d27084fe68db87fc3a38dfd8436
+SIZE (rpm/src/rh-8.0/readline-4.3-3.src.rpm) = 760754
+MD5 (rpm/src/rh-8.0/redhat-release-8.0-8.src.rpm) = 86677f85811a2f362493e1652b1dc177
+SIZE (rpm/src/rh-8.0/redhat-release-8.0-8.src.rpm) = 390643
+MD5 (rpm/src/rh-8.0/rpm-4.1-1.06.src.rpm) = 7d56431377876c25f16a84440b3fb1a0
+SIZE (rpm/src/rh-8.0/rpm-4.1-1.06.src.rpm) = 6472368
+MD5 (rpm/src/rh-8.0/setserial-2.17-9.src.rpm) = 04f10d4b91d225cc616d83fc08120aeb
+SIZE (rpm/src/rh-8.0/setserial-2.17-9.src.rpm) = 59446
+MD5 (rpm/src/rh-8.0/setup-2.5.20-1.src.rpm) = 335786e27611343499c6e133ad70e89e
+SIZE (rpm/src/rh-8.0/setup-2.5.20-1.src.rpm) = 34209
+MD5 (rpm/src/rh-8.0/sh-utils-2.0.12-3.src.rpm) = bb2fd0033193611a961e2c6f8c3daa50
+SIZE (rpm/src/rh-8.0/sh-utils-2.0.12-3.src.rpm) = 1322535
+MD5 (rpm/src/rh-8.0/termcap-11.0.1-13.src.rpm) = 57eb3ff1b7fc20e0fb9c9ff20c149edc
+SIZE (rpm/src/rh-8.0/termcap-11.0.1-13.src.rpm) = 206777
+MD5 (rpm/src/rh-8.0/texinfo-4.2-5.src.rpm) = 6a1a5f82df7799697cacbbd1f42e9d32
+SIZE (rpm/src/rh-8.0/texinfo-4.2-5.src.rpm) = 1218364
+MD5 (rpm/src/rh-8.0/freetype-2.1.2-7.src.rpm) = f2f26e5fa88dd8f31dad0b8667afa6b2
+SIZE (rpm/src/rh-8.0/freetype-2.1.2-7.src.rpm) = 1727397
diff --git a/emulators/linux_base-src-rh-8/pkg-descr b/emulators/linux_base-src-rh-8/pkg-descr
new file mode 100644
index 000000000000..0d51a3014e04
--- /dev/null
+++ b/emulators/linux_base-src-rh-8/pkg-descr
@@ -0,0 +1,8 @@
+This port contains the sources for the packages in linux_base-8. It exists for
+licencing purposes. If you distribute the linux_base-8 binary package or the
+distfiles for it, which are also precompiled binaries, you can satisfy the
+requirements of the GNU GPL by offering this package to your customers. Sources
+for RPM packages with other licences are omitted.
+
+This port takes roughly 66 MB of space when installed. The package and
+distfiles are a similar size.