aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2006-02-02 13:22:47 +0000
committerMax Khon <fjoe@FreeBSD.org>2006-02-02 13:22:47 +0000
commitf2a391d1fb88fd4462a201dc79631f2d8e1db480 (patch)
tree4b4b492dcd4892d0f75f6937368332fd548fea46 /emulators
parent4222e06413cfc08111b1cd7fae0422af1dcea624 (diff)
downloadports-f2a391d1fb88fd4462a201dc79631f2d8e1db480.tar.gz
ports-f2a391d1fb88fd4462a201dc79631f2d8e1db480.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/dynamips-devel/Makefile46
-rw-r--r--emulators/dynamips-devel/distinfo3
-rw-r--r--emulators/dynamips-devel/files/patch-Makefile68
-rw-r--r--emulators/dynamips-devel/pkg-descr3
-rw-r--r--emulators/dynamips/Makefile46
-rw-r--r--emulators/dynamips/distinfo3
-rw-r--r--emulators/dynamips/files/patch-Makefile68
-rw-r--r--emulators/dynamips/pkg-descr3
9 files changed, 241 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 226d92cca8f0..ec90d4f8e19c 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -19,6 +19,7 @@
SUBDIR += dlx
SUBDIR += dosbox
SUBDIR += doscmd
+ SUBDIR += dynamips
SUBDIR += e-uae
SUBDIR += extract-xiso
SUBDIR += fceu
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
new file mode 100644
index 000000000000..412b94e92019
--- /dev/null
+++ b/emulators/dynamips-devel/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: dynamips
+# Date created: 31 Jan 2006
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamips
+PORTVERSION= 0.2.3b
+CATEGORIES= sysutils
+MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= Cisco 7200 Simulator
+
+LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
+ PTHREAD_LIBS=${PTHREAD_LIBS}
+
+PLIST_FILES= bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+DYNAMIPS_ARCH= "x86"
+.elif ${ARCH} == "amd64"
+DYNAMIPS_ARCH= "amd64"
+.else
+DYNAMIPS_ARCH= "nojit"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/dynamips-devel/distinfo b/emulators/dynamips-devel/distinfo
new file mode 100644
index 000000000000..076ba7c1eaff
--- /dev/null
+++ b/emulators/dynamips-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (dynamips-0.2.3b.tar.gz) = 5ec12dedc04391aed8c8f4c7b22c5c75
+SHA256 (dynamips-0.2.3b.tar.gz) = 3764e2cd967674097118637484bc0855ffeac515190a8f13991b0189fbf2b5b6
+SIZE (dynamips-0.2.3b.tar.gz) = 182549
diff --git a/emulators/dynamips-devel/files/patch-Makefile b/emulators/dynamips-devel/files/patch-Makefile
new file mode 100644
index 000000000000..e73318ef8e00
--- /dev/null
+++ b/emulators/dynamips-devel/files/patch-Makefile
@@ -0,0 +1,68 @@
+--- Makefile.orig Mon Jan 30 19:09:47 2006
++++ Makefile Tue Jan 31 01:38:09 2006
+@@ -3,7 +3,7 @@
+
+ # Replace x86 by amd64 for a build on x86_64.
+ # Use "nojit" for architectures that are not x86 or x86_64.
+-ARCH=x86
++DYNAMIPS_ARCH=x86
+
+ # Change this to 0 if your system doesn't support RFC 2553 extensions
+ HAS_RFC2553=1
+@@ -11,21 +11,21 @@
+ # Current dynamips release
+ VERSION=0.2.3b
+
+-CC=gcc
++CC?=gcc
+ LD=ld
+ RM=rm
+ TAR=tar
+ CP=cp
+ LEX=flex
+-ARCH_INC_FILE=\"$(ARCH)_trans.h\"
+-CFLAGS=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(ARCH)\" \
++ARCH_INC_FILE=\"$(DYNAMIPS_ARCH)_trans.h\"
++CFLAGS+=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" \
+ -DARCH_INC_FILE=$(ARCH_INC_FILE) \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
+ -DHAS_RFC2553=$(HAS_RFC2553)
+
+ ifeq ($(shell uname), FreeBSD)
+- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
+- LIBS=-L/usr/local/lib -L. -lelf -pthread
++ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
++ LIBS=-L$(LOCALBASE)/lib -lelf $(PTHREAD_LIBS)
+ else
+ ifeq ($(shell uname -o), Cygwin)
+ CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
+@@ -61,17 +61,17 @@
+ #SOURCES += profiler.c
+ #CFLAGS += -p -DPROFILE -DPROFILE_FILE=\"$(PROG).profile\"
+
+-ifeq ($(ARCH),x86)
++ifeq ($(DYNAMIPS_ARCH),x86)
+ HDR += x86-codegen.h x86_trans.h
+ SOURCES += x86_trans.c
+ endif
+
+-ifeq ($(ARCH),amd64)
++ifeq ($(DYNAMIPS_ARCH),amd64)
+ HDR += x86-codegen.h amd64-codegen.h amd64_trans.h
+ SOURCES += amd64_trans.c
+ endif
+
+-ifeq ($(ARCH),nojit)
++ifeq ($(DYNAMIPS_ARCH),nojit)
+ HDR += nojit_trans.h
+ SOURCES += nojit_trans.c
+ endif
+@@ -101,7 +101,7 @@
+
+ .PHONY: microcode
+ microcode:
+- @$(CC) -Wall -o rom2c rom2c.c $(LIBS)
++ @$(CC) -Wall $(CFLAGS) -o rom2c rom2c.c $(LIBS)
+ @./rom2c microcode microcode_dump.inc
+
+ .PHONY: clean
diff --git a/emulators/dynamips-devel/pkg-descr b/emulators/dynamips-devel/pkg-descr
new file mode 100644
index 000000000000..f4f8a8d23601
--- /dev/null
+++ b/emulators/dynamips-devel/pkg-descr
@@ -0,0 +1,3 @@
+Cisco 7200 simulator.
+
+WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
new file mode 100644
index 000000000000..412b94e92019
--- /dev/null
+++ b/emulators/dynamips/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: dynamips
+# Date created: 31 Jan 2006
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamips
+PORTVERSION= 0.2.3b
+CATEGORIES= sysutils
+MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= Cisco 7200 Simulator
+
+LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
+ PTHREAD_LIBS=${PTHREAD_LIBS}
+
+PLIST_FILES= bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+DYNAMIPS_ARCH= "x86"
+.elif ${ARCH} == "amd64"
+DYNAMIPS_ARCH= "amd64"
+.else
+DYNAMIPS_ARCH= "nojit"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/dynamips/distinfo b/emulators/dynamips/distinfo
new file mode 100644
index 000000000000..076ba7c1eaff
--- /dev/null
+++ b/emulators/dynamips/distinfo
@@ -0,0 +1,3 @@
+MD5 (dynamips-0.2.3b.tar.gz) = 5ec12dedc04391aed8c8f4c7b22c5c75
+SHA256 (dynamips-0.2.3b.tar.gz) = 3764e2cd967674097118637484bc0855ffeac515190a8f13991b0189fbf2b5b6
+SIZE (dynamips-0.2.3b.tar.gz) = 182549
diff --git a/emulators/dynamips/files/patch-Makefile b/emulators/dynamips/files/patch-Makefile
new file mode 100644
index 000000000000..e73318ef8e00
--- /dev/null
+++ b/emulators/dynamips/files/patch-Makefile
@@ -0,0 +1,68 @@
+--- Makefile.orig Mon Jan 30 19:09:47 2006
++++ Makefile Tue Jan 31 01:38:09 2006
+@@ -3,7 +3,7 @@
+
+ # Replace x86 by amd64 for a build on x86_64.
+ # Use "nojit" for architectures that are not x86 or x86_64.
+-ARCH=x86
++DYNAMIPS_ARCH=x86
+
+ # Change this to 0 if your system doesn't support RFC 2553 extensions
+ HAS_RFC2553=1
+@@ -11,21 +11,21 @@
+ # Current dynamips release
+ VERSION=0.2.3b
+
+-CC=gcc
++CC?=gcc
+ LD=ld
+ RM=rm
+ TAR=tar
+ CP=cp
+ LEX=flex
+-ARCH_INC_FILE=\"$(ARCH)_trans.h\"
+-CFLAGS=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(ARCH)\" \
++ARCH_INC_FILE=\"$(DYNAMIPS_ARCH)_trans.h\"
++CFLAGS+=-g -Wall -O3 -fomit-frame-pointer -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" \
+ -DARCH_INC_FILE=$(ARCH_INC_FILE) \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
+ -DHAS_RFC2553=$(HAS_RFC2553)
+
+ ifeq ($(shell uname), FreeBSD)
+- CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
+- LIBS=-L/usr/local/lib -L. -lelf -pthread
++ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
++ LIBS=-L$(LOCALBASE)/lib -lelf $(PTHREAD_LIBS)
+ else
+ ifeq ($(shell uname -o), Cygwin)
+ CFLAGS+=-I/usr/local/include -I/usr/local/include/libelf
+@@ -61,17 +61,17 @@
+ #SOURCES += profiler.c
+ #CFLAGS += -p -DPROFILE -DPROFILE_FILE=\"$(PROG).profile\"
+
+-ifeq ($(ARCH),x86)
++ifeq ($(DYNAMIPS_ARCH),x86)
+ HDR += x86-codegen.h x86_trans.h
+ SOURCES += x86_trans.c
+ endif
+
+-ifeq ($(ARCH),amd64)
++ifeq ($(DYNAMIPS_ARCH),amd64)
+ HDR += x86-codegen.h amd64-codegen.h amd64_trans.h
+ SOURCES += amd64_trans.c
+ endif
+
+-ifeq ($(ARCH),nojit)
++ifeq ($(DYNAMIPS_ARCH),nojit)
+ HDR += nojit_trans.h
+ SOURCES += nojit_trans.c
+ endif
+@@ -101,7 +101,7 @@
+
+ .PHONY: microcode
+ microcode:
+- @$(CC) -Wall -o rom2c rom2c.c $(LIBS)
++ @$(CC) -Wall $(CFLAGS) -o rom2c rom2c.c $(LIBS)
+ @./rom2c microcode microcode_dump.inc
+
+ .PHONY: clean
diff --git a/emulators/dynamips/pkg-descr b/emulators/dynamips/pkg-descr
new file mode 100644
index 000000000000..f4f8a8d23601
--- /dev/null
+++ b/emulators/dynamips/pkg-descr
@@ -0,0 +1,3 @@
+Cisco 7200 simulator.
+
+WWW: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator