aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2014-01-16 22:39:44 +0000
committerShaun Amott <shaun@FreeBSD.org>2014-01-16 22:39:44 +0000
commit411724c8b9a1ee1454fea0e2bc04039bab1eb7c2 (patch)
tree9db7c47ec35953af1889a3fd6a470620849ed8a4 /emulators
parent0f5a57fe87a47ad2a2f7212c6d990277b426cb82 (diff)
downloadports-411724c8b9a1ee1454fea0e2bc04039bab1eb7c2.tar.gz
ports-411724c8b9a1ee1454fea0e2bc04039bab1eb7c2.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/x49gp/Makefile6
-rw-r--r--emulators/x49gp/files/hp50g.sh.in2
-rw-r--r--emulators/x49gp/files/patch-Makefile8
3 files changed, 15 insertions, 1 deletions
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index ef279af7a255..5b7a926c894a 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -15,6 +15,7 @@ COMMENT= HP 49g+/50g graphics calculator emulator
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/x49gp/x49gp-code
+HAVE_CONFIGURE= yes
USE_GCC= any
USE_XORG= x11
@@ -40,6 +41,8 @@ MAKE_ENV+= DEBUGB=1
.include <bsd.port.options.mk>
+MAKE_ARGS+=CC="${CC}"
+
.if ${PORT_OPTIONS:MFIRMWARE_215H3} || ${PORT_OPTIONS:MFIRMWARE_215}
MAKE_ARGS+=FIRMWARE=4950_215.bin
DISTFILES+=hp4950v215.zip
@@ -63,6 +66,9 @@ post-patch:
# @${CP} ${WRKDIR}/rom215_hpgcc3_R004/hpgccrom.bin ${WRKSRC}/4950_215.bin
#.endif
+do-configure:
+ cd ${WRKSRC}/qemu/qemu-git && ./configure-small --extra-cflags=-DX49GP --cc="${CC}"
+
do-build:
cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS}
diff --git a/emulators/x49gp/files/hp50g.sh.in b/emulators/x49gp/files/hp50g.sh.in
index 12ab40dfc2fd..2a82241d7de4 100644
--- a/emulators/x49gp/files/hp50g.sh.in
+++ b/emulators/x49gp/files/hp50g.sh.in
@@ -35,7 +35,7 @@ if [ ! -d "${sdir}" ]; then
cp "${datadir}/flash-50g" "${sdir}/"
if [ "`uname -p`" = "amd64" ]; then
- cp "${datadir}/hp50g-hack.png" "${sdir}/"
+ cp "${datadir}/hp50g-hack.png" "${sdir}/hp50g.png"
else
cp "${datadir}/hp50g.png" "${sdir}/"
fi
diff --git a/emulators/x49gp/files/patch-Makefile b/emulators/x49gp/files/patch-Makefile
index 84097f689616..b355edecc566 100644
--- a/emulators/x49gp/files/patch-Makefile
+++ b/emulators/x49gp/files/patch-Makefile
@@ -30,3 +30,11 @@
ifdef QEMU_OLD
QEMUSRC = qemu/prepare.sh \
+@@ -81,6 +88,7 @@ QEMU_DIR_BUILD=$(QEMU_DIR)/arm-softmmu
+ QEMU_DEFINES+=-DNEED_CPU_H
+ X49GP_LDFLAGS=
+ X49GP_LIBS= $(QEMU_DIR_BUILD)/exec.o $(QEMU_DIR_BUILD)/translate-all.o $(QEMU_DIR_BUILD)/cpu-exec.o $(QEMU_DIR_BUILD)/translate.o $(QEMU_DIR_BUILD)/fpu/softfloat.o $(QEMU_DIR_BUILD)/op_helper.o $(QEMU_DIR_BUILD)/helper.o $(QEMU_DIR_BUILD)/disas.o $(QEMU_DIR_BUILD)/i386-dis.o $(QEMU_DIR_BUILD)/arm-dis.o $(QEMU_DIR_BUILD)/tcg/tcg.o $(QEMU_DIR_BUILD)/iwmmxt_helper.o $(QEMU_DIR_BUILD)/neon_helper.o
++X49GP_LIBS += -lz -lm
+ endif
+ QEMU_INCDIR=$(QEMU_DIR)
+ QEMU_INC=-I$(QEMU_INCDIR)/target-arm -I$(QEMU_INCDIR) -I$(QEMU_INCDIR)/fpu -I$(QEMU_INCDIR)/arm-softmmu