aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-05-17 22:20:26 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-05-17 22:20:26 +0000
commit79ce264e0cd3bf155f58a343098c3b35538671ad (patch)
treee1d16918ec48de2b042530b558906f1840644c40 /emulators
parentdaa809b23778972b7520a82b334fbdecb6683405 (diff)
downloadports-79ce264e0cd3bf155f58a343098c3b35538671ad.tar.gz
ports-79ce264e0cd3bf155f58a343098c3b35538671ad.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mame/Makefile33
-rw-r--r--emulators/mame/distinfo6
-rw-r--r--emulators/mame/files/mame.ini8
-rw-r--r--emulators/mame/files/patch-makefile56
-rw-r--r--emulators/mame/files/pkg-message.in4
-rw-r--r--emulators/mame/files/sdl.mak.patch46
-rw-r--r--emulators/mame/pkg-descr24
-rw-r--r--emulators/mame/pkg-plist17
-rw-r--r--emulators/sdlmame/Makefile73
-rw-r--r--emulators/sdlmame/distinfo3
-rw-r--r--emulators/sdlmame/files/mame.ini262
-rw-r--r--emulators/sdlmame/files/patch-makefile58
-rw-r--r--emulators/sdlmame/files/pkg-message.in13
-rw-r--r--emulators/sdlmame/files/sdl.mak.patch25
-rw-r--r--emulators/sdlmame/pkg-descr17
-rw-r--r--emulators/sdlmame/pkg-plist25
16 files changed, 85 insertions, 585 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 2b9f5051f34a..33daf9800c94 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -5,25 +5,29 @@
# $FreeBSD$
#
-PORTNAME= sdlmame
-PORTVERSION= 0.136
+PORTNAME= mame
+PORTVERSION= 0.137
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+MASTER_SITES= http://www.aarongiles.com/mirror/releases/ \
+ ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}s
MAINTAINER= elbarto@ArcadeBSD.org
-COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
+COMMENT= The popular MAME (Multi Arcade Machine Emulator)
USE_ZIP= yes
+NO_WRKSUBDIR= yes
USE_XORG= xext xrender xinerama xi
USE_GL= gl
USE_GNOME?= gtk20 gconf2
USE_GMAKE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
USE_SDL= sdl
+USE_GCC= 4.2+
MAKEFILE= makefile
ONLY_FOR_ARCHS= i386 amd64
SUB_FILES= pkg-message
+USE_DOS2UNIX= makefile sdl.mak
OPTIONS= DEBUG "Build sdlmame debugger" off
@@ -43,16 +47,22 @@ MAKE_ENV+= PTR64=1
BROKEN= Does not compile on sparc64
.endif
+post-extract:
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/mame.zip ${EXTRACT_AFTER_ARGS}
+ @${RM} -f ${WRKDIR}/mame.zip
+
post-patch:
@${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${MKDIR} ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
+ ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/romcmp ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/unidasm ${PREFIX}/libexec/${PORTNAME}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -60,8 +70,7 @@ do-install:
${CP} -R ${WRKSRC}/docs ${DOCSDIR}
.endif
${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/ui.bdf ${DATADIR}/
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}/
+ ${CP} -R ${WRKSRC}/src/osd/sdl/keymaps ${DATADIR}/
${MKDIR} ${EXAMPLESDIR}
${CP} ${FILESDIR}/mame.ini ${EXAMPLESDIR}
diff --git a/emulators/mame/distinfo b/emulators/mame/distinfo
index 848b8cf706ea..75ade0d67340 100644
--- a/emulators/mame/distinfo
+++ b/emulators/mame/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmame0136.zip) = 3a83a5ba70b63298f4173558ccad1eba
-SHA256 (sdlmame0136.zip) = 863c34af4850b7687de358601e5b13fbb4ed1c121e11654179e87fb39e7ede2d
-SIZE (sdlmame0136.zip) = 18936113
+MD5 (mame0137s.zip) = ce9e5359e882d5a8219821e39bd4f27a
+SHA256 (mame0137s.zip) = 19678b480355b3c88fd026d0b5d4cb8f5da283666be7b0aa677a05f84041f8c7
+SIZE (mame0137s.zip) = 16336251
diff --git a/emulators/mame/files/mame.ini b/emulators/mame/files/mame.ini
index cafbec7c11fb..77be00e03be3 100644
--- a/emulators/mame/files/mame.ini
+++ b/emulators/mame/files/mame.ini
@@ -13,9 +13,9 @@ samplepath $HOME/.mame/samples
artpath $HOME/.mame/artwork
ctrlrpath $HOME/.mame/ctrlr
inipath $HOME/.mame;.;ini
-fontpath /usr/local/share/sdlmame/
+fontpath $HOME/.mame/.
cheatpath $HOME/.mame/cheat
-crosshairpath crosshair
+crosshairpath $HOME/.mame/crosshair
#
# CORE OUTPUT DIRECTORY OPTIONS
@@ -112,6 +112,8 @@ offscreen_reload 0
joystick_map auto
joystick_deadzone 0.3
joystick_saturation 0.85
+natural 0
+uimodekey auto
#
# CORE INPUT AUTOMATIC ENABLE OPTIONS
@@ -133,6 +135,7 @@ verbose 0
update_in_pause 0
debug 0
debugscript
+debug_internal 0
#
# CORE MISC OPTIONS
@@ -150,6 +153,7 @@ oslog 0
# PERFORMANCE OPTIONS
#
multithreading 0
+numprocessors auto
sdlvideofps 0
#
diff --git a/emulators/mame/files/patch-makefile b/emulators/mame/files/patch-makefile
index 9dc54e92d8a5..16ebca17f570 100644
--- a/emulators/mame/files/patch-makefile
+++ b/emulators/mame/files/patch-makefile
@@ -1,58 +1,22 @@
---- makefile.orig 2009-11-13 11:07:31.000000000 +0100
-+++ makefile 2009-11-13 11:08:58.000000000 +0100
-@@ -59,7 +59,7 @@
- ifeq ($(OSD),windows)
- TARGETOS = win32
- else
--TARGETOS = unix
-+TARGETOS = freebsd
- endif
- endif
-
-@@ -197,8 +197,8 @@
+--- makefile.orig 2010-03-01 20:26:50.000000000 +0100
++++ makefile 2010-03-24 00:48:38.000000000 +0100
+@@ -266,8 +266,8 @@
# compiler, linker and utilities
AR = @ar
-CC = @gcc
--LD = @gcc
-+CC := @$(CC)
-+LD := @$(CC)
+-LD = @g++
++CC:= @$(CC)
++LD:= @$(CXX)
MD = -mkdir$(EXE)
RM = @rm -f
-@@ -227,7 +227,7 @@
+@@ -308,7 +308,7 @@
endif
- # fullname is prefix+name+suffix+debugsuffix
--FULLNAME = $(PREFIX)$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
-+FULLNAME = sdl$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
+ # fullname is prefix+name+suffix+suffix64+suffixdebug
+-FULLNAME = $(PREFIX)$(PREFIXSDL)$(NAME)$(SUFFIX)$(SUFFIX64)$(SUFFIXDEBUG)
++FULLNAME = $(NAME)
# add an EXE suffix to get the final emulator name
EMULATOR = $(FULLNAME)$(EXE)
-@@ -338,7 +338,7 @@
- ifneq ($(OPTIMIZE),0)
- ifneq ($(TARGETOS),os2)
- ifndef IA64
--CCOMFLAGS += -Werror -fno-strict-aliasing $(ARCHOPTS)
-+CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
- else
- endif
- else
-@@ -382,7 +382,7 @@
- -I$(SRC)/lib/util \
- -I$(SRC)/osd \
- -I$(SRC)/osd/$(OSD) \
--
-+ -I$(LOCALBASE)/include \
-
-
- #-------------------------------------------------
-@@ -395,7 +395,7 @@
- ifneq ($(TARGETOS),macosx)
- ifneq ($(TARGETOS),os2)
- ifneq ($(TARGETOS),solaris)
--LDFLAGS = -Wl,--warn-common
-+LDFLAGS = -Wl,--warn-common $(PTHREAD_LIBS) -L$(LOCALBASE)/lib
- endif
- endif
- endif
diff --git a/emulators/mame/files/pkg-message.in b/emulators/mame/files/pkg-message.in
index 072489632688..60444573abb4 100644
--- a/emulators/mame/files/pkg-message.in
+++ b/emulators/mame/files/pkg-message.in
@@ -1,10 +1,10 @@
==============================================================================
-SDLMAME has been installed.
+MAME has been installed.
A example configuration file has been installed in "%%EXAMPLESDIR%%/mame.ini"
Should you create a "~/.mame" directory and place it here or
-launch "sdlmame -createconfig" and place the mame.ini created instead.
+launch "mame -createconfig" and place the mame.ini created instead.
If you have a non-qwerty keyboard, you should put in your mame.ini :
keymap 1
diff --git a/emulators/mame/files/sdl.mak.patch b/emulators/mame/files/sdl.mak.patch
index 9623fe59ac74..0518b8181697 100644
--- a/emulators/mame/files/sdl.mak.patch
+++ b/emulators/mame/files/sdl.mak.patch
@@ -1,25 +1,31 @@
---- src/osd/sdl/sdl.mak.orig 2009-11-13 11:09:21.000000000 +0100
-+++ src/osd/sdl/sdl.mak 2009-11-13 11:10:24.000000000 +0100
-@@ -140,6 +140,7 @@
- endif
-
+--- src/osd/sdl/sdl.mak.orig 2010-03-24 00:15:07.000000000 +0100
++++ src/osd/sdl/sdl.mak 2010-03-24 00:17:26.000000000 +0100
+@@ -139,7 +139,7 @@
ifeq ($(TARGETOS),freebsd)
-+DEFS += -DNO_DEBUGGER
- TARGETOS = unix
- SYNC_IMPLEMENTATION = ntc
- endif
-@@ -288,10 +289,10 @@
+ BASE_TARGETOS = unix
+ SYNC_IMPLEMENTATION = tc
+-DEFS += -DNO_AFFINITY_NP
++DEFS += -DNO_AFFINITY_NP -DNO_DEBUGGER
+ # /usr/local/include is not considered a system include directory
+ # on FreeBSD. GL.h resides there and throws warnings
+ CCOMFLAGS += -isystem /usr/local/include
+@@ -304,7 +304,7 @@
+ ifeq ($(BASE_TARGETOS),unix)
+
+ DEFS += -DSDLMAME_UNIX
+-DEBUGOBJS = $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
++DEBUGOBJS = $(SDLOBJ)/debugwin.o
+ LIBGL = -lGL
+ ifeq ($(NO_X11),1)
+ NO_DEBUGGER = 1
+@@ -454,8 +454,8 @@
+
# the new debugger relies on GTK+ in addition to the base SDLMAME needs
# Non-X11 builds can not use the debugger
- ifndef NO_X11
--OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
--CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
+-CCOMFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
-LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
--CFLAGS += -DGTK_DISABLE_DEPRECATED
-+OSDCOREOBJS += $(SDLOBJ)/debugwin.o
-+#CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
++#CCOMFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
+#LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
-+#CFLAGS += -DGTK_DISABLE_DEPRECATED
- else
- OSDCOREOBJS += $(SDLOBJ)/debugwin.o
- endif # NO_X11
+ #CCOMFLAGS += -DGTK_DISABLE_DEPRECATED
+
+ # some systems still put important things in a different prefix
diff --git a/emulators/mame/pkg-descr b/emulators/mame/pkg-descr
index b297a4b68fa9..a1a6d88dfb3d 100644
--- a/emulators/mame/pkg-descr
+++ b/emulators/mame/pkg-descr
@@ -1,17 +1,9 @@
-SDLMAME is a port of the popular MAME. There are a few principles that guide
-it's development:
+MAME stands for Multiple Arcade Machine Emulator.
+When used in conjunction with images of the original
+arcade game's ROM and disk data, MAME attempts to
+reproduce that game as faithfully as possible on a
+more modern general-purpose computer. MAME can currently
+emulate several thousand different classic arcade video
+games from the late 1970s through the modern era.
-1) Run on Linux/Unix, Mac OS X, and other SDL supported operating systems with
- as few changes as possible to the base Win32 code. This means we can track
- changes faster than larger more conventional ports such as MacMAME, and we
- also maintain what I call "Firefox compatibilty" where learning a major app
- only needs to be done once per application, and it then applies across many
- operating systems. If you can use the command-line Win32 MAME, you already
- know how to use SDLMAME on any platform you may encounter it on.
-
-2) MAME developers are important. By keeping quickly up to date, we make it
- easy for people on non-Windows platforms to make and submit changes to the
- core MAME code, and we offer native implementations of MAME's multi-window
- GUI debugger on both Linux/Unix and Mac OS X.
-
-WWW: http://rbelmont.mameworld.info/?page_id=163
+WWW: http://mamedev.org
diff --git a/emulators/mame/pkg-plist b/emulators/mame/pkg-plist
index 9fa6089e814e..b50c4e6757ec 100644
--- a/emulators/mame/pkg-plist
+++ b/emulators/mame/pkg-plist
@@ -1,15 +1,16 @@
-bin/sdlmame
-libexec/sdlmame/chdman
-libexec/sdlmame/ldverify
-libexec/sdlmame/ldresample
-libexec/sdlmame/testkeys
-%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
+bin/mame
+libexec/mame/chdman
+libexec/mame/ldresample
+libexec/mame/ldverify
+libexec/mame/romcmp
+libexec/mame/testkeys
+libexec/mame/unidasm
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
-%%DATADIR%%/ui.bdf
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%DATADIR%%/keymaps/km-be.txt
%%DATADIR%%/keymaps/km-ch.txt
%%DATADIR%%/keymaps/km-de.txt
@@ -19,7 +20,7 @@ libexec/sdlmame/testkeys
%%EXAMPLESDIR%%/mame.ini
@dirrm %%DATADIR%%/keymaps/
@dirrm %%DATADIR%%/
-@dirrm libexec/sdlmame
+@dirrm libexec/mame
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
deleted file mode 100644
index 2b9f5051f34a..000000000000
--- a/emulators/sdlmame/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# New ports collection makefile for: sdlmame
-# Date created: 2007-01-10
-# Whom: alepulver
-#
-# $FreeBSD$
-#
-
-PORTNAME= sdlmame
-PORTVERSION= 0.136
-CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-
-MAINTAINER= elbarto@ArcadeBSD.org
-COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
-
-USE_ZIP= yes
-USE_XORG= xext xrender xinerama xi
-USE_GL= gl
-USE_GNOME?= gtk20 gconf2
-USE_GMAKE= yes
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
-USE_SDL= sdl
-MAKEFILE= makefile
-ONLY_FOR_ARCHS= i386 amd64
-SUB_FILES= pkg-message
-
-OPTIONS= DEBUG "Build sdlmame debugger" off
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITH_DEBUG)
-USE_GNOME= #
-EXTRA_PATCHES+= ${FILESDIR}/sdl.mak.patch
-.endif
-
-MAKE_JOBS_SAFE= yes
-
-.if ${ARCH} == "amd64"
-MAKE_ENV+= PTR64=1
-.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e "s|ui.bdf|${DATADIR}/ui.bdf|g" ${WRKSRC}/src/emu/ui.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${MKDIR} ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
- ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
-.endif
- ${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/ui.bdf ${DATADIR}/
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}/
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} ${FILESDIR}/mame.ini ${EXAMPLESDIR}
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
-.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame/distinfo b/emulators/sdlmame/distinfo
deleted file mode 100644
index 848b8cf706ea..000000000000
--- a/emulators/sdlmame/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sdlmame0136.zip) = 3a83a5ba70b63298f4173558ccad1eba
-SHA256 (sdlmame0136.zip) = 863c34af4850b7687de358601e5b13fbb4ed1c121e11654179e87fb39e7ede2d
-SIZE (sdlmame0136.zip) = 18936113
diff --git a/emulators/sdlmame/files/mame.ini b/emulators/sdlmame/files/mame.ini
deleted file mode 100644
index cafbec7c11fb..000000000000
--- a/emulators/sdlmame/files/mame.ini
+++ /dev/null
@@ -1,262 +0,0 @@
-<UNADORNED0>
-
-#
-# CORE CONFIGURATION OPTIONS
-#
-readconfig 1
-
-#
-# CORE SEARCH PATH OPTIONS
-#
-rompath $HOME/.mame/roms
-samplepath $HOME/.mame/samples
-artpath $HOME/.mame/artwork
-ctrlrpath $HOME/.mame/ctrlr
-inipath $HOME/.mame;.;ini
-fontpath /usr/local/share/sdlmame/
-cheatpath $HOME/.mame/cheat
-crosshairpath crosshair
-
-#
-# CORE OUTPUT DIRECTORY OPTIONS
-#
-cfg_directory $HOME/.mame/cfg
-nvram_directory $HOME/.mame/nvram
-memcard_directory $HOME/.mame/memcard
-input_directory $HOME/.mame/inp
-state_directory $HOME/.mame/sta
-snapshot_directory $HOME/.mame/snap
-diff_directory $HOME/.mame/diff
-comment_directory $HOME/.mame/comments
-
-#
-# CORE STATE/PLAYBACK OPTIONS
-#
-state
-autosave 0
-playback
-record
-mngwrite
-aviwrite
-wavwrite
-snapname %g/%i
-snapsize auto
-snapview internal
-burnin 0
-
-#
-# CORE PERFORMANCE OPTIONS
-#
-autoframeskip 0
-frameskip 0
-seconds_to_run 0
-throttle 1
-sleep 1
-speed 1.0
-refreshspeed 0
-
-#
-# CORE ROTATION OPTIONS
-#
-rotate 1
-ror 0
-rol 0
-autoror 0
-autorol 0
-flipx 0
-flipy 0
-
-#
-# CORE ARTWORK OPTIONS
-#
-artwork_crop 0
-use_backdrops 1
-use_overlays 1
-use_bezels 1
-
-#
-# CORE SCREEN OPTIONS
-#
-brightness 1.0
-contrast 1.0
-gamma 1.0
-pause_brightness 0.65
-
-#
-# CORE VECTOR OPTIONS
-#
-antialias 1
-beam 1.0
-flicker 0
-
-#
-# CORE SOUND OPTIONS
-#
-sound 1
-samplerate 48000
-samples 1
-volume 0
-
-#
-# CORE INPUT OPTIONS
-#
-coin_lockout 1
-ctrlr
-mouse 0
-joystick 1
-lightgun 0
-multikeyboard 0
-multimouse 0
-steadykey 0
-offscreen_reload 0
-joystick_map auto
-joystick_deadzone 0.3
-joystick_saturation 0.85
-
-#
-# CORE INPUT AUTOMATIC ENABLE OPTIONS
-#
-paddle_device keyboard
-adstick_device keyboard
-pedal_device keyboard
-dial_device keyboard
-trackball_device keyboard
-lightgun_device keyboard
-positional_device keyboard
-mouse_device mouse
-
-#
-# CORE DEBUGGING OPTIONS
-#
-log 0
-verbose 0
-update_in_pause 0
-debug 0
-debugscript
-
-#
-# CORE MISC OPTIONS
-#
-bios
-cheat 0
-skip_gameinfo 0
-
-#
-# DEBUGGING OPTIONS
-#
-oslog 0
-
-#
-# PERFORMANCE OPTIONS
-#
-multithreading 0
-sdlvideofps 0
-
-#
-# VIDEO OPTIONS
-#
-video soft
-numscreens 1
-window 0
-maximize 1
-keepaspect 1
-unevenstretch 1
-effect none
-centerh 1
-centerv 1
-waitvsync 0
-scalemode none
-
-#
-# OpenGL-SPECIFIC OPTIONS
-#
-filter 1
-prescale 1
-gl_forcepow2texture 0
-gl_notexturerect 0
-gl_vbo 1
-gl_pbo 1
-gl_glsl 0
-gl_glsl_filter 1
-glsl_shader_mame0 none
-glsl_shader_mame1 none
-glsl_shader_mame2 none
-glsl_shader_mame3 none
-glsl_shader_mame4 none
-glsl_shader_mame5 none
-glsl_shader_mame6 none
-glsl_shader_mame7 none
-glsl_shader_mame8 none
-glsl_shader_mame9 none
-glsl_shader_screen0 none
-glsl_shader_screen1 none
-glsl_shader_screen2 none
-glsl_shader_screen3 none
-glsl_shader_screen4 none
-glsl_shader_screen5 none
-glsl_shader_screen6 none
-glsl_shader_screen7 none
-glsl_shader_screen8 none
-glsl_shader_screen9 none
-gl_glsl_vid_attr 1
-
-#
-# PER-WINDOW VIDEO OPTIONS
-#
-screen auto
-aspect auto
-resolution auto
-view auto
-screen0 auto
-aspect0 auto
-resolution0 auto
-view0 auto
-screen1 auto
-aspect1 auto
-resolution1 auto
-view1 auto
-screen2 auto
-aspect2 auto
-resolution2 auto
-view2 auto
-screen3 auto
-aspect3 auto
-resolution3 auto
-view3 auto
-
-#
-# FULL SCREEN OPTIONS
-#
-switchres 0
-useallheads 0
-
-#
-# SOUND OPTIONS
-#
-audio_latency 3
-
-#
-# SDL KEYBOARD MAPPING
-#
-keymap 0
-keymap_file keymap.dat
-
-#
-# SDL JOYSTICK MAPPING
-#
-joy_idx1 auto
-joy_idx2 auto
-joy_idx3 auto
-joy_idx4 auto
-joy_idx5 auto
-joy_idx6 auto
-joy_idx7 auto
-joy_idx8 auto
-sixaxis 0
-
-#
-# SDL LOWLEVEL DRIVER OPTIONS
-#
-videodriver auto
-audiodriver auto
-gl_lib auto
diff --git a/emulators/sdlmame/files/patch-makefile b/emulators/sdlmame/files/patch-makefile
deleted file mode 100644
index 9dc54e92d8a5..000000000000
--- a/emulators/sdlmame/files/patch-makefile
+++ /dev/null
@@ -1,58 +0,0 @@
---- makefile.orig 2009-11-13 11:07:31.000000000 +0100
-+++ makefile 2009-11-13 11:08:58.000000000 +0100
-@@ -59,7 +59,7 @@
- ifeq ($(OSD),windows)
- TARGETOS = win32
- else
--TARGETOS = unix
-+TARGETOS = freebsd
- endif
- endif
-
-@@ -197,8 +197,8 @@
-
- # compiler, linker and utilities
- AR = @ar
--CC = @gcc
--LD = @gcc
-+CC := @$(CC)
-+LD := @$(CC)
- MD = -mkdir$(EXE)
- RM = @rm -f
-
-@@ -227,7 +227,7 @@
- endif
-
- # fullname is prefix+name+suffix+debugsuffix
--FULLNAME = $(PREFIX)$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
-+FULLNAME = sdl$(NAME)$(CPPSUFFIX)$(SUFFIX)$(DEBUGSUFFIX)
-
- # add an EXE suffix to get the final emulator name
- EMULATOR = $(FULLNAME)$(EXE)
-@@ -338,7 +338,7 @@
- ifneq ($(OPTIMIZE),0)
- ifneq ($(TARGETOS),os2)
- ifndef IA64
--CCOMFLAGS += -Werror -fno-strict-aliasing $(ARCHOPTS)
-+CCOMFLAGS += -fno-strict-aliasing $(ARCHOPTS)
- else
- endif
- else
-@@ -382,7 +382,7 @@
- -I$(SRC)/lib/util \
- -I$(SRC)/osd \
- -I$(SRC)/osd/$(OSD) \
--
-+ -I$(LOCALBASE)/include \
-
-
- #-------------------------------------------------
-@@ -395,7 +395,7 @@
- ifneq ($(TARGETOS),macosx)
- ifneq ($(TARGETOS),os2)
- ifneq ($(TARGETOS),solaris)
--LDFLAGS = -Wl,--warn-common
-+LDFLAGS = -Wl,--warn-common $(PTHREAD_LIBS) -L$(LOCALBASE)/lib
- endif
- endif
- endif
diff --git a/emulators/sdlmame/files/pkg-message.in b/emulators/sdlmame/files/pkg-message.in
deleted file mode 100644
index 072489632688..000000000000
--- a/emulators/sdlmame/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-==============================================================================
-
-SDLMAME has been installed.
-
-A example configuration file has been installed in "%%EXAMPLESDIR%%/mame.ini"
-Should you create a "~/.mame" directory and place it here or
-launch "sdlmame -createconfig" and place the mame.ini created instead.
-
-If you have a non-qwerty keyboard, you should put in your mame.ini :
-keymap 1
-keymap_file %%DATADIR%%/keymaps/km-XX.txt
-
-==============================================================================
diff --git a/emulators/sdlmame/files/sdl.mak.patch b/emulators/sdlmame/files/sdl.mak.patch
deleted file mode 100644
index 9623fe59ac74..000000000000
--- a/emulators/sdlmame/files/sdl.mak.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/osd/sdl/sdl.mak.orig 2009-11-13 11:09:21.000000000 +0100
-+++ src/osd/sdl/sdl.mak 2009-11-13 11:10:24.000000000 +0100
-@@ -140,6 +140,7 @@
- endif
-
- ifeq ($(TARGETOS),freebsd)
-+DEFS += -DNO_DEBUGGER
- TARGETOS = unix
- SYNC_IMPLEMENTATION = ntc
- endif
-@@ -288,10 +289,10 @@
- # the new debugger relies on GTK+ in addition to the base SDLMAME needs
- # Non-X11 builds can not use the debugger
- ifndef NO_X11
--OSDCOREOBJS += $(SDLOBJ)/debugwin.o $(SDLOBJ)/dview.o $(SDLOBJ)/debug-sup.o $(SDLOBJ)/debug-intf.o
--CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
--LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
--CFLAGS += -DGTK_DISABLE_DEPRECATED
-+OSDCOREOBJS += $(SDLOBJ)/debugwin.o
-+#CFLAGS += `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gconf-2.0`
-+#LIBS += `pkg-config --libs gtk+-2.0` `pkg-config --libs gconf-2.0`
-+#CFLAGS += -DGTK_DISABLE_DEPRECATED
- else
- OSDCOREOBJS += $(SDLOBJ)/debugwin.o
- endif # NO_X11
diff --git a/emulators/sdlmame/pkg-descr b/emulators/sdlmame/pkg-descr
deleted file mode 100644
index b297a4b68fa9..000000000000
--- a/emulators/sdlmame/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-SDLMAME is a port of the popular MAME. There are a few principles that guide
-it's development:
-
-1) Run on Linux/Unix, Mac OS X, and other SDL supported operating systems with
- as few changes as possible to the base Win32 code. This means we can track
- changes faster than larger more conventional ports such as MacMAME, and we
- also maintain what I call "Firefox compatibilty" where learning a major app
- only needs to be done once per application, and it then applies across many
- operating systems. If you can use the command-line Win32 MAME, you already
- know how to use SDLMAME on any platform you may encounter it on.
-
-2) MAME developers are important. By keeping quickly up to date, we make it
- easy for people on non-Windows platforms to make and submit changes to the
- core MAME code, and we offer native implementations of MAME's multi-window
- GUI debugger on both Linux/Unix and Mac OS X.
-
-WWW: http://rbelmont.mameworld.info/?page_id=163
diff --git a/emulators/sdlmame/pkg-plist b/emulators/sdlmame/pkg-plist
deleted file mode 100644
index 9fa6089e814e..000000000000
--- a/emulators/sdlmame/pkg-plist
+++ /dev/null
@@ -1,25 +0,0 @@
-bin/sdlmame
-libexec/sdlmame/chdman
-libexec/sdlmame/ldverify
-libexec/sdlmame/ldresample
-libexec/sdlmame/testkeys
-%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
-%%DATADIR%%/ui.bdf
-%%DATADIR%%/keymaps/km-be.txt
-%%DATADIR%%/keymaps/km-ch.txt
-%%DATADIR%%/keymaps/km-de.txt
-%%DATADIR%%/keymaps/km-fr-OSX.txt
-%%DATADIR%%/keymaps/km-fr.txt
-%%DATADIR%%/keymaps/km_it.txt
-%%EXAMPLESDIR%%/mame.ini
-@dirrm %%DATADIR%%/keymaps/
-@dirrm %%DATADIR%%/
-@dirrm libexec/sdlmame
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%