aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-05-30 19:22:32 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-05-30 19:22:32 +0000
commitd192ad85aae5731f564063c93aebe2414b9e11b4 (patch)
tree6a7491cfec88ec8c875cf811549501d8ebb87b6c /emulators
parentfc7219e3d5733d60d563c435becf4c51d5b6d972 (diff)
downloadports-d192ad85aae5731f564063c93aebe2414b9e11b4.tar.gz
ports-d192ad85aae5731f564063c93aebe2414b9e11b4.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-osdep.c9
2 files changed, 9 insertions, 2 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d45f44cd59d4..ae7bb243c0cd 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.11.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
diff --git a/emulators/qemu/files/patch-osdep.c b/emulators/qemu/files/patch-osdep.c
index 984c63bdbbcb..a1b7cadcb08a 100644
--- a/emulators/qemu/files/patch-osdep.c
+++ b/emulators/qemu/files/patch-osdep.c
@@ -1,5 +1,5 @@
Index: qemu/osdep.c
-@@ -179,7 +179,9 @@
+@@ -179,13 +179,15 @@ static void *kqemu_vmalloc(size_t size)
}
unlink(phys_ram_file);
}
@@ -9,3 +9,10 @@ Index: qemu/osdep.c
ftruncate(phys_ram_fd, phys_ram_size + size);
#endif /* !(__OpenBSD__ || __FreeBSD__ || __DragonFly__) */
ptr = mmap(NULL,
+ size,
+ PROT_WRITE | PROT_READ, map_anon | MAP_SHARED,
+- phys_ram_fd, phys_ram_size);
++ phys_ram_fd, map_anon ? 0 : phys_ram_size);
+ if (ptr == MAP_FAILED) {
+ fprintf(stderr, "Could not map physical memory\n");
+ exit(1);