aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-08 10:06:53 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-08 10:06:53 +0000
commit5e908740569ba6f475a96f38ee468b323b6df32b (patch)
tree99d24e7af3c004b0626245fd71171e28c7bfaccb /emulators
parent37a282d06d8724f695f2ac91cb5cb9783d1460c0 (diff)
downloadports-5e908740569ba6f475a96f38ee468b323b6df32b.tar.gz
ports-5e908740569ba6f475a96f38ee468b323b6df32b.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pcsxr/Makefile6
-rw-r--r--emulators/pcsxr/distinfo4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am8
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfinput-pad.c15
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am10
-rw-r--r--emulators/pcsxr/pkg-plist2
6 files changed, 26 insertions, 19 deletions
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 41f2b9d03f01..0665d8562bf0 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= pcsxr
-PORTVERSION= 1.9.92.r78288
-PORTREVISION= 1
+PORTVERSION= 1.9.92.r81088
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Playstation (PSX) emulator
@@ -37,7 +35,7 @@ USE_LDCONFIG= yes
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
-USE_GNOME= gtk20 desktopfileutils glib20 libglade2
+USE_GNOME= gtk20 desktopfileutils glib20
USE_ICONV= yes
USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
diff --git a/emulators/pcsxr/distinfo b/emulators/pcsxr/distinfo
index 5116f707acb4..ef4f1d0c7512 100644
--- a/emulators/pcsxr/distinfo
+++ b/emulators/pcsxr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pcsxr-1.9.92.r78288.tar.bz2) = 31b78b5fe46e860797f8f975199b12565187e4a05fad91f601813f674d05b93b
-SIZE (pcsxr-1.9.92.r78288.tar.bz2) = 1431319
+SHA256 (pcsxr-1.9.92.r81088.tar.bz2) = d514fd045f0dd4fe9c7f8d67afbe031412f38f039b3a53c0007c267366e9595d
+SIZE (pcsxr-1.9.92.r81088.tar.bz2) = 1435621
diff --git a/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
index 100f8d5ef0cf..109ef7ae55e5 100644
--- a/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
@@ -1,5 +1,5 @@
---- plugins/dfinput/Makefile.am.orig 2011-06-30 08:58:33.770048349 +0200
-+++ plugins/dfinput/Makefile.am 2011-06-30 09:00:09.852609400 +0200
+--- plugins/dfinput/Makefile.am.orig 2012-11-07 17:22:21.000000000 +0100
++++ plugins/dfinput/Makefile.am 2012-11-07 17:24:22.000000000 +0100
@@ -1,14 +1,14 @@
-bindir = @libdir@/games/psemu/
-libdir = @libdir@/games/psemu/
@@ -17,11 +17,11 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) $(GLADE2_CFLAGS) \
+ $(GTK2_CFLAGS) \
-I../../include -I../../libpcsxcore $(SDL_CFLAGS)
@@ -17,5 +17,5 @@
- cfgDFInput_LDADD = $(GTK2_LIBS) $(GLADE2_LIBS) $(SDL_LIBS) -lX11
+ cfgDFInput_LDADD = $(GTK2_LIBS) $(SDL_LIBS) -lX11
glade_DATA = dfinput.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfinput-pad.c b/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
index 9f495cce459d..138462295414 100644
--- a/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
+++ b/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
@@ -1,6 +1,15 @@
---- plugins/dfinput/pad.c.orig 2009-12-25 18:26:35.000000000 +0000
-+++ plugins/dfinput/pad.c 2010-06-03 08:06:29.658820184 +0000
-@@ -386,3 +386,6 @@
+--- plugins/dfinput/pad.c.orig 2012-11-08 06:07:00.000000000 +0100
++++ plugins/dfinput/pad.c 2012-11-08 06:09:26.000000000 +0100
+@@ -676,8 +676,6 @@
+ } else if (pid > 0) {
+ waitpid(pid, NULL, 0);
+ }
+-
+- return PSE_PAD_ERR_SUCCESS;
+ }
+
+ #endif
+@@ -685,3 +683,6 @@
long PADtest(void) {
return PSE_PAD_ERR_SUCCESS;
}
diff --git a/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
index b7193a5dd25b..958297e56b19 100644
--- a/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
@@ -1,5 +1,5 @@
---- plugins/dfnet/Makefile.am.orig 2011-01-25 07:30:51.232551129 +0100
-+++ plugins/dfnet/Makefile.am 2011-01-25 16:39:03.458776989 +0100
+--- plugins/dfnet/Makefile.am.orig 2012-11-07 17:26:37.000000000 +0100
++++ plugins/dfnet/Makefile.am 2012-11-07 17:28:04.000000000 +0100
@@ -1,5 +1,5 @@
-bindir = @libdir@/games/psemu/
-libdir = @libdir@/games/psemu/
@@ -14,13 +14,13 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) $(GLADE2_CFLAGS) \
+ $(GTK2_CFLAGS) \
-I../../libpcsxcore -I../../include
@@ -16,5 +16,5 @@
- cfgDFNet_LDADD = $(GTK2_LIBS) $(GLADE2_LIBS)
+ cfgDFNet_LDADD = $(GTK2_LIBS)
glade_DATA = dfnet.ui
-gladedir = $(datadir)/psemu/
-+gladedir = $(datadir)/pcsxr
++gladedir = $(datadir)/pcsxr/
EXTRA_DIST = $(glade_DATA)
diff --git a/emulators/pcsxr/pkg-plist b/emulators/pcsxr/pkg-plist
index a2c44cd8fb61..695f5b4b255d 100644
--- a/emulators/pcsxr/pkg-plist
+++ b/emulators/pcsxr/pkg-plist
@@ -22,7 +22,7 @@ share/pcsxr/spu.png
share/pcsxr/cd.png
share/pcsxr/iso-reopen.png
share/pcsxr/cdr.png
-share/pcsxr/pcsxr.glade2
+share/pcsxr/pcsxr.ui
share/pcsxr/iso-open.png
share/pcsxr/play.png
share/pcsxr/pad.png