aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-02-05 18:53:35 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-02-05 18:53:35 +0000
commit268f7cfcbdc51bf40e90d71e979a53589335993c (patch)
tree87a5ec80fb33f805fcac0bd63dab88ee1c58aa26 /emulators
parent4be9bd4f717167bf739efe076e86a81feee53125 (diff)
downloadports-268f7cfcbdc51bf40e90d71e979a53589335993c.tar.gz
ports-268f7cfcbdc51bf40e90d71e979a53589335993c.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/zsnes/Makefile4
-rw-r--r--emulators/zsnes/distinfo6
-rw-r--r--emulators/zsnes/files/patch-configure63
3 files changed, 62 insertions, 11 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 89753f540db5..cbbef1eb9e14 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= zsnes
-PORTVERSION= 1.50
+PORTVERSION= 1.51
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF
DISTNAME= zsnes${PORTVERSION:S/.//}src
-MAINTAINER= freebsd-ports@stsp.in-berlin.de
+MAINTAINER= stsp@stsp.in-berlin.de
COMMENT= Intel x86 only Super Nintendo Entertainment System (SNES) Emulator
# This must be >= 0.98!
diff --git a/emulators/zsnes/distinfo b/emulators/zsnes/distinfo
index de41648eb23e..560492bea14e 100644
--- a/emulators/zsnes/distinfo
+++ b/emulators/zsnes/distinfo
@@ -1,3 +1,3 @@
-MD5 (zsnes150src.tar.bz2) = f0612e27b1c3dd821044525be5cf4450
-SHA256 (zsnes150src.tar.bz2) = 2ddaaff892d511c717d3e270cc035b208ba2eca04cdf3e749c5739df78ba9aba
-SIZE (zsnes150src.tar.bz2) = 1058671
+MD5 (zsnes151src.tar.bz2) = 328071775f88f7c3b9fdb94176e5e417
+SHA256 (zsnes151src.tar.bz2) = eb013f824f5a9814a714cf0daaea3ea68a1c74fd741e5b0979fcb7964236a866
+SIZE (zsnes151src.tar.bz2) = 1071712
diff --git a/emulators/zsnes/files/patch-configure b/emulators/zsnes/files/patch-configure
index 1da6da61b77b..bfb9a54abebd 100644
--- a/emulators/zsnes/files/patch-configure
+++ b/emulators/zsnes/files/patch-configure
@@ -1,10 +1,61 @@
---- configure.orig Tue Dec 26 18:52:47 2006
-+++ configure Tue Dec 26 18:53:22 2006
-@@ -5075,38 +5075,6 @@
+--- configure.orig Thu Jan 25 23:44:43 2007
++++ configure Thu Jan 25 23:48:32 2007
+@@ -5130,89 +5130,6 @@
- rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- fi
-- if test x$force_arch = x; then
+ { echo "$as_me:$LINENO: checking which cpu architecture to optimize for" >&5
+ echo $ECHO_N "checking which cpu architecture to optimize for... $ECHO_C" >&6; }
+- if test x$force_arch != x; then
+- CFLAGS="$CFLAGS -march=$force_arch"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (ac_try="$ac_compile"
+-case "(($ac_try" in
+- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+- *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+- (eval "$ac_compile") 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && {
+- test -z "$ac_c_werror_flag" ||
+- test ! -s conftest.err
+- } && test -s conftest.$ac_objext; then
+- { echo "$as_me:$LINENO: result: forcing $force_arch" >&5
+-echo "${ECHO_T}forcing $force_arch" >&6; }
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+- { echo "$as_me:$LINENO: result: $force_arch ??" >&5
+-echo "${ECHO_T}$force_arch ??" >&6; }
+- { echo "$as_me:$LINENO: WARNING: incorrect force_arch parameter" >&5
+-echo "$as_me: WARNING: incorrect force_arch parameter" >&2;}
+- force_arch=""
+- CFLAGS="$CFLAGSBAK"
+- { echo "$as_me:$LINENO: checking for autodetected architecture" >&5
+-echo $ECHO_N "checking for autodetected architecture... $ECHO_C" >&6; }
+-fi
+-
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+- else
- if test x$ARCH_INFO = x; then
- case x$target in
- i686-*-*)