aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-22 10:01:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-22 10:01:19 +0000
commit536d89a7a6fbe6834bc1e56b0f03eda8b974f179 (patch)
tree7a38a65f75cca01ca428723b7c053b10fc7c3703 /emulators
parent9085d53461d80d7e85c69016820bbd161ec43d17 (diff)
downloadports-536d89a7a6fbe6834bc1e56b0f03eda8b974f179.tar.gz
ports-536d89a7a6fbe6834bc1e56b0f03eda8b974f179.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile7
-rw-r--r--emulators/dolphin-emu/files/patch-CMakeLists.txt21
2 files changed, 22 insertions, 6 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index b00f1dff836d..deaf3345e635 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 4.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -17,16 +17,15 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libfreetype.so:${PORTSDIR}/print/freetype2 \
liblzo2.so:${PORTSDIR}/archivers/lzo2 \
libSoundTouch.so:${PORTSDIR}/audio/soundtouch \
- libsfml-network.so:${PORTSDIR}/devel/sfml \
libpolarssl.so:${PORTSDIR}/security/polarssl
USE_SDL= sdl
USE_XORG= ice xext x11 xrandr xi
USE_WX= 3.0+
WX_UNICODE= yes
-USE_GL= gl glew glu
+USE_GL= gl glew glu
-USES= dos2unix cmake iconv openal pkgconfig tar:tgz
+USES= dos2unix cmake iconv openal pkgconfig tar:tgz compiler:c++11-lib
DOS2UNIX_REGEX= .*\.(h|c|cpp)
# Disable ALSA (emulated) and ao (buggy)
diff --git a/emulators/dolphin-emu/files/patch-CMakeLists.txt b/emulators/dolphin-emu/files/patch-CMakeLists.txt
index 4faf9d382b07..45ad27dc92c5 100644
--- a/emulators/dolphin-emu/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- CMakeLists.txt.orig 2013-09-16 04:58:51.000000000 +0200
-+++ CMakeLists.txt 2013-09-16 05:15:59.000000000 +0200
+--- CMakeLists.txt.orig 2013-09-23 16:15:52.000000000 +0400
++++ CMakeLists.txt 2014-08-20 17:37:42.000000000 +0400
@@ -351,51 +351,81 @@
message("OpenMP parallelization disabled")
endif()
@@ -158,3 +158,20 @@
if(OPROFILING)
check_lib(OPROFILE opagent opagent.h)
+@@ -577,14 +618,14 @@
+ set(SFML_FIND_VERSION_MAJOR 1)
+ set(SFML_FIND_VERSION_MINOR 5)
+ if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND NOT ANDROID)
+- include(FindSFML OPTIONAL)
++ #include(FindSFML OPTIONAL)
+ endif()
+ if(SFML_FOUND AND NOT SFML_VERSION_MAJOR) # SFML 1.x doesn't define SFML_VERSION_MAJOR
+ message("Using shared SFML")
+ else()
+ message("Using static SFML ${SFML_FIND_VERSION_MAJOR}.${SFML_FIND_VERSION_MINOR} from Externals")
+ add_subdirectory(Externals/SFML)
+- include_directories(Externals/SFML/include)
++ include_directories(BEFORE Externals/SFML/include)
+ endif()
+
+ if(USE_UPNP)