aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 07:39:42 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-09 07:39:42 +0000
commita309fc7b98e2faa0ab054d88a6a3d56574ba9210 (patch)
tree4cb581225331c7aa7ee7eb3bdd7b43790efa4b3e /emulators
parentf10920752de278a74de0212fb219a5ed68a59f20 (diff)
downloadports-a309fc7b98e2faa0ab054d88a6a3d56574ba9210.tar.gz
ports-a309fc7b98e2faa0ab054d88a6a3d56574ba9210.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64-base/Makefile7
-rw-r--r--emulators/mupen64-base/Makefile.common39
-rw-r--r--emulators/mupen64-base/distinfo6
3 files changed, 43 insertions, 9 deletions
diff --git a/emulators/mupen64-base/Makefile b/emulators/mupen64-base/Makefile
index 694c3c3c3300..fb779e108dfd 100644
--- a/emulators/mupen64-base/Makefile
+++ b/emulators/mupen64-base/Makefile
@@ -7,12 +7,13 @@
PORTNAME= mupen64
PORTVERSION?= 0.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
-MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/ \
+MASTER_SITES= http://mupen64.emulation64.com/files/${MUPEN64VERSION}/ \
${MASTER_SITE_GENTOO:S|$|distfiles/|}
PKGNAMESUFFIX?= -base
-DISTNAME= ${PORTNAME}_src-${PORTVERSION}
+DISTNAME?= ${PORTNAME}_src-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER?= acm@FreeBSD.org
COMMENT?= Mupen64 is a Nintendo 64 emulator
diff --git a/emulators/mupen64-base/Makefile.common b/emulators/mupen64-base/Makefile.common
index 5eeb662cc8bb..da71d5559f56 100644
--- a/emulators/mupen64-base/Makefile.common
+++ b/emulators/mupen64-base/Makefile.common
@@ -1,6 +1,6 @@
DISTNAME= ${PORTNAME}_src-${MUPEN64VERSION}
PATCHDIR= ${.CURDIR}/files
-WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC?= ${WRKDIR}/${DISTNAME}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${DISTNAME}/Makefile ${DISTNAME}/config.h \
${DISTNAME}/main ${DISTNAME}/plugins
@@ -24,7 +24,7 @@ EXTRACT_AFTER_ARGS+= ${DISTNAME}/README.vcr ${DISTNAME}/doc ${DISTNAME}/lang ${D
${DISTNAME}/memory ${DISTNAME}/mupen64.ini ${DISTNAME}/r4300 \
${DISTNAME}/whatsnew.txt
.else
-EXTRA_PATCHES= ${.CURDIR}/../mupen64-base/files/patch-Makefile
+EXTRA_PATCHES?= ${.CURDIR}/../mupen64-base/files/patch-Makefile
PLIST= ${WRKDIR}/pkg-plist
.endif
@@ -68,6 +68,29 @@ ALL_TARGET= plugins/mupen64_hle_rsp_azimer.so
EXTRACT_AFTER_ARGS+= ${DISTNAME}/Makefile ${DISTNAME}/rsp_hle
.endif
+.if ${PKGNAMESUFFIX} == "-glide"
+ALL_TARGET= plugins/Glide64.so
+
+MD5_FILE= ${.CURDIR}/distinfo
+DISTNAME= ${PKGNAMESUFFIX:S/-//:S/$/64/}-${PORTVERSION:S/$/.SP8/}
+
+EXTRACT_AFTER_ARGS+= ${DISTNAME}
+EXTRA_PATCHES= #
+.endif
+
+.if ${PKGNAMESUFFIX} == "-tr64"
+ALL_TARGET= plugins/tr64gl.so
+
+MD5_FILE= ${.CURDIR}/distinfo
+DISTNAME= ${PKGNAMESUFFIX:S/-//}_ogl_gtk2-${PORTVERSION}
+
+EXTRACT_AFTER_ARGS+= ${PKGNAMESUFFIX:S/-//}_ogl-${PORTVERSION}
+EXTRA_PATCHES= #
+
+WRKSRC= ${WRKDIR}/${PKGNAMESUFFIX:S/-//}_ogl-${PORTVERSION}
+.endif
+
+
post-configure:
@${REINPLACE_CMD} -i "" -e 's|^#undef WITH_HOME|#define WITH_HOME \"${PREFIX}/\"|g' ${WRKSRC}/config.h
@@ -76,7 +99,9 @@ post-configure:
.endif
.if defined(HAVE_VCR)
- @${REINPLACE_CMD} -i "" -e 's|^#undef VCR_SUPPORT|#define VCR_SUPPORT 1|g' ${WRKSRC}/config.h
+. if ${PKGNAMESUFFIX} != "-glide"
+ @${REINPLACE_CMD} -i "" -e 's|^#undef VCR_SUPPORT|#define VCR_SUPPORT 1|g' ${WRKSRC}/config.h
+. endif
.endif
.for f in ${FIXFILES}
@@ -86,6 +111,10 @@ post-configure:
.if ${PKGNAMESUFFIX} != "-base"
pre-install:
@${RM} -f ${PLIST}
+. if ${PKGNAMESUFFIX} == "-glide"
+ @${ECHO_CMD} "%%DATADIR%%/plugins/${PLUGIN_NAME}.ini" >> ${PLIST}
+. endif
+
@${ECHO_CMD} "%%DATADIR%%/plugins/${PLUGIN_NAME}.so" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%/plugins" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
@@ -109,5 +138,9 @@ do-install:
. endif
.else
@${MKDIR} ${DATADIR}/plugins
+. if ${PKGNAMESUFFIX} == "-glide"
+ ${INSTALL_DATA} ${WRKSRC}/${PLUGIN_NAME}.ini ${DATADIR}/plugins/
+. endif
+
${INSTALL_PROGRAM} ${WRKSRC}/plugins/${PLUGIN_NAME}.so ${DATADIR}/plugins/
.endif
diff --git a/emulators/mupen64-base/distinfo b/emulators/mupen64-base/distinfo
index 252b86f84101..933ecb5a4e3f 100644
--- a/emulators/mupen64-base/distinfo
+++ b/emulators/mupen64-base/distinfo
@@ -1,3 +1,3 @@
-MD5 (mupen64_src-0.5.tar.bz2) = 11f994bed40e00fad5b82333b553e421
-SHA256 (mupen64_src-0.5.tar.bz2) = 1b8e4188ab7a94d8125b77aed8725ee348c24818622b881adfe16be510487dfd
-SIZE (mupen64_src-0.5.tar.bz2) = 1981046
+MD5 (mupen64/mupen64_src-0.5.tar.bz2) = 11f994bed40e00fad5b82333b553e421
+SHA256 (mupen64/mupen64_src-0.5.tar.bz2) = 1b8e4188ab7a94d8125b77aed8725ee348c24818622b881adfe16be510487dfd
+SIZE (mupen64/mupen64_src-0.5.tar.bz2) = 1981046