aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-07-10 16:44:22 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-07-10 16:44:22 +0000
commite45c9fdb5cc32650864c91543c611bc8fb0904dd (patch)
treefafe29190bb7f2077c2fdd3ee6b8fbbf2d172a18 /emulators
parent57ebee93f3d320d66dd2d6735d49de3a9be9a649 (diff)
downloadports-e45c9fdb5cc32650864c91543c611bc8fb0904dd.tar.gz
ports-e45c9fdb5cc32650864c91543c611bc8fb0904dd.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile1
-rw-r--r--emulators/qemu-devel/files/extra-patch-bsd-user-freebsd-os-sys.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index e3c4c177789f..d6ef944cb506 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -77,6 +77,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-arm-target_arch_thread.h
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-sparc64-target_arch_cpu.h
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-trapsig
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-21927cffcc7bcacbb953155f778200846df9f60e
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-freebsd-os-sys.c
.endif
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
diff --git a/emulators/qemu-devel/files/extra-patch-bsd-user-freebsd-os-sys.c b/emulators/qemu-devel/files/extra-patch-bsd-user-freebsd-os-sys.c
new file mode 100644
index 000000000000..a9f01f34a38c
--- /dev/null
+++ b/emulators/qemu-devel/files/extra-patch-bsd-user-freebsd-os-sys.c
@@ -0,0 +1,13 @@
+--- a/bsd-user/freebsd/os-sys.c
++++ b/bsd-user/freebsd/os-sys.c
+@@ -75,8 +75,10 @@ host_to_target_vfc_flags(int flags)
+ ret |= TARGET_VFCF_JAIL;
+ if (flags & VFCF_DELEGADMIN)
+ ret |= TARGET_VFCF_DELEGADMIN;
++#ifdef VFCF_SBDRY
+ if (flags & VFCF_SBDRY)
+ ret |= TARGET_VFCF_SBDRY;
++#endif
+
+ return ret;
+ }