aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-01-12 00:41:29 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-01-12 00:41:29 +0000
commite8b55f1b0199b666acbe18e0dde8bc698561144c (patch)
tree7053ced3a727d74d80873d5a764a5c3bafe7c611 /emulators
parentaed0f845b2ade967396d3deecfaca526608c8ec3 (diff)
downloadports-e8b55f1b0199b666acbe18e0dde8bc698561144c.tar.gz
ports-e8b55f1b0199b666acbe18e0dde8bc698561144c.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/hercules/Makefile39
-rw-r--r--emulators/hercules/distinfo4
-rw-r--r--emulators/hercules/files/patch-20080506-cvs-endian.diff168
-rw-r--r--emulators/hercules/files/patch-libtool2262
-rw-r--r--emulators/hercules/pkg-plist3
5 files changed, 55 insertions, 221 deletions
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index 78a87e4d9cb6..a328a019bfbb 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -2,29 +2,32 @@
# $FreeBSD$
PORTNAME= hercules
-PORTVERSION= 3.05
-PORTREVISION= 3
+PORTVERSION= 3.07
CATEGORIES= emulators
MASTER_SITES= http://www.hercules-390.org/
MAINTAINER= bzeeb+freebsdports@zabbadoz.net
-COMMENT= The Hercules System/370, ESA/390, and z/Architecture Emulator
+COMMENT= System/370, ESA/390, and z/Architecture Emulator
-OPTIONS= PTHREADS "Build with pthreads instead of fthreads." on \
- NLS "Build with native language support." on \
- DEBUG "Enable for debugging hercules itself." off
+OPTIONS_DEFINE= DEBUG NLS PTHREADS
+OPTIONS_DEFAULT= NLS PTHREADS
+PTHREADS_DESC= Build with pthreads instead of fthreads
USE_AUTOTOOLS= libtool libltdl
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
post-extract:
- ${RM} ${WRKSRC}/ltdl.*
+ @${RM} ${WRKSRC}/ltdl.*
post-patch:
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's@SOL_TCP@IPPROTO_TCP@g' ${WRKSRC}/hscutl.c
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e 's,^SUBDIRS = decNumber m4 po util html man . crypto,SUBDIRS = decNumber m4 po util man . crypto,g' ${WRKSRC}/Makefile.in
.else
@${REINPLACE_CMD} -e 's,^datadir = @datadir@,datadir = ${PREFIX}/share/doc/,' ${WRKSRC}/html/Makefile.in
@@ -35,22 +38,18 @@ post-patch:
MAN1= cckddiag.1 dasdseq.1
MAN4= cckd.4
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_DEBUG)
-CFLAGS+= -g
+.if ${PORT_OPTIONS:MDEBUG}
+CFLAGS+= -g
.endif
-.if defined(WITH_PTHREADS)
+
+.if ${PORT_OPTIONS:MPTHREADS}
CONFIGURE_ARGS+= --disable-fthreads
.endif
-.if defined(WITHOUT_NLS)
+
+.if empty(PORT_OPTIONS:MNLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= GETTEXT="@comment "
.else
@@ -63,4 +62,4 @@ PLIST_SUB+= GETTEXT=""
CONFIGURE_ARGS+= --enable-optimization="no"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/hercules/distinfo b/emulators/hercules/distinfo
index 01352b9db749..cf3bcfda61e3 100644
--- a/emulators/hercules/distinfo
+++ b/emulators/hercules/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hercules-3.05.tar.gz) = f190221fa25692c0316be331f618c0675f9f9875c44b8af3efa7a431d138b1e2
-SIZE (hercules-3.05.tar.gz) = 2470621
+SHA256 (hercules-3.07.tar.gz) = 02d5f6c66d699d413a4db9ef5a799249a6645ac10f2af1edb37992e7fa1f7724
+SIZE (hercules-3.07.tar.gz) = 2701835
diff --git a/emulators/hercules/files/patch-20080506-cvs-endian.diff b/emulators/hercules/files/patch-20080506-cvs-endian.diff
deleted file mode 100644
index 4afac262d7c4..000000000000
--- a/emulators/hercules/files/patch-20080506-cvs-endian.diff
+++ /dev/null
@@ -1,168 +0,0 @@
-Index: control.c
-===================================================================
-RCS file: /usr/cvs/hercules/hercules/control.c,v
-retrieving revision 1.266
-retrieving revision 1.267
-diff -u -p -r1.266 -r1.267
---- control.c 11 Apr 2008 14:28:00 -0000 1.266
-+++ control.c 6 May 2008 22:15:42 -0000 1.267
-@@ -1968,16 +1971,16 @@ U16 updated = 0;
- m = n;
-
- /* Copy from operand beginning */
-- for (i = 0; i < m; i++)
-+ for (i = 0; i < m; i++, p1++)
- {
-- regs->CR_L((r1 + i) & 0xF) = fetch_fw (p1++);
-+ regs->CR_L((r1 + i) & 0xF) = fetch_fw (p1);
- updated |= BIT((r1 + i) & 0xF);
- }
-
- /* Copy from next page */
-- for ( ; i < n; i++)
-+ for ( ; i < n; i++, p2++)
- {
-- regs->CR_L((r1 + i) & 0xF) = fetch_fw (p2++);
-+ regs->CR_L((r1 + i) & 0xF) = fetch_fw (p2);
- updated |= BIT((r1 + i) & 0xF);
- }
-
-Index: esame.c
-===================================================================
-RCS file: /usr/cvs/hercules/hercules/esame.c,v
-retrieving revision 1.201
-retrieving revision 1.202
-diff -u -p -r1.201 -r1.202
---- esame.c 11 Apr 2008 14:28:29 -0000 1.201
-+++ esame.c 6 May 2008 22:15:42 -0000 1.202
-@@ -4038,8 +4041,8 @@ U32 *p1, *p2;
- {
- /* Boundary not crossed */
- n >>= 2;
-- for (i = 0; i < n; i++)
-- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < n; i++, p1++)
-+ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1);
- }
- else
- {
-@@ -4052,11 +4055,11 @@ U32 *p1, *p2;
- {
- /* Addresses are word aligned */
- m >>= 2;
-- for (i = 0; i < m; i++)
-- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < m; i++, p1++)
-+ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1);
- n >>= 2;
-- for ( ; i < n; i++)
-- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p2++);
-+ for ( ; i < n; i++, p2++)
-+ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p2);
- }
- else
- {
-@@ -6728,16 +6731,16 @@ U32 *p1, *p2 = NULL;
- m = n;
-
- /* Load from first page */
-- for (i = 0; i < m; i++)
-+ for (i = 0; i < m; i++, p1++)
- {
-- regs->AR((r1 + i) & 0xF) = fetch_fw (p1++);
-+ regs->AR((r1 + i) & 0xF) = fetch_fw (p1);
- SET_AEA_AR(regs, (r1 + i) & 0xF);
- }
-
- /* Load from next page */
-- for ( ; i < n; i++)
-+ for ( ; i < n; i++, p2++)
- {
-- regs->AR((r1 + i) & 0xF) = fetch_fw (p2++);
-+ regs->AR((r1 + i) & 0xF) = fetch_fw (p2);
- SET_AEA_AR(regs, (r1 + i) & 0xF);
- }
-
-@@ -6811,8 +6814,8 @@ U32 *p1, *p2;
- {
- /* Boundary not crossed */
- n >>= 2;
-- for (i = 0; i < n; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < n; i++, p1++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
- }
- else
- {
-@@ -6825,11 +6828,11 @@ U32 *p1, *p2;
- {
- /* Addresses are word aligned */
- m >>= 2;
-- for (i = 0; i < m; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < m; i++, p1++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
- n >>= 2;
-- for ( ; i < n; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2++);
-+ for ( ; i < n; i++, p2++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2);
- }
- else
- {
-Index: general1.c
-===================================================================
-RCS file: /usr/cvs/hercules/hercules/general1.c,v
-retrieving revision 1.165
-retrieving revision 1.166
-diff -u -p -r1.165 -r1.166
---- general1.c 11 Apr 2008 14:28:44 -0000 1.165
-+++ general1.c 6 May 2008 22:15:42 -0000 1.166
-@@ -3413,16 +3416,16 @@ U32 *p1, *p2 = NULL;
- m = n;
-
- /* Copy from operand beginning */
-- for (i = 0; i < m; i++)
-+ for (i = 0; i < m; i++, p1++)
- {
-- regs->AR((r1 + i) & 0xF) = fetch_fw (p1++);
-+ regs->AR((r1 + i) & 0xF) = fetch_fw (p1);
- SET_AEA_AR (regs, (r1 + i) & 0xF);
- }
-
- /* Copy from next page */
-- for ( ; i < n; i++)
-+ for ( ; i < n; i++, p2++)
- {
-- regs->AR((r1 + i) & 0xF) = fetch_fw (p2++);
-+ regs->AR((r1 + i) & 0xF) = fetch_fw (p2);
- SET_AEA_AR (regs, (r1 + i) & 0xF);
- }
-
-@@ -3580,8 +3583,8 @@ U32 *p1, *p2;
- {
- /* Boundary not crossed */
- n >>= 2;
-- for (i = 0; i < n; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < n; i++, p1++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
- }
- else
- {
-@@ -3594,11 +3597,11 @@ U32 *p1, *p2;
- {
- /* Addresses are word aligned */
- m >>= 2;
-- for (i = 0; i < m; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
-+ for (i = 0; i < m; i++, p1++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
- n >>= 2;
-- for ( ; i < n; i++)
-- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2++);
-+ for ( ; i < n; i++, p2++)
-+ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2);
- }
- else
- {
diff --git a/emulators/hercules/files/patch-libtool22 b/emulators/hercules/files/patch-libtool22
index 273885ebc59c..2fc025f142ad 100644
--- a/emulators/hercules/files/patch-libtool22
+++ b/emulators/hercules/files/patch-libtool22
@@ -1,6 +1,28 @@
---- Makefile.in.orig 2009-07-13 15:39:03.000000000 -0500
-+++ Makefile.in 2009-07-13 15:39:06.000000000 -0500
-@@ -257,13 +257,13 @@
+--- crypto/Makefile.in.orig 2009-07-13 15:39:40.000000000 -0500
++++ crypto/Makefile.in 2009-07-13 15:39:44.000000000 -0500
+@@ -244,7 +244,7 @@
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
+ @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
+-@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
++@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
+ @OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
+--- decNumber/Makefile.in.orig 2009-07-13 15:40:23.000000000 -0500
++++ decNumber/Makefile.in 2009-07-13 15:40:25.000000000 -0500
+@@ -258,7 +258,7 @@
+ @BUILD_SHARED_FALSE@XSTATIC = -static
+ @BUILD_SHARED_TRUE@XSTATIC =
+ @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
+-@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
++@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
+ @OPTION_DYNAMIC_LOAD_FALSE@LIB_LD_FLAGS = $(XSTATIC) \
+ @OPTION_DYNAMIC_LOAD_FALSE@ -no-undefined \
+ @OPTION_DYNAMIC_LOAD_FALSE@ -avoid-version
+--- Makefile.in.orig 2010-03-07 14:04:49.000000000 +0200
++++ Makefile.in 2012-10-14 17:27:30.565513737 +0300
+@@ -304,13 +304,13 @@
libhercu_la_DEPENDENCIES = $(am__DEPENDENCIES_1) libhercs.la
am__libhercu_la_SOURCES_DIST = version.c hscutl.c hscutl2.c codepage.c \
logger.c logmsg.c hdl.c hostinfo.c hsocket.c memrchr.c \
@@ -16,7 +38,7 @@
am_libhercu_la_OBJECTS = version.lo hscutl.lo hscutl2.lo codepage.lo \
logger.lo logmsg.lo hdl.lo hostinfo.lo hsocket.lo memrchr.lo \
parser.lo pttrace.lo $(am__objects_8) $(am__objects_9) \
-@@ -626,7 +626,7 @@
+@@ -687,7 +687,7 @@
@OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
@OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
@OPTION_DYNAMIC_LOAD_FALSE@LTDL =
@@ -25,7 +47,7 @@
@OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
@OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
@OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
-@@ -843,8 +843,7 @@
+@@ -913,8 +913,7 @@
memrchr.c \
$(dynamic_SRC) \
$(extra_SRC) \
@@ -35,7 +57,7 @@
libherc_la_LDFLAGS = $(LIB_LD_FLAGS)
libherc_la_LIBADD = libhercs.la \
-@@ -1089,7 +1088,6 @@
+@@ -1166,7 +1165,6 @@
hdl.h \
crypto.h \
sockdev.h \
@@ -43,33 +65,11 @@
herc_getopt.h \
service.h \
chsc.h \
-@@ -1465,7 +1463,6 @@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/loadparm.Plo@am__quote@
+@@ -1552,7 +1550,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logger.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logmsg.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/losc.Plo@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ltdl.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/machchk.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memrchr.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opcode.Plo@am__quote@
---- crypto/Makefile.in.orig 2009-07-13 15:39:40.000000000 -0500
-+++ crypto/Makefile.in 2009-07-13 15:39:44.000000000 -0500
-@@ -244,7 +244,7 @@
- @OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
- @OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
- @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
--@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
-+@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
- @OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
- @OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
- @OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
---- decNumber/Makefile.in.orig 2009-07-13 15:40:23.000000000 -0500
-+++ decNumber/Makefile.in 2009-07-13 15:40:25.000000000 -0500
-@@ -258,7 +258,7 @@
- @BUILD_SHARED_FALSE@XSTATIC = -static
- @BUILD_SHARED_TRUE@XSTATIC =
- @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
--@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
-+@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
- @OPTION_DYNAMIC_LOAD_FALSE@LIB_LD_FLAGS = $(XSTATIC) \
- @OPTION_DYNAMIC_LOAD_FALSE@ -no-undefined \
- @OPTION_DYNAMIC_LOAD_FALSE@ -avoid-version
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/omatape.Plo@am__quote@
diff --git a/emulators/hercules/pkg-plist b/emulators/hercules/pkg-plist
index dd81e5f58eb6..5e9e3b367e34 100644
--- a/emulators/hercules/pkg-plist
+++ b/emulators/hercules/pkg-plist
@@ -66,11 +66,14 @@ lib/hercules/hdt3505.la
lib/hercules/hdt3505.so
lib/hercules/hdt3525.la
lib/hercules/hdt3525.so
+lib/hercules/hdt3705.la
+lib/hercules/hdt3705.so
lib/hercules/hdteq.la
lib/hercules/hdteq.so
lib/hercules/hdtqeth.la
lib/hercules/hdtqeth.so
@dirrm lib/hercules
+%%DATADIR%%/TMOUNT.txt
%%DATADIR%%/awssl-v19g
%%DATADIR%%/awswrite.jcl
%%DATADIR%%/cckddump.hla