aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:49:25 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:49:25 +0000
commit1ebe0c8e83f539b2512d69a2b482e3f8a4af39f7 (patch)
treef251646a244da7778d0ebaea473c1c4f964b5e18 /emulators
parentffef66e77669b6d46f2d6bf1d214d488ee63b237 (diff)
downloadports-1ebe0c8e83f539b2512d69a2b482e3f8a4af39f7.tar.gz
ports-1ebe0c8e83f539b2512d69a2b482e3f8a4af39f7.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-gln64/Makefile23
-rw-r--r--emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp39
3 files changed, 63 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 0b43c9068f45..9b5b204aa152 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -110,6 +110,7 @@
SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-dummyaudio
SUBDIR += mupen64plus-glide
+ SUBDIR += mupen64plus-gln64
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader
diff --git a/emulators/mupen64plus-gln64/Makefile b/emulators/mupen64plus-gln64/Makefile
new file mode 100644
index 000000000000..407b8b6b49d1
--- /dev/null
+++ b/emulators/mupen64plus-gln64/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mupen64plus-gln64
+# Date created: 2008-05-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -gln64
+
+COMMENT= The glN64 graphics plugin for Mupen64plus
+
+USE_GL= yes
+USE_SDL= sdl
+
+FIXFILES= glN64/DepthBuffer.cpp
+
+PLUGIN_NAME= glN64
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-base
+
+OPTIONS= #
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp b/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp
new file mode 100644
index 000000000000..afaf0fbc94ca
--- /dev/null
+++ b/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp
@@ -0,0 +1,39 @@
+--- glN64/Config_linux.cpp 2008-05-16 17:58:34.000000000 -0500
++++ glN64/Config_linux.cpp 2008-05-16 18:00:13.000000000 -0500
+@@ -1,4 +1,3 @@
+-#include <features.h>
+ #include <dlfcn.h>
+ #include <unistd.h>
+ #include "../main/winlnxdefs.h"
+@@ -44,29 +43,8 @@
+ }
+ else
+ {
+-#ifdef __USE_GNU
+- Dl_info info;
+- void *addr = (void*)GetPluginDir;
+- if(dladdr(addr, &info) != 0)
+- {
+- strncpy(path, info.dli_fname, PATH_MAX);
+- *(strrchr(path, '/')) = '\0';
+- }
+- else
+- {
+- fprintf(stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n");
+-#endif // __USE_GNU
+- if(readlink("/proc/self/exe", path, PATH_MAX) == -1)
+- {
+- fprintf(stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror(errno));
+- path[0] = '.';
+- path[1] = '\0';
+- }
+- *(strrchr(path, '/')) = '\0';
+- strncat(path, "/plugins", PATH_MAX);
+-#ifdef __USE_GNU
+- }
+-#endif
++ strcpy(path, getenv("HOME"));
++ strncat(path, "/.mupen64plus/plugins", PATH_MAX);
+ }
+ return path;
+ }