aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /emulators
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile2
-rw-r--r--emulators/i386-wine-devel/Makefile.amd646
-rw-r--r--emulators/i386-wine/Makefile2
-rw-r--r--emulators/i386-wine/Makefile.amd646
-rw-r--r--emulators/i386-wine/pkg-plist1
-rw-r--r--emulators/libc6-shim/Makefile1
-rw-r--r--emulators/linux_base-c7/Makefile3
-rw-r--r--emulators/mesen/Makefile17
-rw-r--r--emulators/qemu-devel/Makefile1
-rw-r--r--emulators/qemu-guest-agent/Makefile6
-rw-r--r--emulators/qemu-guest-agent/pkg-message-1124
-rw-r--r--emulators/rpcs3/files/patch-rpcs3_Emu_system__config.h16
-rw-r--r--emulators/rtc/files/rtc.c18
-rw-r--r--emulators/sameboy/Makefile1
-rw-r--r--emulators/xen-kernel/Makefile4
-rw-r--r--emulators/yuzu/files/patch-freebsd1146
16 files changed, 11 insertions, 143 deletions
diff --git a/emulators/i386-wine-devel/Makefile b/emulators/i386-wine-devel/Makefile
index 11df0601940f..e5aa64d6ee7e 100644
--- a/emulators/i386-wine-devel/Makefile
+++ b/emulators/i386-wine-devel/Makefile
@@ -27,7 +27,7 @@ PKGDEINSTALL= ${PKGINSTALL}
distinfo-update:
${RM} ${.CURDIR}/distinfo~
-.for osrel in 11 12 13 14
+.for osrel in 12 13 14
${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${CAT} ${.CURDIR}/distinfo >> ${.CURDIR}/distinfo~
.endfor
diff --git a/emulators/i386-wine-devel/Makefile.amd64 b/emulators/i386-wine-devel/Makefile.amd64
index 19d705e314d9..4a03379d2e8f 100644
--- a/emulators/i386-wine-devel/Makefile.amd64
+++ b/emulators/i386-wine-devel/Makefile.amd64
@@ -21,7 +21,7 @@ USES= desktop-file-utils tar:txz
BUNDLE_LIBS= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-.for osrel in 11 12 13 14
+.for osrel in 12 13 14
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
PLIST_SUB+= NOOSREL${osrel}="@comment "
@@ -31,8 +31,8 @@ PLIST_SUB+= NOOSREL${osrel}=""
.endif
.endfor
-.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1104001 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1202000 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300139 && ${OSVERSION} < 1400000) && !(${OSVERSION} >= 1400024))
-IGNORE= binaries compiled for FreeBSD 11.4+, 12.2+, 13.0+ and 14.0+ only
+.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1202000 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300139 && ${OSVERSION} < 1400000) && !(${OSVERSION} >= 1400024))
+IGNORE= binaries compiled for FreeBSD 12.2+, 13.0+ and 14.0+ only
.endif
OPTIONS_DEFINE= GECKO MONO
diff --git a/emulators/i386-wine/Makefile b/emulators/i386-wine/Makefile
index c0667e8ba455..7904a4328f45 100644
--- a/emulators/i386-wine/Makefile
+++ b/emulators/i386-wine/Makefile
@@ -26,7 +26,7 @@ PKGDEINSTALL= ${PKGINSTALL}
distinfo-update:
${RM} ${.CURDIR}/distinfo ${.CURDIR}/distinfo~
-.for osrel in 11 12 13 14
+.for osrel in 12 13 14
${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${CAT} ${.CURDIR}/distinfo >> ${.CURDIR}/distinfo~
diff --git a/emulators/i386-wine/Makefile.amd64 b/emulators/i386-wine/Makefile.amd64
index 8af03b14fc8a..565689b58994 100644
--- a/emulators/i386-wine/Makefile.amd64
+++ b/emulators/i386-wine/Makefile.amd64
@@ -22,7 +22,7 @@ BUNDLE_LIBS= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
PORTSCOUT= limitw:1,even
-.for osrel in 11 12 13 14
+.for osrel in 12 13 14
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
PLIST_SUB+= NOOSREL${osrel}="@comment "
@@ -32,8 +32,8 @@ PLIST_SUB+= NOOSREL${osrel}=""
.endif
.endfor
-.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1104001 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1202000 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300139 && ${OSVERSION} < 1400000) && !(${OSVERSION} >= 1400024))
-IGNORE= binaries compiled for FreeBSD 11.4+, 12.2+, 13.0+ & 14.0+ only
+.if ${OPSYS} != FreeBSD || (!(${OSVERSION} >= 1202000 && ${OSVERSION} < 1300000) && !(${OSVERSION} >= 1300139 && ${OSVERSION} < 1400000) && !(${OSVERSION} >= 1400024))
+IGNORE= binaries compiled for FreeBSD 12.2+, 13.0+ & 14.0+ only
.endif
OPTIONS_DEFINE= GECKO MONO
diff --git a/emulators/i386-wine/pkg-plist b/emulators/i386-wine/pkg-plist
index 38394c36fe31..370366b6576c 100644
--- a/emulators/i386-wine/pkg-plist
+++ b/emulators/i386-wine/pkg-plist
@@ -1160,7 +1160,6 @@ lib32/libpcre.so.1
lib32/libpng16.so.16
lib32/libtasn1.so.6
lib32/libunistring.so.2
-%%OSREL11%%lib32/libunwind.so.8
lib32/libwine.so
lib32/libwine.so.1
lib32/libxcb-dri2.so.0
diff --git a/emulators/libc6-shim/Makefile b/emulators/libc6-shim/Makefile
index 4d0dfe5cc53d..d6d8e20aea3b 100644
--- a/emulators/libc6-shim/Makefile
+++ b/emulators/libc6-shim/Makefile
@@ -8,7 +8,6 @@ COMMENT= ABI-compatible glibc shim library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_FreeBSD_11=not supported
ONLY_FOR_ARCHS= amd64
USE_GITHUB= yes
diff --git a/emulators/linux_base-c7/Makefile b/emulators/linux_base-c7/Makefile
index d267f05ec2d5..8964a3901c63 100644
--- a/emulators/linux_base-c7/Makefile
+++ b/emulators/linux_base-c7/Makefile
@@ -131,8 +131,7 @@ REMOVE_FILES= bin/chfn bin/chsh bin/findmnt bin/login bin/lsblk bin/lscpu \
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && (${OSVERSION} < 1201524 \
- || (${OSVERSION} >= 1300000 && ${OSVERSION} < 1300077))
+.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1300000 && ${OSVERSION} < 1300077)
GLIBC_VER= 2.17-292.el7
MASTER_SITE_SUBDIR+= centos/7.7.1908/os/x86_64/Packages/:DEFAULT,amd64 \
centos/7.7.1908/updates/x86_64/Packages/:DEFAULT,amd64 \
diff --git a/emulators/mesen/Makefile b/emulators/mesen/Makefile
index 083312a41888..052b714128bf 100644
--- a/emulators/mesen/Makefile
+++ b/emulators/mesen/Makefile
@@ -26,24 +26,11 @@ USE_SDL= sdl2
MAKEFILE= makefile
MAKE_ARGS= MESENPLATFORM=${MESEN_ARCH} \
CC="${CC}" CPPC="${CXX}" \
+ FSLIB=-lc++experimental \
+ LTO=true \
SYSTEM_LIBEVDEV=true
MESEN_ARCH= ${ARCH:S/amd64/x64/:S/i386/x86/}
-.if exists(/usr/lib/libc++fs.a)
-MAKE_ARGS+= FSLIB=-lc++fs
-.elif exists(/usr/lib/libc++experimental.a)
-# XXX Remove after FreeBSD 12.0 EOL
-MAKE_ARGS+= FSLIB=-lc++experimental
-.else
-# XXX Remove after FreeBSD 11.2 EOL
-USE_GCC= yes
-.endif
-
-# XXX Always enable LTO after FreeBSD 11.2 and 12.0 EOL
-.if defined(USE_GCC) || (${/usr/bin/ld:L:tA} == /usr/bin/ld.lld)
-MAKE_ARGS+= LTO=true
-.endif
-
OPTIONS_MULTI= FRONTENDS
OPTIONS_MULTI_FRONTENDS= MONO LIBRETRO
OPTIONS_DEFAULT= MONO LIBRETRO
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 9220675fb093..699fecc85471 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -12,7 +12,6 @@ COMMENT= QEMU CPU Emulator - development version
LICENSE= GPLv2
ONLY_FOR_ARCHS= amd64 powerpc powerpc64 powerpc64 powerpc64le
-IGNORE_FreeBSD_11= Unable to produce Position Independent Code
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
diff --git a/emulators/qemu-guest-agent/Makefile b/emulators/qemu-guest-agent/Makefile
index 66aa2ff0c86a..21b02023f317 100644
--- a/emulators/qemu-guest-agent/Makefile
+++ b/emulators/qemu-guest-agent/Makefile
@@ -163,12 +163,6 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
-.if ${OSVERSION} < 1200000
-PKGMESSAGE= ${.CURDIR}/pkg-message-11
-.else
-PKGMESSAGE= ${.CURDIR}/pkg-message
-.endif
-
PLIST_SUB+= LINUXBOOT_DMA=""
# XXX need to disable usb host code on head while it's not ported to the
diff --git a/emulators/qemu-guest-agent/pkg-message-11 b/emulators/qemu-guest-agent/pkg-message-11
deleted file mode 100644
index aa4cddb92062..000000000000
--- a/emulators/qemu-guest-agent/pkg-message-11
+++ /dev/null
@@ -1,24 +0,0 @@
-[
-{ type: install
- message: <<EOM
-=======================================================
-Modify your `/etc/rc.conf` by adding these settings
-
-qemu_guest_agent_enable="YES"
-qemu_guest_agent_flags="-d -v -l /var/log/qemu-ga.log"
-
-and run
-# service qemu-guest-agent start
-
-For FreeBSD less than 12
-------------------------
-virtio_console driver in FreeBSD 11 doesn't support aliasing virtio channels in devfs. Use direct path for control device. eq:
-qemu_guest_agent_flags="-d -v -l /var/log/qemu-ga.log -p /dev/ttyV0.2"
-
-For detailed help use `qemu-ga -h`
-
-Also read port homepage https://github.com/aborche/qemu-guest-agent
-=======================================================
-EOM
-}
-]
diff --git a/emulators/rpcs3/files/patch-rpcs3_Emu_system__config.h b/emulators/rpcs3/files/patch-rpcs3_Emu_system__config.h
deleted file mode 100644
index 653489f1a9c1..000000000000
--- a/emulators/rpcs3/files/patch-rpcs3_Emu_system__config.h
+++ /dev/null
@@ -1,16 +0,0 @@
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240495
-
---- rpcs3/Emu/system_config.h.orig 2020-05-02 11:57:38 UTC
-+++ rpcs3/Emu/system_config.h
-@@ -28,7 +28,11 @@ struct cfg_root : cfg::node
- cfg::_int<0, INT32_MAX> llvm_threads{ this, "Max LLVM Compile Threads", 0 };
- cfg::_bool thread_scheduler_enabled{ this, "Enable thread scheduler", thread_scheduler_enabled_def };
- cfg::_bool set_daz_and_ftz{ this, "Set DAZ and FTZ", false };
-+#if defined(__FreeBSD__) && __FreeBSD__ < 12
-+ cfg::_enum<spu_decoder_type> spu_decoder{ this, "SPU Decoder", spu_decoder_type::asmjit };
-+#else
- cfg::_enum<spu_decoder_type> spu_decoder{ this, "SPU Decoder", spu_decoder_type::llvm };
-+#endif
- cfg::_bool lower_spu_priority{ this, "Lower SPU thread priority" };
- cfg::_bool spu_debug{ this, "SPU Debug" };
- cfg::_int<0, 6> preferred_spu_threads{ this, "Preferred SPU Threads", 0, true }; // Number of hardware threads dedicated to heavy simultaneous spu tasks
diff --git a/emulators/rtc/files/rtc.c b/emulators/rtc/files/rtc.c
index 8cc3f50dfa23..49c3638965f7 100644
--- a/emulators/rtc/files/rtc.c
+++ b/emulators/rtc/files/rtc.c
@@ -337,36 +337,18 @@ rtc_callback(void *xtp)
restart:
increment.tv_sec = 0;
increment.tv_nsec = 1000000000 / sc->var.freq;
-#if P_OSREL_MAJOR(__FreeBSD_version) >= 12
timespecadd(&sc->var.lasttime, &increment, &sc->var.lasttime);
timespecadd(&sc->var.lasttime, &increment, &nexttime);
-#else
- timespecadd(&sc->var.lasttime, &increment);
- nexttime.tv_sec = sc->var.lasttime.tv_sec;
- nexttime.tv_nsec = sc->var.lasttime.tv_nsec;
- timespecadd(&nexttime, &increment);
-#endif
if (timespeccmp(&nexttime, &curtime, <)) {
/* Catch up if we lag curtime */
-#if P_OSREL_MAJOR(__FreeBSD_version) >= 12
timespecsub(&curtime, &increment, &sc->var.lasttime);
timespecsub(&nexttime, &curtime, &nexttime);
-#else
- sc->var.lasttime.tv_sec = curtime.tv_sec;
- sc->var.lasttime.tv_nsec = curtime.tv_nsec;
- timespecsub(&sc->var.lasttime, &increment);
- timespecsub(&nexttime, &curtime);
-#endif
#if 0
printf("lagging curtime by %d.%ld\n", nexttime.tv_sec, nexttime.tv_nsec);
#endif
goto restart;
} else {
-#if P_OSREL_MAJOR(__FreeBSD_version) >= 12
timespecsub(&nexttime, &curtime, &nexttime);
-#else
- timespecsub(&nexttime, &curtime);
-#endif
sleep = nexttime.tv_nsec / (1000000000 / hz);
}
callout_reset(&sc->var.rtc_handle, sleep, &rtc_callback, xtp);
diff --git a/emulators/sameboy/Makefile b/emulators/sameboy/Makefile
index 7ae33480fa50..899ed51f2574 100644
--- a/emulators/sameboy/Makefile
+++ b/emulators/sameboy/Makefile
@@ -22,7 +22,6 @@ USE_SDL= sdl2
MAKE_ARGS= FREEDESKTOP=true
ALL_TARGET= sdl
# -flto
-LDFLAGS+= -fuse-ld=lld
OPTIONS_DEFINE= LIBRETRO
OPTIONS_DEFAULT= LIBRETRO
diff --git a/emulators/xen-kernel/Makefile b/emulators/xen-kernel/Makefile
index 24c222999c77..8bd1c117fa20 100644
--- a/emulators/xen-kernel/Makefile
+++ b/emulators/xen-kernel/Makefile
@@ -34,10 +34,6 @@ EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-mtrr-remove-stale-function-prototype.patch:
IGNORE= only supported on FreeBSD
.endif
-.if ${OSVERSION} < 1200074
-IGNORE= only supported on FreeBSD 12.0 or newer
-.endif
-
# The ports native 'build' target cannot be used because it sets
# CFLAGS, and that breaks the Xen build system.
do-build:
diff --git a/emulators/yuzu/files/patch-freebsd11 b/emulators/yuzu/files/patch-freebsd11
deleted file mode 100644
index c3922e2e2507..000000000000
--- a/emulators/yuzu/files/patch-freebsd11
+++ /dev/null
@@ -1,46 +0,0 @@
-Drop after FreeBSD 11 EOL. OpenSSL 1.0 still works fine.
-
--- Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR: Found unsuitable version "1.0.2u", but required is at least "1.1" (found /usr/lib/libcrypto.so, )
-CMake Error at externals/CMakeLists.txt:83 (add_subdirectory):
-
-In file included from src/core/hle/service/bcat/backend/boxcat.cpp:6:
-externals/./httplib/httplib.h:214:2: error: Sorry, OpenSSL versions prior to 1.1.1 are not supported
-#error Sorry, OpenSSL versions prior to 1.1.1 are not supported
- ^
-
---- externals/CMakeLists.txt.orig 2020-11-18 04:02:27 UTC
-+++ externals/CMakeLists.txt
-@@ -73,7 +73,7 @@ if (NOT LIBZIP_FOUND)
- endif()
-
- if (ENABLE_WEB_SERVICE)
-- find_package(OpenSSL 1.1)
-+ find_package(OpenSSL)
- if (OPENSSL_FOUND)
- set(OPENSSL_LIBRARIES OpenSSL::SSL OpenSSL::Crypto)
- else()
---- externals/cpp-httplib/httplib.h.orig 2021-06-18 12:45:50 UTC
-+++ externals/cpp-httplib/httplib.h
-@@ -219,10 +219,6 @@ using socket_t = int;
- #include <iostream>
- #include <sstream>
-
--#if OPENSSL_VERSION_NUMBER < 0x1010100fL
--#error Sorry, OpenSSL versions prior to 1.1.1 are not supported
--#endif
--
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
- #include <openssl/crypto.h>
- inline const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1) {
-@@ -6729,7 +6725,11 @@ static SSLInit sslinit_;
- inline SSLServer::SSLServer(const char *cert_path, const char *private_key_path,
- const char *client_ca_cert_file_path,
- const char *client_ca_cert_dir_path) {
-+#if OPENSSL_VERSION_NUMBER < 0x10100001L
-+ ctx_ = SSL_CTX_new(SSLv23_server_method());
-+#else
- ctx_ = SSL_CTX_new(TLS_method());
-+#endif
-
- if (ctx_) {
- SSL_CTX_set_options(ctx_,