aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-22 15:26:03 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-22 15:26:03 +0000
commitca38a6bd4f9611539951c2d55af7afde252a25cd (patch)
treed486543df5091f2cdc34e29177a7a8a2c32b2f70 /emulators
parentbd2f0fbaef00d1a48602391c3d6bb3e2b5e57648 (diff)
downloadports-ca38a6bd4f9611539951c2d55af7afde252a25cd.tar.gz
ports-ca38a6bd4f9611539951c2d55af7afde252a25cd.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/tiemu2/Makefile37
-rw-r--r--emulators/tiemu2/distinfo3
-rw-r--r--emulators/tiemu2/pkg-descr9
-rw-r--r--emulators/tiemu2/pkg-plist121
5 files changed, 171 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index e4d11f1da041..8924db0cef41 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -108,6 +108,7 @@
SUBDIR += stella
SUBDIR += stonx
SUBDIR += svr4_base
+ SUBDIR += tiemu2
SUBDIR += tkhfs
SUBDIR += tuxnes
SUBDIR += twin
diff --git a/emulators/tiemu2/Makefile b/emulators/tiemu2/Makefile
new file mode 100644
index 000000000000..ff5c26e9c2a0
--- /dev/null
+++ b/emulators/tiemu2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: TiEmu-2
+# Date created: 21 Feb 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiemu2
+PORTVERSION= 2.04
+CATEGORIES= emulators
+MASTER_SITES= http://www.ticalc.org/pub/unix/ \
+ http://freebsd.nsu.ru/distfiles/tiemu/
+DISTNAME= tiemu
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= TI89(ti)/92(+)/V200 hand-helds emulator
+
+LIB_DEPENDS= ticalcs.9:${PORTSDIR}/devel/libticalcs \
+ ticables.12:${PORTSDIR}/comms/libticables \
+ tifiles.6:${PORTSDIR}/devel/libtifiles
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
+
+MAN1= tiemu.1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-extract: .SILENT
+ ${REINPLACE_CMD} -e 's,\*-\*-linux\*,\*-\*-freebsd\*,' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -E 's,(install-data-am:).*$$,\1,' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's,defined(__LINUX__),& || defined(__BSD__),' \
+ ${WRKSRC}/src/gui/calc/pckeys.h ${WRKSRC}/src/misc/paths.h
+
+.include <bsd.port.mk>
diff --git a/emulators/tiemu2/distinfo b/emulators/tiemu2/distinfo
new file mode 100644
index 000000000000..3933cf7b6e35
--- /dev/null
+++ b/emulators/tiemu2/distinfo
@@ -0,0 +1,3 @@
+MD5 (tiemu.tar.gz) = 19c365c2277a95a4290ac268b3733862
+SHA256 (tiemu.tar.gz) = 5158ee6af771be1340219fc47f1a8ab863487e1a41e88e29690a5630fb0b0380
+SIZE (tiemu.tar.gz) = 2267307
diff --git a/emulators/tiemu2/pkg-descr b/emulators/tiemu2/pkg-descr
new file mode 100644
index 000000000000..dadfccfa7298
--- /dev/null
+++ b/emulators/tiemu2/pkg-descr
@@ -0,0 +1,9 @@
+This project aims to develop a fast emulator for the TI89(titanium), 92(+),
+and V200PLT calculators. This emulator started on the Jonas Minnberg's
+(X)Tiger emulator which is based on UAE (the Universal Amiga Emulator). It
+was deeply reworked and improved thus it's very different now.
+
+TiEmu uses the GDK library (GTK component) for display. The GUI has been
+written with GTK+ (the Gimp ToolKit).
+
+WWW: http://lpg.ticalc.org/prj_tiemu/
diff --git a/emulators/tiemu2/pkg-plist b/emulators/tiemu2/pkg-plist
new file mode 100644
index 000000000000..6c36b144b0ab
--- /dev/null
+++ b/emulators/tiemu2/pkg-plist
@@ -0,0 +1,121 @@
+bin/tiemu-2
+%%DATADIR%%/glade/about-2.glade
+%%DATADIR%%/glade/calc-2.glade
+%%DATADIR%%/glade/comm-2.glade
+%%DATADIR%%/glade/dbg_bkpts-2.glade
+%%DATADIR%%/glade/dbg_cause-2.glade
+%%DATADIR%%/glade/dbg_code-2.glade
+%%DATADIR%%/glade/dbg_data-2.glade
+%%DATADIR%%/glade/dbg_entry-2.glade
+%%DATADIR%%/glade/dbg_heap-2.glade
+%%DATADIR%%/glade/dbg_ioports-2.glade
+%%DATADIR%%/glade/dbg_mem-2.glade
+%%DATADIR%%/glade/dbg_pclog-2.glade
+%%DATADIR%%/glade/dbg_regs-2.glade
+%%DATADIR%%/glade/dbg_stack-2.glade
+%%DATADIR%%/glade/dbg_vectors-2.glade
+%%DATADIR%%/glade/dboxes-2.glade
+%%DATADIR%%/glade/infos-2.glade
+%%DATADIR%%/glade/manpage-2.glade
+%%DATADIR%%/glade/pbars-2.glade
+%%DATADIR%%/glade/popup-2.glade
+%%DATADIR%%/glade/release-2.glade
+%%DATADIR%%/glade/romversion-2.glade
+%%DATADIR%%/glade/scroptions-2.glade
+%%DATADIR%%/glade/wizard-2.glade
+%%DATADIR%%/glade/about-2.gladep
+%%DATADIR%%/glade/calc-2.gladep
+%%DATADIR%%/glade/comm-2.gladep
+%%DATADIR%%/glade/dbg_bkpts-2.gladep
+%%DATADIR%%/glade/dbg_cause-2.gladep
+%%DATADIR%%/glade/dbg_code-2.gladep
+%%DATADIR%%/glade/dbg_data-2.gladep
+%%DATADIR%%/glade/dbg_entry-2.gladep
+%%DATADIR%%/glade/dbg_heap-2.gladep
+%%DATADIR%%/glade/dbg_ioports-2.gladep
+%%DATADIR%%/glade/dbg_mem-2.gladep
+%%DATADIR%%/glade/dbg_pclog-2.gladep
+%%DATADIR%%/glade/dbg_regs-2.gladep
+%%DATADIR%%/glade/dbg_stack-2.gladep
+%%DATADIR%%/glade/dbg_vectors-2.gladep
+%%DATADIR%%/glade/dboxes-2.gladep
+%%DATADIR%%/glade/infos-2.gladep
+%%DATADIR%%/glade/manpage-2.gladep
+%%DATADIR%%/glade/pbars-2.gladep
+%%DATADIR%%/glade/popup-2.gladep
+%%DATADIR%%/glade/release-2.gladep
+%%DATADIR%%/glade/romversion-2.gladep
+%%DATADIR%%/glade/scroptions-2.gladep
+%%DATADIR%%/glade/wizard-2.gladep
+%%DATADIR%%/help/FAQ.html
+%%DATADIR%%/help/Manual_en.html
+%%DATADIR%%/help/chapter01.html
+%%DATADIR%%/help/chapter02.html
+%%DATADIR%%/help/chapter03.html
+%%DATADIR%%/help/chapter04.html
+%%DATADIR%%/help/chapter05.html
+%%DATADIR%%/help/chapter06.html
+%%DATADIR%%/help/chapter07.html
+%%DATADIR%%/help/chapter08.html
+%%DATADIR%%/help/chapter09.html
+%%DATADIR%%/help/chapter10.html
+%%DATADIR%%/help/chapter11.html
+%%DATADIR%%/help/chapter20.html
+%%DATADIR%%/help/chapter21.html
+%%DATADIR%%/help/chapter22.html
+%%DATADIR%%/help/calc_infos.png
+%%DATADIR%%/help/dbg_bkpts.png
+%%DATADIR%%/help/dbg_heap.png
+%%DATADIR%%/help/dbg_mem.png
+%%DATADIR%%/help/dbg_registers.png
+%%DATADIR%%/help/dbg_search.png
+%%DATADIR%%/help/dbg_source.png
+%%DATADIR%%/help/dbg_sr.png
+%%DATADIR%%/help/dbg_stack.png
+%%DATADIR%%/help/linkport.png
+%%DATADIR%%/help/logo_lpg.png
+%%DATADIR%%/help/logo_tiemu.png
+%%DATADIR%%/help/no_skin.png
+%%DATADIR%%/help/popup_menu.png
+%%DATADIR%%/help/romversion.png
+%%DATADIR%%/help/screenshot.png
+%%DATADIR%%/help/wizard.png
+%%DATADIR%%/help/skinedit.jpg
+%%DATADIR%%/help/tiemu.jpg
+%%DATADIR%%/misc/iodefs_ti89_hw1.txt
+%%DATADIR%%/misc/iodefs_ti89_hw2.txt
+%%DATADIR%%/misc/iodefs_ti89t_hw3.txt
+%%DATADIR%%/misc/iodefs_ti92_hw1.txt
+%%DATADIR%%/misc/iodefs_ti92p_hw1.txt
+%%DATADIR%%/misc/iodefs_ti92p_hw2.txt
+%%DATADIR%%/misc/iodefs_v200_hw2.txt
+%%DATADIR%%/misc/romcalls.txt
+%%DATADIR%%/pedrom/pedrom89.tib
+%%DATADIR%%/pedrom/pedrom89ti.tib
+%%DATADIR%%/pedrom/pedrom9x.tib
+%%DATADIR%%/pedrom/pedromv2.tib
+%%DATADIR%%/pixmaps/bkpt.xpm
+%%DATADIR%%/pixmaps/bkpt_tmp.xpm
+%%DATADIR%%/pixmaps/icon.xpm
+%%DATADIR%%/pixmaps/logo.xpm
+%%DATADIR%%/pixmaps/run.xpm
+%%DATADIR%%/pixmaps/void.xpm
+%%DATADIR%%/skins/ipaq_89.skn
+%%DATADIR%%/skins/ipaq_92.skn
+%%DATADIR%%/skins/ipaq_v200plt.skn
+%%DATADIR%%/skins/ti89.skn
+%%DATADIR%%/skins/ti89t.skn
+%%DATADIR%%/skins/ti92.skn
+%%DATADIR%%/skins/v200plt.skn
+%%DATADIR%%/skins/ti89.map
+%%DATADIR%%/skins/ti89_fr.map
+%%DATADIR%%/skins/ti92.map
+%%DATADIR%%/skins/ti92_fr.map
+%%DATADIR%%/Manpage.txt
+@dirrm %%DATADIR%%/skins
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/pedrom
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%