aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2003-02-07 22:17:09 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2003-02-07 22:17:09 +0000
commit9a7ff961bb4852d2886377e6dd52bc43bdc6d33e (patch)
treebdd6cf7d467e70a0ba2707331306a392967ee059 /emulators
parentb77d7e4e498295b9b5cde81a4563cfc7e806464e (diff)
downloadports-9a7ff961bb4852d2886377e6dd52bc43bdc6d33e.tar.gz
ports-9a7ff961bb4852d2886377e6dd52bc43bdc6d33e.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ski/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/emulators/ski/Makefile b/emulators/ski/Makefile
index 3c4369e2c659..e7454732162c 100644
--- a/emulators/ski/Makefile
+++ b/emulators/ski/Makefile
@@ -18,8 +18,10 @@ MAINTAINER= freebsd-ia64@FreeBSD.org
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
ONLY_FOR_ARCHS= i386
-NO_PACKAGE= 'Must be downloaded direct from HP via web interface'
-NO_CDROM= 'Must be downloaded direct from HP via web interface'
+
+NOTICE= -- please manually download ${DISTNAME}${EXTRACT_SUFX} from the HP site and put it in ${DISTDIR} first.
+NO_PACKAGE= ${NOTICE}
+NO_CDROM= ${NOTICE}
EXTRACT_CMD= rpm2cpio
EXTRACT_BEFORE_ARGS=
@@ -49,4 +51,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/usr/doc/ski-0.943l/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= ${NOTICE}
+.endif
+
+.include <bsd.port.post.mk>