aboutsummaryrefslogtreecommitdiff
path: root/finance/aqbanking/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-06-08 14:52:51 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-06-08 14:52:51 +0000
commitd58ef8d2e2710dc47974e38d7a1b7214e932c217 (patch)
tree9e8efa20c2f36969fe42a1214cc6d2381d7d9627 /finance/aqbanking/Makefile
parent877d5ac090fe2e18a70da0f70fc033cb5dcd5476 (diff)
downloadports-d58ef8d2e2710dc47974e38d7a1b7214e932c217.tar.gz
ports-d58ef8d2e2710dc47974e38d7a1b7214e932c217.zip
Notes
Diffstat (limited to 'finance/aqbanking/Makefile')
-rw-r--r--finance/aqbanking/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
new file mode 100644
index 000000000000..4ab10b87386f
--- /dev/null
+++ b/finance/aqbanking/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: aqbanking
+# Date created: June 2005
+# Whom: Sam Lawrance <lawrance@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aqbanking
+PORTVERSION= 1.0.11
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aqbanking
+
+MAINTAINER= lawrance@FreeBSD.org
+COMMENT= Online banking interface and financial data framework
+
+LIB_DEPENDS= gwenhywfar.30:${PORTSDIR}/devel/gwenhywfar
+
+OPTIONS= OFX "LibOFX support" off \
+ KTOBLZCHECK "KtoBlzCheck support" off
+
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GCC= 3.4+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OFX)
+LIB_DEPENDS+= ofx.1:${PORTSDIR}/finance/libofx
+CONFIGURE_ARGS+=--enable-libofx
+PLIST_SUB+= OFX=""
+.else
+CONFIGURE_ARGS+=--disable-libofx
+PLIST_SUB+= OFX="@comment "
+.endif
+
+# no configure option to disable ktoblzcheck support (yet)
+.if defined(WITH_KTOBLZCHECK) || exists(${LOCALBASE}/lib/libktoblzcheck.so.1)
+LIB_DEPENDS+= ktoblzcheck.1:${PORTSDIR}/finance/ktoblzcheck
+.endif
+
+.include <bsd.port.post.mk>