aboutsummaryrefslogtreecommitdiff
path: root/finance/bitcoin-armory
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-02-04 13:37:15 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-02-04 13:37:15 +0000
commit4c7d30bb708caa0cb93b401f96679728a9f52974 (patch)
treed3572a824910587e038d1100b5972b19f37005aa /finance/bitcoin-armory
parentdbf5f956b89ab67ab031eafbe3508f2a7632ee42 (diff)
downloadports-4c7d30bb708caa0cb93b401f96679728a9f52974.tar.gz
ports-4c7d30bb708caa0cb93b401f96679728a9f52974.zip
Notes
Diffstat (limited to 'finance/bitcoin-armory')
-rw-r--r--finance/bitcoin-armory/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index c47797523259..d97686a29c5b 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -15,16 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:devel/swig30 \
${LOCALBASE}/bin/pyrcc4:textproc/py-qt4-xml \
${LOCALBASE}/bin/rsync:net/rsync
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:devel/py-qt4-core \
- ${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}twistedCore>=14.0.0:devel/py-twistedCore \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=14.0.0:devel/py-twistedCore \
${PYTHON_PKGNAMEPREFIX}psutil>1.2.1:sysutils/py-psutil \
${LOCALBASE}/bin/bitcoind:net-p2p/bitcoin-daemon
USE_GITHUB= yes
GH_ACCOUNT= etotheipi
-USES= compiler:c++11-lang compiler:c++11-lib gmake python:2 shebangfix
+USES= compiler:c++11-lang compiler:c++11-lib gmake pyqt:4 python:2 shebangfix
+USE_PYQT= core_run gui_run
SHEBANG_FILES= extras/extractKeysFromWallet.py
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib