aboutsummaryrefslogtreecommitdiff
path: root/finance/gnucash
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /finance/gnucash
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Notes
Diffstat (limited to 'finance/gnucash')
-rw-r--r--finance/gnucash/Makefile11
-rw-r--r--finance/gnucash/files/patch-configure18
-rw-r--r--finance/gnucash/files/patch-ltmain.sh28
-rw-r--r--finance/gnucash/files/patch-po::Makefile.in.in7
-rw-r--r--finance/gnucash/files/patch-src::gnome::Makefile.in14
5 files changed, 31 insertions, 47 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index b6acbed87844..85faa7a61fa5 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -35,9 +35,10 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_XPM= yes
USE_PERL5= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomeprint libglade gtkhtml libghttp
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -45,12 +46,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnc-prices.1 gnucash.1
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|[{]datadir[}]/gnome/|(datadir)/|g ; \
- s|[{]datadir[}]/aclocal|(prefix)/share/aclocal|g ; \
- s|[{]datadir[}]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/finance/gnucash/files/patch-configure b/finance/gnucash/files/patch-configure
index cb1f57af28a6..f5f7a504dc49 100644
--- a/finance/gnucash/files/patch-configure
+++ b/finance/gnucash/files/patch-configure
@@ -1,9 +1,17 @@
$FreeBSD$
---- configure.orig Thu Jan 10 12:57:53 2002
-+++ configure Thu Jan 10 12:59:14 2002
-@@ -9608,7 +9608,7 @@
+--- configure.orig Mon Mar 11 00:50:12 2002
++++ configure Thu Jul 11 11:16:21 2002
+@@ -5229,6 +5229,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -9608,7 +9609,7 @@
withval="$with_help_prefix"
GNC_HELPDIR="$with_help_prefix/gnome/help/gnucash"
else
@@ -12,7 +20,7 @@ $FreeBSD$
fi
-@@ -10128,7 +10128,7 @@
+@@ -10128,7 +10129,7 @@
if test "$prefer_db1" = "yes"; then
@@ -21,7 +29,7 @@ $FreeBSD$
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -10168,7 +10168,7 @@
+@@ -10168,7 +10169,7 @@
fi
done
diff --git a/finance/gnucash/files/patch-ltmain.sh b/finance/gnucash/files/patch-ltmain.sh
deleted file mode 100644
index 022bcf04f826..000000000000
--- a/finance/gnucash/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Mon Nov 12 01:53:44 2001
-+++ ltmain.sh Thu Jan 10 13:04:25 2002
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/finance/gnucash/files/patch-po::Makefile.in.in b/finance/gnucash/files/patch-po::Makefile.in.in
deleted file mode 100644
index 5586a26e17f2..000000000000
--- a/finance/gnucash/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- po/Makefile.in.in.orig Fri Apr 27 01:23:42 2001
-+++ po/Makefile.in.in Tue May 22 18:25:29 2001
-@@ -22,3 +22,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
diff --git a/finance/gnucash/files/patch-src::gnome::Makefile.in b/finance/gnucash/files/patch-src::gnome::Makefile.in
new file mode 100644
index 000000000000..2e9afd4bd045
--- /dev/null
+++ b/finance/gnucash/files/patch-src::gnome::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/gnome/Makefile.in 2002/07/11 09:16:01 1.1
++++ src/gnome/Makefile.in 2002/07/11 09:16:10
+@@ -226,7 +226,7 @@
+ window-report.c
+
+
+-gnomeappdir = ${datadir}/gnome/apps/Applications
++gnomeappdir = ${datadir}/apps/Applications
+
+ gnomeapp_DATA = gnucash.desktop
+