aboutsummaryrefslogtreecommitdiff
path: root/finance/grisbi/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-10-18 09:23:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-10-18 09:23:46 +0000
commit47f92c6d1c72b62d05aefffef26f52c581a5d76b (patch)
tree7915508109deaa7489e17f5743c7401395aa27a3 /finance/grisbi/Makefile
parentc9b65dc2dc946c8dcd99991c4b0719e613a4f1f4 (diff)
downloadports-47f92c6d1c72b62d05aefffef26f52c581a5d76b.tar.gz
ports-47f92c6d1c72b62d05aefffef26f52c581a5d76b.zip
Notes
Diffstat (limited to 'finance/grisbi/Makefile')
-rw-r--r--finance/grisbi/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 0437b6ac8f5c..84ec406c228b 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= grisbi
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,6 @@ RUN_DEPENDS= ${UCS_CLASSDIR}/ucs.sty:${PORTSDIR}/print/latex-ucs
.endif
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_GCC= 3.4
@@ -35,4 +34,21 @@ MAN1= grisbi.1
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(NOPORTDOCS)
+USE_REINPLACE= yes
+.endif
+
+pre-configure:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>