aboutsummaryrefslogtreecommitdiff
path: root/finance/libofx
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-20 10:00:24 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-20 10:00:24 +0000
commiteb06a64599e783d5f7e7c75b39789ff77c716b2c (patch)
tree2729a52d8b12e489bf2954a32d62fb88566f860a /finance/libofx
parent45ca7771107e81c333ce2c1b949ef408f062ea33 (diff)
downloadports-eb06a64599e783d5f7e7c75b39789ff77c716b2c.tar.gz
ports-eb06a64599e783d5f7e7c75b39789ff77c716b2c.zip
Notes
Diffstat (limited to 'finance/libofx')
-rw-r--r--finance/libofx/Makefile12
-rw-r--r--finance/libofx/files/patch-configure11
-rw-r--r--finance/libofx/files/patch-lib__ofx_preproc.cpp8
-rw-r--r--finance/libofx/pkg-plist6
4 files changed, 18 insertions, 19 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 1305a5f8b0d9..d5b77fada263 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libofx
PORTVERSION= 0.9.10
+PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= SF
@@ -22,21 +23,14 @@ CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+PORTDOCS= *
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= DOCS DOXYGEN
-
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-install:
${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
-.if ${PORT_OPTIONS:MDOXYGEN}
- @${FIND} -P ${STAGEDIR}${DOCSDIR}/html -type f 2>/dev/null | \
- ${SED} -ne 's|^${STAGEDIR}${PREFIX}/||p' >> ${TMPPLIST}
- @${FIND} -P -d ${STAGEDIR}${DOCSDIR}/ -type d -empty 2>/dev/null | \
- ${SED} -ne 's|^${STAGEDIR}${PREFIX}/|@dir |p' >> ${TMPPLIST}
-.endif
.include <bsd.port.mk>
diff --git a/finance/libofx/files/patch-configure b/finance/libofx/files/patch-configure
new file mode 100644
index 000000000000..2156020d6ed7
--- /dev/null
+++ b/finance/libofx/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-09-12 19:48:15 UTC
++++ configure
+@@ -3791,7 +3791,7 @@ $as_echo "#define HAVE_GCC_VISIBILITY_EX
+
+ VISIBILITY_FLAGS="-fvisibility=hidden"
+ CFLAGS="$VISIBILITY_FLAGS $CFLAGS"
+- CXXFLAGS="$VISIBILITY_FLAGS -fvisibility-inlines-hidden $CFLAGS"
++ CXXFLAGS="$VISIBILITY_FLAGS -fvisibility-inlines-hidden $CXXFLAGS"
+ fi
+
+ ## Pass -DIN_LIBOFX to the compiler so we can detect it and include config.h
diff --git a/finance/libofx/files/patch-lib__ofx_preproc.cpp b/finance/libofx/files/patch-lib__ofx_preproc.cpp
index 915fe2ed35c0..18a35c29e49b 100644
--- a/finance/libofx/files/patch-lib__ofx_preproc.cpp
+++ b/finance/libofx/files/patch-lib__ofx_preproc.cpp
@@ -1,11 +1,11 @@
---- ./lib/ofx_preproc.cpp.orig 2013-04-25 14:06:29.000000000 -0400
-+++ ./lib/ofx_preproc.cpp 2014-06-22 19:44:48.000000000 -0400
-@@ -310,7 +310,7 @@
+--- lib/ofx_preproc.cpp.orig 2014-09-12 19:26:30 UTC
++++ lib/ofx_preproc.cpp
+@@ -310,7 +310,7 @@ int ofx_proc_file(LibofxContextPtr ctx,
size_t outbytesleft = inbytesleft * 2 - 1;
iconv_buffer = (char*) malloc (inbytesleft * 2);
memset(iconv_buffer, 0, inbytesleft * 2);
-#if defined(OS_WIN32) || defined(__sun)
-+#if defined(OS_WIN32) || defined(__sun) || defined(__FreeBSD__)
++#if defined(__FreeBSD__) || defined(__DragonFly__)
const char * inchar = (const char *)s_buffer.c_str();
#else
char * inchar = (char *)s_buffer.c_str();
diff --git a/finance/libofx/pkg-plist b/finance/libofx/pkg-plist
index 1477f17d32bf..99d141685720 100644
--- a/finance/libofx/pkg-plist
+++ b/finance/libofx/pkg-plist
@@ -9,12 +9,6 @@ lib/libofx.so.6.0.0
libdata/pkgconfig/libofx.pc
man/man1/ofxconnect.1.gz
man/man1/ofxdump.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/totest.txt
%%DATADIR%%/dtd/ofc.dtd
%%DATADIR%%/dtd/ofx160.dtd
%%DATADIR%%/dtd/ofx201.dtd