aboutsummaryrefslogtreecommitdiff
path: root/finance/mybudget
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-07-05 04:26:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-07-05 04:26:49 +0000
commitbc3cef4c15e010db2d5689a9368730aab014dc60 (patch)
tree064ab37a44afe1f1a4edff17bcf2db3f9abdd21b /finance/mybudget
parent12806240d94f180a103582d2c0b418cf16a20661 (diff)
downloadports-bc3cef4c15e010db2d5689a9368730aab014dc60.tar.gz
ports-bc3cef4c15e010db2d5689a9368730aab014dc60.zip
Notes
Diffstat (limited to 'finance/mybudget')
-rw-r--r--finance/mybudget/Makefile23
-rw-r--r--finance/mybudget/distinfo2
-rw-r--r--finance/mybudget/pkg-descr27
-rw-r--r--finance/mybudget/pkg-plist52
4 files changed, 104 insertions, 0 deletions
diff --git a/finance/mybudget/Makefile b/finance/mybudget/Makefile
new file mode 100644
index 000000000000..8aa98d040cf8
--- /dev/null
+++ b/finance/mybudget/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: myBudget
+# Date created: 2004 05 July
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= myBudget
+PORTVERSION= 0.60
+CATEGORIES= finance gnome
+MASTER_SITES= http://www.abisource.com/~msevior/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gtk+-2 finance manager
+
+NO_BUILD= yes
+USE_PYTHON= yes
+USE_GNOME= pygnome2
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} ./install.py ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/finance/mybudget/distinfo b/finance/mybudget/distinfo
new file mode 100644
index 000000000000..647593c177cb
--- /dev/null
+++ b/finance/mybudget/distinfo
@@ -0,0 +1,2 @@
+MD5 (myBudget-0.60.tar.gz) = a7343a8a4359c8383f5cccedd735bc58
+SIZE (myBudget-0.60.tar.gz) = 1516083
diff --git a/finance/mybudget/pkg-descr b/finance/mybudget/pkg-descr
new file mode 100644
index 000000000000..c17fb954807d
--- /dev/null
+++ b/finance/mybudget/pkg-descr
@@ -0,0 +1,27 @@
+The aim of the program is to make it as easy as possible for people to
+do their own personal budgets and keep track of their finances. Using
+this program you can:
+
+ * Create a budget and organize budget items into categories.
+ * Nominate budget items to be paid from either a cash account or
+ via a "Direct Debit" account which allows you to save for big
+ ticket items and ensure timely payment of scheduled bills.
+ * Automatically calculates how much money you must put aside
+ each fortnight to meet all your "Direct Debit" obligations.
+ * Automatically tells you how much money you must have in Direct
+ Debit account to meet your obligatory payments on any
+ particular date.
+ * Record and save expenses against each of your budget categories.
+ * Track how your expenses relate to your budget so you can
+ determine if you are over or under-spending in any of your
+ categories.
+ * Sort your records into categories or by date.
+ * Comes with realistic example to show how things work.
+ * Allows you to export any of your reports, records, budget and
+ Direct Debit status to the Gnumeric Spreadsheet program where
+ they can be either printed or used for more detailed analysis.
+ * Allows you to export any of your reports, records, budget and
+ Direct Debit status to the AbiWord WordProcessor program where
+ they can be printed or incorporated into a report.
+
+WWW: http://www.abisource.com/~msevior/index.html
diff --git a/finance/mybudget/pkg-plist b/finance/mybudget/pkg-plist
new file mode 100644
index 000000000000..88628a3f28da
--- /dev/null
+++ b/finance/mybudget/pkg-plist
@@ -0,0 +1,52 @@
+bin/myBudget
+%%DATADIR%%/abiword_head.txt
+%%DATADIR%%/applications/myBudget.desktop
+%%DATADIR%%/docs/DirectDebitPane.png
+%%DATADIR%%/docs/ExportAbiWord.png
+%%DATADIR%%/docs/MyBudget.html
+%%DATADIR%%/docs/MyBudget.html_files/1.png
+%%DATADIR%%/docs/MyBudget.html_files/addButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/deleteButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/deleteButton_1.png
+%%DATADIR%%/docs/MyBudget.html_files/gnumericButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/gnumericButton_1.png
+%%DATADIR%%/docs/MyBudget.html_files/gnumericButton_2.png
+%%DATADIR%%/docs/MyBudget.html_files/myBudget-1_0.png
+%%DATADIR%%/docs/MyBudget.html_files/myBudget-2_0.png
+%%DATADIR%%/docs/MyBudget.html_files/mybudget-3_0.png
+%%DATADIR%%/docs/MyBudget.html_files/quitButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/replaceButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/replaceButton_1.png
+%%DATADIR%%/docs/MyBudget.html_files/sortCategoriesButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/sortDatesButton_0.png
+%%DATADIR%%/docs/MyBudget.html_files/sortItem_0.png
+%%DATADIR%%/docs/MyBudget.zabw
+%%DATADIR%%/docs/addButton.png
+%%DATADIR%%/docs/applyButton.png
+%%DATADIR%%/docs/deleteButton.png
+%%DATADIR%%/docs/gnumericButton.png
+%%DATADIR%%/docs/myBudget-1.png
+%%DATADIR%%/docs/myBudget-2.png
+%%DATADIR%%/docs/mybudget-3.png
+%%DATADIR%%/docs/quitButton.png
+%%DATADIR%%/docs/replaceButton.png
+%%DATADIR%%/docs/sortCategoriesButton.png
+%%DATADIR%%/docs/sortDatesButton.png
+%%DATADIR%%/docs/sortItem.png
+%%DATADIR%%/example.myb
+%%DATADIR%%/generic-budget.txt
+%%DATADIR%%/glade/icon.svg
+%%DATADIR%%/glade/mybudget.glade
+%%DATADIR%%/glade/mybudget.gladep
+%%DATADIR%%/gnumeric_foot.txt
+%%DATADIR%%/gnumeric_head.txt
+%%DATADIR%%/pixmaps/myBudget-icon.svg
+%%DATADIR%%/po/myBudget.po
+%%DATADIR%%/splashscreen.png
+@dirrm %%DATADIR%%/po
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/docs/MyBudget.html_files
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/applications
+@dirrm %%DATADIR%%