aboutsummaryrefslogtreecommitdiff
path: root/finance/openerp-server/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-09-06 23:08:36 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-09-06 23:08:36 +0000
commitce5d2946b19968af335247b0a3479b9bebe0582f (patch)
tree9b5c4252d9faf89bc1548c76797ee35e7c844a0b /finance/openerp-server/Makefile
parent7ddd5c11c03053809f0712f300c6c33e02a1bb32 (diff)
downloadports-ce5d2946b19968af335247b0a3479b9bebe0582f.tar.gz
ports-ce5d2946b19968af335247b0a3479b9bebe0582f.zip
Notes
Diffstat (limited to 'finance/openerp-server/Makefile')
-rw-r--r--finance/openerp-server/Makefile35
1 files changed, 29 insertions, 6 deletions
diff --git a/finance/openerp-server/Makefile b/finance/openerp-server/Makefile
index 8757ba5554f5..37c82978f46f 100644
--- a/finance/openerp-server/Makefile
+++ b/finance/openerp-server/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: openerp-server
-# Date created: 27 February 2009
-# Whom: Wen Heping<wenheping@gmail.com>
+# Date created: 27 February 2009
+# Whom: Wen Heping <wenheping@gmail.com>
#
# $FreeBSD$
#
PORTNAME= openerp-server
-PORTVERSION= 5.0.15
-PORTREVISION= 1
+PORTVERSION= 6.0.3
PORTEPOCH= 1
CATEGORIES= finance python
MASTER_SITES= http://www.openerp.com/download/stable/source/
@@ -25,8 +24,24 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imag
${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
+ ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
+ ${PYTHON_PKGNAMEPREFIX}chart>0:${PORTSDIR}/graphics/py-chart \
+ ${PYTHON_PKGNAMEPREFIX}pydot>0:${PORTSDIR}/graphics/py-pydot \
+ ${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RC_SUBR= openerpd
SUB_FILES= openerp-server.conf pkg-message
@@ -34,7 +49,11 @@ SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
-PYDISTUTILS_EGGINFO= openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
+PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
+PYDISTUTILS_EGGINFO= PKG-INFO
+
+USERS= openerpd
+GROUPS= openerpd
MAN1= openerp-server.1
MAN5= openerp_serverrc.5
@@ -70,6 +89,10 @@ post-install:
-type f | ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
@${FIND} -s -d ${PYTHON_SITELIBDIR}/${PORTNAME} \
-type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
+ @${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
+ -type f -print |grep -v PKG-INFO| ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
+ @${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
+ -type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}