aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Business-Stripe
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2012-12-18 15:20:39 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2012-12-18 15:20:39 +0000
commit36d179240da043a094a171b1549c7e47c1b6758c (patch)
tree3e0b0404d7aba61a473287998febf83b7f0be9fc /finance/p5-Business-Stripe
parent4796b52f1fcf836c58ba6db3ca61f510876280a8 (diff)
downloadports-36d179240da043a094a171b1549c7e47c1b6758c.tar.gz
ports-36d179240da043a094a171b1549c7e47c1b6758c.zip
Notes
Diffstat (limited to 'finance/p5-Business-Stripe')
-rw-r--r--finance/p5-Business-Stripe/Makefile24
-rw-r--r--finance/p5-Business-Stripe/distinfo2
-rw-r--r--finance/p5-Business-Stripe/pkg-descr4
-rw-r--r--finance/p5-Business-Stripe/pkg-plist6
4 files changed, 36 insertions, 0 deletions
diff --git a/finance/p5-Business-Stripe/Makefile b/finance/p5-Business-Stripe/Makefile
new file mode 100644
index 000000000000..803d5752de43
--- /dev/null
+++ b/finance/p5-Business-Stripe/Makefile
@@ -0,0 +1,24 @@
+# Created by: Vick Khera <vivek@khera.org>
+# $FreeBSD$
+
+PORTNAME= Business-Stripe
+PORTVERSION= 0.04
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Perl5 module interface for the Stripe.com payment system
+
+RUN_DEPENDS= p5-HTTP-Message>=0.0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-JSON>=0.0:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww>0.0:${PORTSDIR}/www/p5-libwww \
+ p5-MIME-Base64>=0.0:${PORTSDIR}/converters/p5-MIME-Base64
+
+WRKSRC= ${WRKDIR}/aquaron-Business-Stripe-c067843
+
+PERL_CONFIGURE= YES
+
+MAN3= Business::Stripe.3 Business::README.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-Stripe/distinfo b/finance/p5-Business-Stripe/distinfo
new file mode 100644
index 000000000000..5cf50e71f553
--- /dev/null
+++ b/finance/p5-Business-Stripe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Business-Stripe-0.04.tar.gz) = 340bddb22e3b4c6bb95f82f742a7726d7895908e2b4f8a0fef9fb03da1b2281d
+SIZE (Business-Stripe-0.04.tar.gz) = 6412
diff --git a/finance/p5-Business-Stripe/pkg-descr b/finance/p5-Business-Stripe/pkg-descr
new file mode 100644
index 000000000000..6baec06a8c99
--- /dev/null
+++ b/finance/p5-Business-Stripe/pkg-descr
@@ -0,0 +1,4 @@
+Provides common bindings for Stripe payment system. Any API calls that do not
+have bindings can be access through the generic api method.
+
+WWW: http://search.cpan.org/dist/Business-Stripe/
diff --git a/finance/p5-Business-Stripe/pkg-plist b/finance/p5-Business-Stripe/pkg-plist
new file mode 100644
index 000000000000..da21f18e33ad
--- /dev/null
+++ b/finance/p5-Business-Stripe/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Business/README.pod
+%%SITE_PERL%%/Business/Stripe.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Stripe/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Stripe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business
+@dirrmtry %%SITE_PERL%%/Business