aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Finance-Quote/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:48:35 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:48:35 +0000
commit441bdcd6a5240032827d0607153516fc663b914d (patch)
treef597b110a834b4275bd1099513f2f729c41a5bf2 /finance/p5-Finance-Quote/Makefile
parent3afad9b84d9ee11aae4e6d1400063bd1e0eabb5d (diff)
downloadports-441bdcd6a5240032827d0607153516fc663b914d.tar.gz
ports-441bdcd6a5240032827d0607153516fc663b914d.zip
Notes
Diffstat (limited to 'finance/p5-Finance-Quote/Makefile')
-rw-r--r--finance/p5-Finance-Quote/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/finance/p5-Finance-Quote/Makefile b/finance/p5-Finance-Quote/Makefile
new file mode 100644
index 000000000000..118a0c91f36d
--- /dev/null
+++ b/finance/p5-Finance-Quote/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Finance::Quote
+# Date created: 26 Dec 2000
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-Quote
+PORTVERSION= 1.04
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= yes
+
+MAN3= Finance::Quote::Tiaacref.3 Finance::Quote::Yahoo::Europe.3\
+ Finance::Quote.3 Finance::Quote::VWD.3\
+ Finance::Quote::Troweprice.3 Finance::Quote::Yahoo::Australia.3\
+ Finance::Quote::Yahoo::USA.3 Finance::Quote::Trustnet.3\
+ Finance::Quote::Yahoo::Base.3 Finance::Quote::Fidelity.3\
+ Finance::Quote::ASX.3 Finance::Quote::DWS.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>