aboutsummaryrefslogtreecommitdiff
path: root/finance/pfpro/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-14 02:55:46 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-14 02:55:46 +0000
commit3fb7a9de17fe02e22db8701b119e6a9445273062 (patch)
treef99915481b2184564930a444953d8be2f227809a /finance/pfpro/Makefile
parentb9410c5b8ddd36177a7a67275d5b2c549d08b3eb (diff)
downloadports-3fb7a9de17fe02e22db8701b119e6a9445273062.tar.gz
ports-3fb7a9de17fe02e22db8701b119e6a9445273062.zip
Notes
Diffstat (limited to 'finance/pfpro/Makefile')
-rw-r--r--finance/pfpro/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/finance/pfpro/Makefile b/finance/pfpro/Makefile
index 5dc0983cf44b..56f15e041bcb 100644
--- a/finance/pfpro/Makefile
+++ b/finance/pfpro/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pfpro
PORTVERSION= 3.0.8
+PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= #https://manager.verisign.com/
DISTNAME= pfpro_freebsd
@@ -15,8 +16,7 @@ MAINTAINER= durian@shadetreesoftware.com
COMMENT= SDK for VeriSign's PayFlow Pro
ONLY_FOR_ARCHS= i386
-RESTRICTED= "Only for VeriSign PayFlow Pro customers"
-NO_BUILD= yes
+RESTRICTED= Only for VeriSign PayFlow Pro customers
INSTALLS_SHLIB= yes
NO_WRKSUBDIR= yes
SUB_FILES= pkg-message
@@ -25,8 +25,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
LATEST_LINK= verisign-pfpro
CERTDIR= ${PREFIX}/certs
-
FBSDDIR= ${WRKSRC}/verisign/payflowpro/freebsd
+PFCFLAGS= -DUSE_SSLEAY -fPIC -DFREEBSD_OS -DGENERIC_SEED -D_REENTRANT -pthread -DPTHREADS -I. -L.
# XXX nees to be the same as DISTFILES
PFP_BUNDLE= ${DISTNAME}${EXTRACT_SUFX}
@@ -36,7 +36,7 @@ PFP_BUNDLE= ${DISTNAME}${EXTRACT_SUFX}
# Check for SDK bundle
.if !exists(${DISTDIR}/${PFP_BUNDLE})
ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
+IGNORE= :\n\
The VeriSign PayFlow Pro SDK is only available to customers who have\n\
subscribed to this service. Please access your account at\n\
https://manager.verisign.com/ and retrieve the FreeBSD 5.x version\n\
@@ -45,9 +45,11 @@ some terms and conditions. After downing the SDK, place ${PFP_BUNDLE}\n\
in ${DISTDIR}.\n
.endif
+do-build:
+ (cd ${FBSDDIR}/lib && ${CC} ${PFCFLAGS} ${CFLAGS} -c ../bin/${PORTNAME}.c -o ${PORTNAME}.o && ${CC} ${PFCFLAGS} ${CFLAGS} -lpfpro ${PORTNAME}.o -o ${PORTNAME})
+
do-install:
- ${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${FBSDDIR}/bin/pfpro-file ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${FBSDDIR}/lib/pfpro ${PREFIX}/bin
${INSTALL_DATA} ${FBSDDIR}/lib/pfpro.h ${PREFIX}/include
${INSTALL_DATA} ${FBSDDIR}/lib/libpfpro.so ${PREFIX}/lib
${MKDIR} ${CERTDIR}