aboutsummaryrefslogtreecommitdiff
path: root/finance/qhacc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-12 18:04:27 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-12 18:04:27 +0000
commit0bb2417319bda720d6a045ecb4f0fbe0505236e4 (patch)
tree3fb85b81debdfc2c4dbc35bbc6c12beeb32dfc9b /finance/qhacc
parent931968845043047af748ffe1f01ff4bc42e76a54 (diff)
downloadports-0bb2417319bda720d6a045ecb4f0fbe0505236e4.tar.gz
ports-0bb2417319bda720d6a045ecb4f0fbe0505236e4.zip
Notes
Diffstat (limited to 'finance/qhacc')
-rw-r--r--finance/qhacc/Makefile35
-rw-r--r--finance/qhacc/distinfo2
-rw-r--r--finance/qhacc/files/config6
-rw-r--r--finance/qhacc/files/patch-ltmain.sh15
-rw-r--r--finance/qhacc/files/patch-src::main.cpp10
-rw-r--r--finance/qhacc/files/patch-src::qhacctable.h15
-rw-r--r--finance/qhacc/pkg-message10
-rw-r--r--finance/qhacc/pkg-plist75
8 files changed, 101 insertions, 67 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index 78ed5c8d54f6..4b1fb5e58873 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qhacc
-PORTVERSION= 2.6.1
+PORTVERSION= 2.9
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,32 +14,39 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple QT-based financial manager
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
USE_QT_VER= 3
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
+CONFIGURE_ARGS= --enable-mysql=no \
+ --with-qt-moc=${QT_PREFIX}/bin \
--with-qt-libs=${QT_PREFIX}/lib
+INSTALLS_SHLIB= yes
-post-extract:
- @${RM} -f ${WRKSRC}/src/moc_*.cpp
+STRIP= # none
-pre-patch:
+post-patch:
@${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|#! /bin/sh|#!${LOCALBASE}/bin/bash|g ; \
+ s|/usr/local/|${PREFIX}/lib/|g' ${WRKSRC}/src/qhacc.orig
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^CXXFLAGS =.*$$|CXXFLAGS = \@CXXFLAGS\@|g'
+ 's|-O2 -Wall -g||g ; \
+ s|contrib docs qm|contrib|g ; \
+ s|$$(prefix)/plugins|$$(pkglibdir)/plugins|g'
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/qhacc ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/qm/*.qm ${DATADIR}
- ${INSTALL_DATA} ${FILESDIR}/config ${DATADIR}/config.sample
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/qhacc-*
+.for file in accounts memorized preferences transactions
+ ${INSTALL_DATA} ${WRKSRC}/contrib/easysetup/${file} ${PREFIX}/lib/qhacc
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/qm/*.qm ${PREFIX}/lib/qhacc
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
.endif
- @${SED} -e "s:/usr/X11R6:${PREFIX}:g" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/finance/qhacc/distinfo b/finance/qhacc/distinfo
index c2d0a02e42ce..dc8451ca1033 100644
--- a/finance/qhacc/distinfo
+++ b/finance/qhacc/distinfo
@@ -1 +1 @@
-MD5 (qhacc-2.6.1.tar.gz) = 6b61a2c428106bde00d833b27a3c548c
+MD5 (qhacc-2.9.tar.gz) = 5df88c785d1f30cd60592eabeda4467c
diff --git a/finance/qhacc/files/config b/finance/qhacc/files/config
deleted file mode 100644
index 9f6bed1d2f5d..000000000000
--- a/finance/qhacc/files/config
+++ /dev/null
@@ -1,6 +0,0 @@
-ALTCOLOR=173 216 230
-LINESPERTRANS=1
-NUMACCTS=0
-NUMSHOWS=0
-SHOWINDEX=-1
-ACCTFILES=
diff --git a/finance/qhacc/files/patch-ltmain.sh b/finance/qhacc/files/patch-ltmain.sh
new file mode 100644
index 000000000000..9be482bc72a2
--- /dev/null
+++ b/finance/qhacc/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Mar 13 01:25:30 2003
++++ ltmain.sh Tue Aug 12 01:49:52 2003
+@@ -4210,10 +4210,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/finance/qhacc/files/patch-src::main.cpp b/finance/qhacc/files/patch-src::main.cpp
deleted file mode 100644
index 99ffb4f458df..000000000000
--- a/finance/qhacc/files/patch-src::main.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/main.cpp.orig Thu Jan 2 02:42:35 2003
-+++ src/main.cpp Wed Jan 8 04:51:12 2003
-@@ -26,7 +26,6 @@
- #include "qhaccwidget.h"
-
- #include <stdlib.h>
--#include <getopt.h>
- #include <locale.h>
-
- #include <qapplication.h>
diff --git a/finance/qhacc/files/patch-src::qhacctable.h b/finance/qhacc/files/patch-src::qhacctable.h
deleted file mode 100644
index ff5282b99d1a..000000000000
--- a/finance/qhacc/files/patch-src::qhacctable.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/qhacctable.h.orig Sun Nov 24 19:22:27 2002
-+++ src/qhacctable.h Sun Nov 24 19:26:03 2002
-@@ -26,9 +26,10 @@
- #include <qstring.h>
- #include <qdatetime.h>
-
--class QFile;
-+#include <fstream>
-+using std::ostream;
-
--class ostream;
-+class QFile;
-
- class QHaccTableIndex;
-
diff --git a/finance/qhacc/pkg-message b/finance/qhacc/pkg-message
deleted file mode 100644
index 8c0ab62f5892..000000000000
--- a/finance/qhacc/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-************************************************************
- Before running QHacc, users should prepare as follows:
-
- $ mkdir ~/.qhacc
- $ cp /usr/X11R6/share/qhacc/config.sample ~/.qhacc/config
- $ chmod u+rw ~/.qhacc/config
- $ export QHACC_HOME=~/.qhacc (sh or bash)
- $ setenv QHACC_HOME ~/.qhacc (csh or tcsh)
-
-************************************************************
diff --git a/finance/qhacc/pkg-plist b/finance/qhacc/pkg-plist
index bbed25856c5a..7aa75b211a24 100644
--- a/finance/qhacc/pkg-plist
+++ b/finance/qhacc/pkg-plist
@@ -1,12 +1,65 @@
bin/qhacc
-%%PORTDOCS%%share/doc/qhacc/compiling.html
-%%PORTDOCS%%share/doc/qhacc/index.html
-%%PORTDOCS%%share/doc/qhacc/intro.html
-%%PORTDOCS%%share/doc/qhacc/faq.html
-%%PORTDOCS%%share/doc/qhacc/formats.html
-%%PORTDOCS%%share/doc/qhacc/using.html
-%%PORTDOCS%%share/doc/qhacc/primer.html
-share/qhacc/config.sample
-share/qhacc/qhacc_es_ES.qm
-@dirrm share/qhacc
-%%PORTDOCS%%@dirrm share/doc/qhacc
+bin/qhacc-cli
+bin/qhacc-gui
+include/localfileplugin.h
+include/plugins.h
+include/qhacc.h
+include/qhaccconstants.h
+include/qhaccext.h
+include/qhaccsegmenter.h
+include/qhacctable.h
+include/qhacctablerows.h
+include/qhaccutils.h
+include/resultset.h
+include/sqldbplugin.h
+lib/libcliimpio.a
+lib/libcliimpio.so
+lib/libcliimpio.so.1
+lib/libcronio.a
+lib/libcronio.so
+lib/libcronio.so.1
+lib/libfiledbio.a
+lib/libfiledbio.so
+lib/libfiledbio.so.2
+lib/libforeigndbio.a
+lib/libforeigndbio.so
+lib/libforeigndbio.so.2
+lib/libnativedbio.a
+lib/libnativedbio.so
+lib/libnativedbio.so.2
+lib/libqhacc.a
+lib/libqhacc.so
+lib/libqhacc.so.2
+lib/libqhaccext.a
+lib/libqhaccext.so
+lib/libqhaccext.so.2
+lib/libqifio.a
+lib/libqifio.so
+lib/libqifio.so.1
+lib/libxmlio.a
+lib/libxmlio.so
+lib/libxmlio.so.1
+lib/qhacc/accounts
+lib/qhacc/memorized
+lib/qhacc/plugins/db/libxmlio.so
+lib/qhacc/plugins/export/libxmlio.so
+lib/qhacc/plugins/import/libcliimpio.so
+lib/qhacc/plugins/import/libcronio.so
+lib/qhacc/plugins/import/libqifio.so
+lib/qhacc/plugins/import/libxmlio.so
+lib/qhacc/preferences
+lib/qhacc/qhacc_es_ES.qm
+lib/qhacc/transactions
+%%PORTDOCS%%%%DOCSDIR%%/compiling.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/formats.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/primer.html
+%%PORTDOCS%%%%DOCSDIR%%/using.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/qhacc/plugins/import
+@dirrm lib/qhacc/plugins/export
+@dirrm lib/qhacc/plugins/db
+@dirrm lib/qhacc/plugins
+@dirrm lib/qhacc