aboutsummaryrefslogtreecommitdiff
path: root/finance/qhacc
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-07-15 16:47:45 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-07-15 16:47:45 +0000
commite6246d1055202098dd1df8f2a827665d39dddde8 (patch)
tree6a8029cf8aa42fc328c40fc63ed5d1ae25d0c255 /finance/qhacc
parenta7000e3a390271ff985d84e575f89d8239e49aa7 (diff)
Notes
Diffstat (limited to 'finance/qhacc')
-rw-r--r--finance/qhacc/Makefile4
-rw-r--r--finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp10
2 files changed, 12 insertions, 2 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index c3d83a5d74b7..caeb09e3a70d 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qhacc
PORTVERSION= 3.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= finance
MASTER_SITES= SF
@@ -56,7 +56,7 @@ PLIST_SUB+= SQLITE="@comment "
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+= --enable-gpg
PLIST_SUB+= GPGME=""
.else
diff --git a/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp b/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp
new file mode 100644
index 000000000000..ce4133454c49
--- /dev/null
+++ b/finance/qhacc/files/patch-plugins::gpg::gpgplugin.cpp
@@ -0,0 +1,10 @@
+--- ./plugins/gpg/gpgplugin.cpp.orig 2009-06-30 00:55:33.000000000 -0400
++++ ./plugins/gpg/gpgplugin.cpp 2009-06-30 00:59:33.000000000 -0400
+@@ -56,6 +56,7 @@
+ const PluginInfo& GPGDBPlugin::info() const { return pinfo; }
+
+ bool GPGDBPlugin::iconnect( QHacc *, const QString&, QString& error ){
++ gpgme_check_version( NULL );
+ madectx=( GPG_ERR_NO_ERROR==gpgme_new( &gpgctx ) );
+ if( madectx ){
+ gpgme_set_passphrase_cb( gpgctx, GPGDBPlugin::passphrase_cb,