aboutsummaryrefslogtreecommitdiff
path: root/finance/quantlib/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2019-03-05 21:36:27 +0000
committerMikhail Teterin <mi@FreeBSD.org>2019-03-05 21:36:27 +0000
commiteb4180764f0847aaa88d25981f58c78c9b13f22c (patch)
tree8c91b5d3b9d12572e30f2175b9067f3b1d84246b /finance/quantlib/Makefile
parent630fe1e7af38b5f93f4fb31f8e0da4e77d118f97 (diff)
Upgrade from 1.13 to 1.15.
PR: 233864 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=494745
Diffstat (limited to 'finance/quantlib/Makefile')
-rw-r--r--finance/quantlib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 5d0b497d325a..d1fe78d83ba2 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quantlib
-PORTVERSION= 1.13
-PORTREVISION= 4
+PORTVERSION= 1.15
CATEGORIES= finance math devel
MASTER_SITES= https://dl.bintray.com/${PORTNAME}/releases/
DISTNAME= QuantLib-${PORTVERSION}
@@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= compiler
+USES= compiler libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= EMACS=no
@@ -60,4 +59,6 @@ OPENMP_LDFLAGS= -L${LOCALBASE}/lib
# one too:
OPENMP_LDFLAGS+= -L${LOCALBASE}/llvm${COMPILER_VERSION}/lib
+CXXFLAGS_i386= -DBOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS
+
.include <bsd.port.mk>