aboutsummaryrefslogtreecommitdiff
path: root/finance/skrooge/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-12-26 22:09:55 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-12-26 22:09:55 +0000
commitc9ed991044db73436663715b23bd89b91f9b0128 (patch)
tree0643eee639f30337a6417e451caf5ac6cf2ef442 /finance/skrooge/Makefile
parent0857284d5046e8145e0ac4e4d45dc5f5bb355935 (diff)
downloadports-c9ed991044db73436663715b23bd89b91f9b0128.tar.gz
ports-c9ed991044db73436663715b23bd89b91f9b0128.zip
Notes
Diffstat (limited to 'finance/skrooge/Makefile')
-rw-r--r--finance/skrooge/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index c3b3b6b4d0bc..e10027ff1e1a 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= skrooge
-PORTVERSION= 2.9.0
+DISTVERSION= 2.10.5
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -18,8 +18,8 @@ LIB_DEPENDS= libofx.so:finance/libofx \
libsqlcipher.so:databases/sqlcipher
USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
- gettext grantlee:5 kde:5 pkgconfig shared-mime-info \
- sqlite:3 tar:xz
+ gettext grantlee:5 kde:5 pkgconfig python:3.4+ shared-mime-info \
+ shebangfix sqlite:3 tar:xz
USE_KDE= activities archive attica5 auth bookmarks codecs completion \
config configwidgets coreaddons crash dbusaddons \
designerplugin doctools ecm emoticons guiaddons i18n \
@@ -31,6 +31,8 @@ USE_KDE= activities archive attica5 auth bookmarks codecs completion \
USE_QT5= concurrent core dbus designer gui network printsupport qml \
quick script sql svg webkit widgets xml \
qmake_build buildtools_build
+SHEBANG_FILES= plugins/import/skrooge_import_backend/skrooge-sabb.py \
+ skgbankmodeler/skrooge-yahoodl.py
USE_LDCONFIG= yes